Jump to content

Recommended Posts

Neither of the last two nightlies will launch. What is causing that? It's happening all the time lately. With some of the recent ones when there were two files and you said, "Try this one first and if it doesn't launch try this other one," it was always the second one that worked for me. Is it a Windows thing? I'm still on Win7.

Share this post


Link to post
Share on other sites

The latest few nightlies won't start for me either, but the 380-fomod-support and dev branches both start just fine.  Here is the BugDump log. 

Traceback (most recent call last):
  File "Wrye Bash Launcher.pyw", line 89, in <module>
    bash.main(opts)
  File "bash\bash.py", line 204, in main
    wx_locale = localize.setup_locale(opts.language, _wx)
  File "bash\localize.py", line 89, in setup_locale
    target_name, target_locale.GetCanonicalName()))
  File "bash\bolt.py", line 1666, in deprint
    msg = u'%s %4d %s: ' % (GPath(file_).tail.s, line, function)
  File "bash\bolt.py", line 322, in GPath
    else: norm = os.path.normpath(decode(name))
  File "bash\bolt.py", line 126, in decode
    encoding,confidence = getbestencoding(byte_str)
  File "bash\bolt.py", line 107, in getbestencoding
    result = chardet.detect(bitstream)
AttributeError: 'module' object has no attribute 'detect'
 

Share this post


Link to post
Share on other sites

@Tanker1985 Try deleting loot.dll. We removed the second build to get some feedback on an experimental change that seems to have fixed the loot issue for Win10 users, but apparently Win7 users still experience it.
@Verayth If you're using the Python version, you need to make sure to always synchronize your dependencies when you grab a new version. Use something like this to do it (substituting PATH_TO_PYTHON for your python path, obviously):

PATH_TO_PYTHON\python.exe -m pip install -U -r requirements.txt

 

Share this post


Link to post
Share on other sites

@Infernio I upgraded the requirements, but still get the same crash trying to run the latest python nightly.  Here is the upgrade log:

Spoiler

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting https://bintray.com/loot/snapshots/download_file?file_path=loot_api_python-4.0.2-7-g580bf87_master-python2.7-win32.zip (from -r requirements.txt (line 8))
  Downloading https://bintray.com/loot/snapshots/download_file?file_path=loot_api_python-4.0.2-7-g580bf87_master-python2.7-win32.zip (5.3MB)
     |UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU| 5.3MB 1.9MB/s
Requirement already up-to-date: chardet~=3.0 in c:\dev\python27\lib\site-packages (from -r requirements.txt (line 2)) (3.0.4)
Requirement already up-to-date: pywin32<225,>=220 in c:\dev\python27\lib\site-packages (from -r requirements.txt (line 3)) (224)
Collecting wxPython==3.0.2.0
  Using cached https://github.com/wrye-bash/dev-tools/raw/master/wheels/wxPython-3.0.2.0-cp27-cp27m-win32.whl
Requirement already up-to-date: scandir~=1.9 in c:\dev\python27\lib\site-packages (from -r requirements.txt (line 6)) (1.10.0)
Requirement already up-to-date: pygit2~=0.28 in c:\dev\python27\lib\site-packages (from -r requirements.txt (line 9)) (0.28.2)
Requirement already up-to-date: pyfiglet~=0.8 in c:\dev\python27\lib\site-packages (from -r requirements.txt (line 10)) (0.8.post1)
Collecting py2exe==0.6.9
  Using cached https://github.com/wrye-bash/dev-tools/raw/master/wheels/py2exe-0.6.9-cp27-cp27m-win32.whl
Requirement already satisfied, skipping upgrade: cffi in c:\dev\python27\lib\site-packages (from pygit2~=0.28->-r requirements.txt (line 9)) (1.13.2)
Requirement already satisfied, skipping upgrade: six in c:\dev\python27\lib\site-packages (from pygit2~=0.28->-r requirements.txt (line 9)) (1.13.0)
Requirement already satisfied, skipping upgrade: pycparser in c:\dev\python27\lib\site-packages (from cffi->pygit2~=0.28->-r requirements.txt (line 9)) (2.19)
Installing collected packages: wxPython, py2exe, loot-api
  Found existing installation: wxPython 3.0.2.0
    Uninstalling wxPython-3.0.2.0:
      Successfully uninstalled wxPython-3.0.2.0
  Found existing installation: py2exe 0.6.9
    Uninstalling py2exe-0.6.9:
      Successfully uninstalled py2exe-0.6.9
  Found existing installation: loot-api 4.0.2
    Uninstalling loot-api-4.0.2:
      Successfully uninstalled loot-api-4.0.2
    Running setup.py install for loot-api ... done
Successfully installed loot-api-4.0.2 py2exe-0.6.9 wxPython-3.0.2.0
 

 

Share this post


Link to post
Share on other sites

Removing loot.dll gave me:

Error! Unable to start Wrye Bash.


Please ensure Wrye Bash is correctly installed.


Traceback (most recent call last):
  File "bash\bash.pyo", line 285, in _main
  File "zipextimporter.pyo", line 82, in load_module
  File "bash\bosh\__init__.pyo", line 46, in <module>
  File "zipextimporter.pyo", line 82, in load_module
  File "bash\bosh\mods_metadata.pyo", line 28, in <module>
  File "zipextimporter.pyo", line 98, in load_module
ImportError: MemoryLoadLibrary failed loading loot_api.pyd
 

 

Share this post


Link to post
Share on other sites

@Verayth Are you using git or the source download? Make sure that your Python version no longer contains a 'chardet' folder, even if it's only .pyc files, otherwise Python might still try to use it.
@Tanker1985 Huh, removing loot.dll shouldn't *crash*. LOOT stuff just shouldn't work. I'll forward it to Ganda.

Share this post


Link to post
Share on other sites

@Infernio Thank you, that fixed it!  I'm using git, and GITK to choose the branch.  Guess I'll be doing a git clean after every branch switch from now on.  Coming from Java, I didn't realize I needed to.

git -C %REPO% clean -fdx Mopy/bash

 

Share this post


Link to post
Share on other sites
On 11/19/2019 at 2:55 PM, Infernio said:

@Tanker1985 Could you try the latest nightly? We've changed to using PyInstaller to build nightlies now, which *should* fix the LOOT crash.

I'm just seeing this on the 23rd and tried 201911230448. Same result. Wouldn't launch with loot.dll, instant crash with the same error message without it.

The one that I keep reverting to is 201910221723. I also consider that the solution will be Win10, which will mean a new machine. Which I need anyway, but I'm about a year from being able to do that, I think.

Share this post


Link to post
Share on other sites

Traceback (most recent call last):
  File "bash\bash.pyo", line 188, in main
  File "bash\bash.pyo", line 372, in _main
  File "bash\basher\__init__.pyo", line 4050, in Init
  File "bash\basher\__init__.pyo", line 4087, in InitData
  File "bash\bosh\__init__.pyo", line 1936, in refresh
  File "bash\bosh\__init__.pyo", line 1683, in _modinfos_cache_wrapper
  File "bash\bosh\__init__.pyo", line 1791, in refreshLoadOrder
  File "bash\load_order.pyo", line 303, in refresh_lo
  File "bash\load_order.pyo", line 253, in _update_cache
  File "bash\games.pyo", line 228, in get_load_order
  File "bash\games.pyo", line 247, in _cached_or_fetch
  File "bash\games.pyo", line 685, in _fetch_load_order
KeyError: bolt.Path(u'wolf people home.esp')

this is what it does when i open it

got it it was my fault i deleted my master file by mistake.

Share this post


Link to post
Share on other sites

I got an error with Sharlikran's. Actually I had also tried an earlier one of his that I saw on the Discord last week, but it wouldn't launch. I'm done here. It's obvious that this program has hit a wall on my machine, for whatever reasons, so I'll just keep the version that I have that works until I can upgrade to Windows 10. Thanks for the continued work. I probably wouldn't mod Skyrim at all if my choices were only Vortex or MO.

Share this post


Link to post
Share on other sites

I'm using the Beta4 version currently available from Nexus.  When I have 254 normal plugins enabled, I am unable to activate any ESL-flagged plugins.  I get the error "Skyrim.esm: Trying to activate more than 254 espms".  I have to disable a normal plugin, activate the ESL, then I can re-activate the normal plugin.  Seems to be tripping over the file extension before it recognizes it as being flagged ESL.

Share this post


Link to post
Share on other sites

You need to avoid trying to activate that many. The game can only support 253, not 254, because 2 slots are reserved: FE for engine mapping the ESL forms, and FF because it belongs to the save game. Forcing it to accept a standard mod in the FE slot is going to lead to save corruption.

Share this post


Link to post
Share on other sites

Nah, you can have 254 mods, that's FD in hex. The save game uses FF (256) and ESLs use FE (255). And I can confirm the bug report above, you do indeed get an error if you try to activate an ESL with 254 mods. Will look into it.

Share this post


Link to post
Share on other sites

Wouldn't that be assuming then that Skyrim.esm is 01 instead of 00? Cause if you check form IDs in the game, FF is definitely the save game and that translates to 255 in decimal.

Share this post


Link to post
Share on other sites
11 hours ago, Infernio said:

FF is 255, but indices begin at 00, so it's 255 + 1 = 256. Including the savegame and ESL slots, you have 256 mod indices.

Let's see if i understand. 

Base game ESM is in slot 00.

ESL files are slot FE.

The savegame is slot FF. 

That's three (00, FE and FF) of the 256 slots taken up, leaving 253 slots for everything else (additional Mod ESP files and DSL ESM files). 

So I guess I do not understand how there are 254 slots for mods. 

Share this post


Link to post
Share on other sites

Yes, I know indices begin at 00, they also end at FF, and saying you can use slot 254 (FE) is not correct for SSE or FO4 because that slot is reserved for the ESL form mapping in-game.

@The Black Swan For purposes of Fallout 4, obviously 00 and FF are reserved for required files. So no, you can't actually have 254 mods installed because 2 slots are reserved. With SSE it's even lower, because SSE requires 5 official masters, reducing the max count to 249, not 255. It's an issue I've tried several times to get people to clarify but they won't, insisting they have better information than the observable facts. And no, before someone else tries to imply it, I am NOT accusing the Wrye Bash team of such ignorance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

Patreon
×
×
  • Create New...