Jump to content

Wrye Bash - All Games


Utumno

Recommended Posts

@alt3rn1ty You need to put the BCF into "Bash Installers\Bain Converters\" in order for Wrye Bash to pick it up.

It's a good thing that you encountered that though because it means we need to document it better. I'll update my post above.

EDIT: After reading your post I was reminded that Embedded BCFs were a thing. Maybe I can do something with those hmm. :devil:

Link to comment
Share on other sites

:)  Its certainly been a while since I used BCFs :facepalm: ..

 

Now the pluggy bcf worked fine, and no issues in the bugdump using it

 

Wrye Bash starting
Using Wrye Bash Version 307.201707092223 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Oblivion found in parent directory of Mopy:  e:\Oblivion
bush.pyo  170 __setGame:  Using Oblivion game: e:\Oblivion
testing UAC
mods_metadata.pyo  224 __init__: Using LOOT API version: 0.10.2

Link to comment
Share on other sites

Immersive Citizens now has a shiny knew Wizard courtesy of a flawless BCF ..

0000.png

 

Wrye Bash starting
Using Wrye Bash Version 307.201707092223 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Skyrim Special Edition found in parent directory of Mopy:  D:\Steam\steamapps\Common\Skyrim Special Edition
bush.pyo  170 __setGame:  Using Skyrim Special Edition game: D:\Steam\steamapps\Common\Skyrim Special Edition
testing UAC
mods_metadata.pyo  224 __init__: Using LOOT API version: 0.10.2

Link to comment
Share on other sites

.. And lastly the Fallout 4 BCFs .. No problems creating them

Though I think @Beermotor ( or maybe @Utumno ) you have a problem with an image type in the armour one

(Reference this post and the files for Fallout 4)

 

0000.png

000.png

 

Wrye Bash starting
Using Wrye Bash Version 307.201707092223 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Fallout4 found in parent directory of Mopy:  D:\Steam\steamapps\Common\Fallout 4
bush.pyo  170 __setGame:  Using Fallout4 game: D:\Steam\steamapps\Common\Fallout 4
testing UAC
mods_metadata.pyo  224 __init__: Using LOOT API version: 0.10.2
installer_links.pyo  334 _get_size_and_pos: Saved Wizard position ((-1, -1)) was not a tuple (<class 'wx._core.Point'>), reverting to default position.

Link to comment
Share on other sites

It looks like there may be more to the "No image handler" thing than just wizards without images, because the True Storms and Immersive Citizens ones have images pulled from the FOMOD resources.  Unfortunately I'm at work and can't test..

@alt3rn1ty could you try to extract one of those BCF-built packages to see if anything got munged in the wizard.txt during the BCF creation please?

Edit: disregard, you're at work too :P  I guess I'll test it today a bit after 3PM CDT.

Link to comment
Share on other sites

6 hours ago, Beermotor said:

Edit: disregard, you're at work too :P  I guess I'll test it today a bit after 3PM CDT.

I was / still am - But while no-one is looking ..

I just added a bit to the sticky posts on nexus, because I think a crowd of pitch forks has potential to gather on the issue of merged patch offering to disable plugins, and resources from BSAs no longer being used because of it. Added it to the second sticky post so as to try and minimise the amount of space taken by sticky posts .. Will drop it on release of the next beta (if detecting BSA / BA2 on merge is implemented). I also mentioned about Auto-ghosting will be getting dropped for Skyrim / SSE / FO4 too, pointing them at the new image uploaded. Will be back home tomorrow morning and after turning a machine gun loose on my garden to try and win the summer war there, will get back to testing stuff later.

Link to comment
Share on other sites

10 hours ago, Beermotor said:

It looks like there may be more to the "No image handler" thing than just wizards without images, because the True Storms and Immersive Citizens ones have images pulled from the FOMOD resources.  Unfortunately I'm at work and can't test.

ok I'm home now and did a round of testing.

Scenario 1: newly created zipped package created from BCF - Images are in FOMOD folder inside the zip: Wizard loads no images, but no "no image handler" error.

Scenario 2: unzip the above package (manually, WB will not unpack it): images appear in Wizard, no errors.

Scenario 3: Repackaged Donor complex BAIN moving images from "FOMOD\\images\" to "Wizard Images" folder. Updated image paths in wizard.txt. Created new BCF. BCF produced zip package installs without images in wizard.

There is no traceback or anything in the BashBugDump.log in any of the scenarios.

 

Link to comment
Share on other sites

@Utumno We have someone on Skyrim LE nexus gave a bugdump, but no apparent errors.

He / She has transferred files and setup across from an old computer to a new one in an attempt to continue on the new machine with little fuss

But now finds when clicking on the Installers Tab, he cant get the Installers Tab to show

I made a few suggestions here (this is a continuation of a previous conversation string of posts, so probaably better to read back on the Wrye Bash Nexus page comments instead of the forum duplicate)

Can you think of anything else maybe going wrong there in case the response is not positive ?

 

EDIT : Scratch the above, my suggestions worked, he had copied across old .dat files from the old computer trying to preserve as much of the setup as possible which gave him problems on the new computer = Solved

Link to comment
Share on other sites

Also @Utumno Gameduchess on Skyrim SE Nexus has a problem that Wrye Bash for SSE stops her trying to build a bashed patch for load orders with more than 255 plugins (even though once completed and auto deselected merged plugins this limit would not be reached on completion of building the bashed patch)

I dont know what to suggest, its not a scenario I will ever end up in - This post

It also sounds like it is unique to Skyrim SE Wrye Bash, because a similar circumstance on Skyrim LE (possibly older versions of Wrye Bash) would allow building the Bashed Patch.

GameDuchess appears to be reluctant to produce a bashbugdump so far, so I'm not going to push for one again, its in the sticky, and I just mentioned you would need one in the post prior to the post linked. :shrug:

Link to comment
Share on other sites

I reproduced Gameduchess problem by copying a heap of plugins

BAshBugDump.log

Wrye Bash starting
Using Wrye Bash Version 307.201707092223 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Skyrim Special Edition found in parent directory of Mopy:  D:\Steam\steamapps\Common\Skyrim Special Edition
bush.pyo  170 __setGame:  Using Skyrim Special Edition game: D:\Steam\steamapps\Common\Skyrim Special Edition
testing UAC
mods_metadata.pyo  224 __init__: Using LOOT API version: 0.10.2
games.pyo  157 warn_lo: Fixed Load Order: added(DesyncBirdsOfPrey - Copy (7).esp, DesyncBirdsOfPrey - Copy (4).esp, DesyncBirdsOfPrey - Copy (11).esp, DesyncBirdsOfPrey - Copy (2).esp, DesyncBirdsOfPrey - Copy (3).esp, DesyncBirdsOfPrey - Copy (6).esp, DesyncBirdsOfPrey - Copy (5).esp, DesyncBirdsOfPrey - Copy.esp, DesyncBirdsOfPrey - Copy (9).esp, DesyncBirdsOfPrey - Copy (10).esp, DesyncBirdsOfPrey - Copy (8).esp), removed(None), reordered (No)

 

0000.png

 

One of Wrye Bash traditional strengths is to take you beyond 255 plugins by having the ability to fully merge them .. That error stops you selecting more of them, so you will never be able to exceed the plugin limit.

I chose Sheson's DesyncBirdsOfPrey.esp to take me over the limit because it is fully mergeable.

I think the auto-deselect should kick in before that error, and then if there are still more than 255 plugins after the auto-deselect is accounted for .. Then the error should kick in.

Link to comment
Share on other sites

Well one should be able to use old dat files (except if they are really old) so that worries me a bit. In general instruct people to try newest nigthly, currently

307.201707150002

Fixes a regression in restore settings - which needs testing, roll up your sleeves. Fixes your traceback when selecting "Apply AutoBCFs" -> they work fine now

I think BCFs work now fine, case closed

 

@Beermotor the issue with wizards probably merits an issue - can't look at this right now, it's complex - FOMOD folder is skipped...

 

Re: plugins - Bash won't let you activate more than 255 plugins, stop - was like that since forever IIRC, just now the code works :P. Workaround - deactivate mergeable then merge them. The error can't be postponed - it's raised when trying to activate the plugins - the deactivate dialog kicks in on building the patch.

 

Finally re: mods that should remain active. There's a tag turns out, that doesn't work:

MustBeActiveIfImported tag appears to do nothing · Issue #229 · wrye-bash/wrye-bash
https://github.com/wrye-bash/wrye-bash/issues/229

Reported by @Supierce

Should be an easy fix. So maybe fix that, transfer it to all games and have those mods tagged ?

 

Link to comment
Share on other sites

28 minutes ago, Utumno said:

Re: plugins - Bash won't let you activate more than 255 plugins, stop - was like that since forever IIRC, just now the code works :P. Workaround - deactivate mergeable then merge them. The error can't be postponed - it's raised when trying to activate the plugins - the deactivate dialog kicks in on building the patch.

 

Yep I am not the best person to be trying to remember these details, typically I have always had no more than circa 100 mods for any game, so have no experience taking it to the limit ..

.. I just seem to recall seeing cases where people have liked the fact they could take it beyond the limit due to merging and auto-deselecting :

But anyway yes deactivating mergable then merging would also work. Gamerduchess already does something similar.

 

Ok .. Back to testing the latest ..

Link to comment
Share on other sites

@Utumno Got a quick one back atcha :

Backup settings, in my case where I have installed separate Wrye Bash Standalone per game for Oblivion, Skyrim SE and Fallout 4 ..

All three of them are saving their settings into the same location, which is the Fallout 4 Mods \ Bash Mod Data \ folder

Here's the bugdump from the last to load after installation of the most recent nightly build - Which was Oblivion Wrye Bash

Wrye Bash starting
Using Wrye Bash Version 307.201707150002 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Oblivion found in parent directory of Mopy:  E:\Oblivion
bush.pyo  170 __setGame:  Using Oblivion game: E:\Oblivion
testing UAC
mods_metadata.pyo  223 __init__: Using LOOT API version: 0.10.2
barb.pyo  163 Apply: 
barb.pyo  164 Apply: BACKUP BASH SETTINGS: D:\Steam\steamapps\Common\Fallout4 Mods\Bash Mod Data\Backup Bash Settings Oblivion (2017-07-15 00.00.41) v307.201707092223-307.201707150002.7z
barb.pyo  176 _backup_settings: Oblivion\Mopy\bash\l10n\Italian.txt <-- E:\Oblivion\Mopy\bash\l10n\Italian.txt
barb.pyo  176 _backup_settings: Oblivion Mods\Bash Mod Data\Table.dat <-- E:\Oblivion Mods\Bash Mod Data\Table.dat
barb.pyo  176 _backup_settings: Oblivion\Mopy\bash\l10n\Chinese (Simplified).txt <-- E:\Oblivion\Mopy\bash\l10n\Chinese (Simplified).txt
barb.pyo  176 _backup_settings: Oblivion Mods\Bash Installers\Bash\Installers.dat <-- E:\Oblivion Mods\Bash Installers\Bash\Installers.dat
barb.pyo  176 _backup_settings: Oblivion\Mopy\bash\l10n\Russian.txt <-- E:\Oblivion\Mopy\bash\l10n\Russian.txt
barb.pyo  176 _backup_settings: Oblivion\Mopy\bash\l10n\de.txt <-- E:\Oblivion\Mopy\bash\l10n\de.txt
barb.pyo  176 _backup_settings: Oblivion\Mopy\bash\l10n\Chinese (Traditional).txt <-- E:\Oblivion\Mopy\bash\l10n\Chinese (Traditional).txt
barb.pyo  176 _backup_settings: My Games\Oblivion\BashLoadOrders.dat <-- D:\Documents\My Games\Oblivion\BashLoadOrders.dat
barb.pyo  176 _backup_settings: Oblivion\Mopy\bash\l10n\pt_opt.txt <-- E:\Oblivion\Mopy\bash\l10n\pt_opt.txt
barb.pyo  176 _backup_settings: Oblivion Mods\Bash Installers\Bash\Converters.dat <-- E:\Oblivion Mods\Bash Installers\Bash\Converters.dat
barb.pyo  176 _backup_settings: My Games\Oblivion\BashSettings.dat <-- D:\Documents\My Games\Oblivion\BashSettings.dat
 

0000.png

 

Each game has its own gamename mods \ folder, but the bash settings backup is not using them.

Edit : Note though this problem is not new to this build, I think its been doing it a long time and I had not noticed before ( I just weeded a heap of old settings from all three games Wrye Bash, all out of the same folder .. Going back about 8 nightly builds worth )

Edit 2 : Also note Bash ini is not in use, for any of the Wrye Bash installations.

Link to comment
Share on other sites

Each game setup has its own bashsettings.dat file, in game specific folders in my documents \ my games \

Here I have selected Fallout 4 on the left to show the files within, but could similarly show a different bashsettings.dat file for each game

 

0000.png

 

I never change any advanced settings to the setup, its all as per the Installer set things up per each game.

Link to comment
Share on other sites

I hope I'm not derailing this topic. If so, please feel free to move this post to another thread. I posted the issue over at the official forums, but I get the feeling it's pretty much been abandoned due to the horrible issues they're having. Anyway:

 I was wondering if anyone knew the cause of this error. I am unable to unpack any packages into a project.

I get the following wxPython: stdout/stderr message:

Quote

Traceback (most recent call last):
  File "bash\balt.pyo", line 2490, in __Execute
  File "bash\balt.pyo", line 1602, in _conversation_wrapper
  File "bash\basher\installer_links.pyo", line 956, in Execute
  File "bash\bosh\bain.pyo", line 1189, in unpackToProject
  File "bash\bosh\bain.pyo", line 1158, in unpackToTemp
  File "bash\archives.pyo", line 101, in extract7z
bash.bolt.StateError: test.zip: Extraction failed:
7z.exe return value: 7

I've Googled all over the place & checked all my known WB threads but can't seem to find anything.

I've tried changing all names in the packages to one word, all standard character names with nothing that could be considered a special character in some other type of formatting. E.G., test.zip containing test.esp and test.txt. Still getting the same error. The only thing I can think of that has changed recently is that I've relocated my Temp folder in Environment Variables off of my SSD to a standard (local) HDD. Since the last call before trying to unpack appears to have something to do with the Temp folder, I thought this may be relevant. 

7-ZipFM and other programs have all worked fine with this change, so not sure it's the culprit. I'm using WB version: 307.201705262232(Standalone), and so far it's worked perfectly. I've also tried running WB as admin.

Any help would be greatly appreciated!

Thanks!

RM

 

Edit:

And now for some reason I'm getting this error. All my untrained eye can see are two backslashes between each folder. Unknown if this is intended.

Quote

settings_links.pyo  461 Execute: Debug Printing: On
Traceback (most recent call last):
  File "bash\balt.pyo", line 2490, in __Execute
  File "bash\balt.pyo", line 1602, in _conversation_wrapper
  File "bash\basher\installer_links.pyo", line 957, in Execute
  File "bash\basher\installer_links.pyo", line 87, in _get_refreshed
  File "bash\bosh\bain.pyo", line 818, in refreshBasic
  File "bash\bosh\bain.pyo", line 825, in _refreshBasic
  File "bash\bosh\bain.pyo", line 1371, in _refreshSource
  File "bash\bosh\bain.pyo", line 1303, in _refresh_from_project_dir
  File "bash\bolt.pyo", line 823, in _getmtime
  File "genericpath.pyo", line 62, in getmtime
WindowsError: [Error 2] The system cannot find the file specified: u'C:\\Users\\Chuck\\Games\\Oblivion Mods\\Bash Installers\\testpackage'

WB does seem to be seeing my new Temp folder though. When I "Create New Project" I get a dialogue box saying the folder d:\windows temp\WryeBash_tpzirs\testpackage doesn't exist and asking if I want to create it. I do, and then try to unpack testpackage.zip to project, and get another dialogue box saying "testpackage already exists. Overwrite it?" I do, and then once again get the above error, and the testpackage project disappears out of the installers tab. I can't find testpackage project in any of the \Bash Installers or \Bash Mod Data subdirectories. The BashBugDump.log is empty.

Link to comment
Share on other sites

@Utumno Bit of settings feedback for the latest nightly build end of second post :

I made a new backup settings using the Settings menu option (Gear Icon), and just for experiment set Status Bar, Icon Size = 32

After the backup, changed Icon size to 24, then restored settings .. Icon size remained at 24 instead of going to what was set at 32

 

I had not run it via command line so decided to close Wrye Bash and generate a bashbugdump.log

After loading Wrye Bash up again .. Icon size was now at 16, and I had not left it that way when closing it down.

I now tried to change to Icon size 32, and Wrye Bash became unresponsive, and then crashed

The bashbugdump.log was completely empty (not even Testing UAC in there)

 

Now I cant change Icon size at all no matter what approach, its stuck at "cant see them properly size 16 unless I use a magnifying glass" - Any attempt to change the size results in CTD with no dump

 

Edit : Actually if I delete all bashsettings.dat files I can now change Icon size again, I think the restore settings messed things up

Link to comment
Share on other sites

Well, this is mildly interesting..

After a full Oblivion delete & re-install (for other added reasons), and a complete WB uninstall/reinstall, I found that WB couldn't install packages either. (I hadn't tried installing/uninstalling packages recently.)  So on a hunch, I changed the location of the Temp folder in user variables to point to D:\Temp, instead of D:\Windows Temp. Now, magically, everything is working fine. I'm able to install, uninstall, create & unpack to projects etc. I checked the new D:\Temp folder and am finding entries generated by WB.

So it appears my issue is resolved. However, for anyone looking at the code (and I'm sure this is VERY low priority), you may want to see how WB is resolving the path to the User Temp folder. (Not sure of the right lingo here.) Simply having removed the space makes me think it has something to do with the ability to resolve different encoding (Unicode, ANSI, UTF-8, etc). Or I suppose something like, when it runs the command, it doesn't enclose the path in double quotes, like when I have to use the command line. I'm only thinking this may be an upcoming issue because with the rise in popularity of SSD's, some people are going to be moving their Temp folders to a different drive, and if they use a folder name which WB doesn't like, it's going to totally break WB for them. As for me, EVERY other program that reads/writes to the Temp folder I previously had with a space worked just fine, so the issue may not be obvious to others. Maybe this is my fault, and I should have done something like enclosed the path with double quotes when changing the Environment Variables ("D:\Windows Temp"), but everything else was able to resolve the path fine (Photoshop, Premiere, 7-Zip, Blender, NifSkope, Audacity, Paint.Net, etc.).

Sorry for the verbosity, and I hope somebody may find this info useful. Thanks everyone for your continued work on WB. Once I learned it, can't live without it! :)

Link to comment
Share on other sites

On 7/10/2017 at 0:47 PM, alt3rn1ty said:

.. And lastly the Fallout 4 BCFs .. No problems creating them

Though I think @Beermotor ( or maybe @Utumno ) you have a problem with an image type in the armour one

(Reference this post and the files for Fallout 4)

 

0000.png

000.png

  Hide contents

Wrye Bash starting
Using Wrye Bash Version 307.201707092223 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Fallout4 found in parent directory of Mopy:  D:\Steam\steamapps\Common\Fallout 4
bush.pyo  170 __setGame:  Using Fallout4 game: D:\Steam\steamapps\Common\Fallout 4
testing UAC
mods_metadata.pyo  224 __init__: Using LOOT API version: 0.10.2
installer_links.pyo  334 _get_size_and_pos: Saved Wizard position ((-1, -1)) was not a tuple (<class 'wx._core.Point'>), reverting to default position.

With latest nightly build I can still reproduce the above quoted problem, no handler found for image type, and the resulting BashBugDump.log is the same too - For BeerMotors Fallout 4 BCF applied to Armour and Weapon Keywords

To be clear it is the resulting BAIN, after applying the BCF, which now has a wizard - Run the wizard in the newly created BAIN and the above occurs.

Wrye Bash starting
Using Wrye Bash Version 307.201707150002 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Fallout4 found in parent directory of Mopy:  D:\Steam\steamapps\Common\Fallout 4
bush.pyo  170 __setGame:  Using Fallout4 game: D:\Steam\steamapps\Common\Fallout 4
testing UAC
mods_metadata.pyo  223 __init__: Using LOOT API version: 0.10.2
installer_links.pyo  334 _get_size_and_pos: Saved Wizard position ((-1, -1)) was not a tuple (<class 'wx._core.Point'>), reverting to default position.

 

EDIT : SEE FOLLOW UP POST 

 

Link to comment
Share on other sites

14 hours ago, Utumno said:

 

@Beermotor the issue with wizards probably merits an issue - can't look at this right now, it's complex - FOMOD folder is skipped...

 

No worries.  I do not consider this to be a show-stopper bug since it is mainly cosmetic.

It can go into Known Issues for this upcoming release if you don't have time to look at it this cycle.  

Thanks for the update, I'll try to run my full test plan over the next couple of days.

EDIT: ok I saw @alt3rn1ty can reproduce the "no handler" error now so maybe it isn't entirely cosmetic.

Link to comment
Share on other sites

15 hours ago, Utumno said:

Finally re: mods that should remain active. There's a tag turns out, that doesn't work:

MustBeActiveIfImported tag appears to do nothing · Issue #229 · wrye-bash/wrye-bash
https://github.com/wrye-bash/wrye-bash/issues/229

Reported by @Supierce

Should be an easy fix. So maybe fix that, transfer it to all games and have those mods tagged ?

 

@Utumno :) Just realised the relevance of this = For fully mergable plugins which have an associated BSA, it should not get auto-deselected if it has the Bash Tag MustBeActiveIfImported ..

It would do the trick - But there are going to be an awful lot of ruined saves and effed up games before mod authors start including their mod to have that tag in the LOOT / BOSS masterlists (if ever they do know to do such), and eventually Wrye Bashes own taglist would catch up after about three years of messing up peoples games - Wrye Bash is already earning a reputation in the Skyrim / Fallout 4 communities to deselect and dont use any merging (or at least do not allow the mods to be deselected at all), which is being spread as general advice on nexus forums somewhere apparently (to be honest, currently, I would have to agree with that as general advice, the amount of damage missing resources like scripts from deactivated BSAs' can do to the newer games progress is not insignificant).

For this problem especially for newer games, I think detection of associated BSA / BA2 is still the best way to go to prevent them being disabled.

Link to comment
Share on other sites

1 hour ago, Beermotor said:

EDIT: ok I saw @alt3rn1ty can reproduce the "no handler" error now so maybe it isn't entirely cosmetic.

Goddammit! HOLD THE PHONE @Utumno

The problem is now gone .. sort of :

Use the Armour and Keywords mod and BCF from this post by Beermotor - So have the mod in your installers tab, and the BCF in the conversions folder.

Apply the BCF to the mod

Resulting in the new BAIN for Armour and keywords, with a new wizard

WITHOUT CLOSING WRYE BASH - Run the wizard - And you will get the image no handler issue, and an entry in the bashbugdump (as previously posted)

 

Now close Fallout 4 Wrye Bash

Load it again

and now run the wizard = No problems ..

Wrye Bash starting
Using Wrye Bash Version 307.201707150002 (Standalone)
OS info: Windows-10-10.0.15063
Python version: 2.7.12
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_GB', 'cp1252')
filesystem encoding: mbcs 
bash.pyo  322 main: Searching for game to manage:
bush.pyo   89 __supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   91 __supportedGames:  Oblivion: e:\oblivion
bush.pyo   91 __supportedGames:  Skyrim Special Edition: D:\Steam\steamapps\common\Skyrim Special Edition
bush.pyo   91 __supportedGames:  Fallout4: D:\Steam\steamapps\common\Fallout 4
bush.pyo  149 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  155 _detectGames: Set game mode to Fallout4 found in parent directory of Mopy:  D:\Steam\steamapps\Common\Fallout 4
bush.pyo  170 __setGame:  Using Fallout4 game: D:\Steam\steamapps\Common\Fallout 4
testing UAC
mods_metadata.pyo  223 __init__: Using LOOT API version: 0.10.2

 

0000.png

 

The problem only occurs if you try to do everything in the same session of having Wrye Bash apply the BCF, then immediately trying to run the wizard in the newly created BAIN. Shut down Wrye Bash first (I also deleted the original Armour and Keywords mod and the BCF at this stage, leaving just the new BAIN with wizard in place), then load it up again and run the new wizard = no image handler issues.

Link to comment
Share on other sites

14 hours ago, alt3rn1ty said:

@Utumno Got a quick one back atcha :

Backup settings, in my case where I have installed separate Wrye Bash Standalone per game for Oblivion, Skyrim SE and Fallout 4 ..

All three of them are saving their settings into the same location, which is the Fallout 4 Mods \ Bash Mod Data \ folder

Same here - in my case the first build of 307 I used was for SSE so mine are all under that tree.

Link to comment
Share on other sites

22 minutes ago, alt3rn1ty said:

Goddammit! HOLD THE PHONE @Utumno

The problem is now gone .. sort of :

Interesting. The only difference I can see in this case (from the other FO4 BCFs I've done) is the image entry for this WizBAIN option is passed to "SelectOne" as a string instead of literally in the wizard. For example in the AKWCR Wizard I do this:

This is a block of script that sets up vars for each field in "SelectOne".  This gets iterated for each selection (e.g. sModName002, sModName003)

sModName001 = "Vanilla or Partial DLC"
sModDescription001 = "Select this option if you are running Vanilla Fallout 4 or only have a few DLCs"
sModImage001 = ""
If  bHasAllDLC == 0
    sModName001 = "|" + sModName001
EndIf

Then when "SelectOne" is actually called in the wizard, it is handled like this:

SelectOne "Choose your install type",\
    str(sModName001),str(sModDescription001),str(sModImage001),\
    str(sModName002),str(sModDescription002),str(sModImage002)
    Case "Vanilla or Partial DLC" <snip>

Handling it that way does not throw the "no handler for image type" error.

Perhaps I should fetch some holy water and a dead chicken? ;)

EDIT: all kidding aside I'm going to hold off on creating the issue on Github until we figure out the proper repro steps. This one is weird.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...