Jump to content

[RELz/WIPz] Unofficial Skyrim Legendary Edition Patch [USLEEP]


Arthmoor
 Share

Recommended Posts

About my bug report: https://afktrack.afkmods.com/index.php?a=issues&i=23565.

Quote

That's the result of the CK amending that data of its own accord and we've taken the position that when it does things like this we will not interfere with it since it's just going to put it back again later. This is not a bug, but the CK updating things that need to be updated.

This assumption is false. The CK did not automatically update and add those Attack Events for DremoraRace as a result of including the other changes mentioned in my previous bug report: https://afktrack.afkmods.com/index.php?a=issues&i=22848. The new Attack Events were added by VOLUNTARILY selecting Update Events in the Attack Data tab of DremoraRace (see below). I just tested that it actually doesn't need to be selected in order to fix the DremoraRace's invisible-item-in-left-hand issue when resurrected (as well as the CK not updating its Attack Events if I didn't touch Update Events). I would at least request someone to double-check this "bug" so it isn't something that is mistakenly included in future releases of USLEEP/USSEP as a "bugged" bug fix.

Sorry for my imprudence. I really do appreciate all of the bugs and inconsistencies you guys fix in the Unofficial Patches.

RaceAttackDataWindow.png

BlO9Iht.gif

Link to comment
Share on other sites

On 2018-02-15 at 5:57 AM, iMACobra said:

What about it?  Seriously, I took a closer look at the picture from TES5Edit and it seems you have at least three records entries that might be dirty as all three are shown in red.

That could might be what is causing your issue, so I suggest that you clean the master files first then try to reproduce your issue in-game without any other mods than USLEEP.

Are you sure you use mods that has been cleaned, including the master files?  I don't think the master files have been cleaned, otherwise it won't show up three records in red.

7 hours ago, iMACobra said:

2018-02-15 19-59-42.flv

Why do I get an error about permission, unless only the USKP team has access to that video?

Link to comment
Share on other sites

Quote

What about it?  Seriously, I took a closer look at the picture from TES5Edit and it seems you have at least three records entries that might be dirty as all three are shown in red.

That could might be what is causing your issue, so I suggest that you clean the master files first then try to reproduce your issue in-game without any other mods than USLEEP.

Are you sure you use mods that has been cleaned, including the master files?  I don't think the master files have been cleaned, otherwise it won't show up three records in red.

Those aren't dirty edits done by me. They are USLEEP edits. I don't know what they were changed for so I leave them alone. My Master files were cleaned as well prior to recreating the DremoraRace issue in-game. The issue is caused by USLEEP's change so that needs to be activated in order for me to show my problem. I know the testing parameters of USLEEP and had no other mods on.

image.thumb.png.42588f9b6f02a695cf0296150022b356.png

image.thumb.png.92b0e4ef6fec1a1cc4fe3eb0ac686f81.png

image.thumb.png.a57ffa582c54b6d59843aef4f88ca09a.png

image.thumb.png.b4ac0c338e82d9b0d450d7ced6834bec.png

Quote

Why do I get an error about permission, unless only the USKP team has access to that video?

I uploaded the video to YouTube but the original one I posted is much higher quality. I don't know why its uploaded quality on YouTube is bad.

Those Attack Events in DremoraRace need to be reverted because it wasn't something done by the CK automatically but by pressing Update Events.

Edited by iMACobra
Link to comment
Share on other sites

Whatever you say guy, I think I should know what I did and did not click in the CK when those changes appeared. You can't always be 100% correct about every "bug" you submit you know and your aggressive tone is not appreciated.

Link to comment
Share on other sites

I am not trying to be aggressive. If anything, it is a passive-aggressive (and purely objective) tone but this is simply how one argues when they are trying to get a point across. Sorry if it came off that way and I apologize for the unintentional tone but I know what I did in the CK and can comfortably say that I don't get the same result as presented in USLEEP in TES5Edit. One person's possibly-off changes should not warrant affecting everyone else's games which is I why I'm asking ANYONE to at least double-check this. All it takes is about 5 minutes to do the same changes is all I'm asking. And if I'm wrong, I'll put this to rest and won't ever bring it up again.

Link to comment
Share on other sites

  • 4 weeks later...

I tried the new AFKTrack today, it won't let me register, saying there is already a user by this name. It doesn't complain when I login with my usual password, but doesn't show the Open New Issue. Any pointers?

I've uploaded a small patch to cover a gap below the post and wall.

 

Link to comment
Share on other sites

Logging in with your usual password would be expected since the account data has migrated trackers a couple of times, originating from here when we were still using Tracdown.

In order to open a ticket you need to select a project first. Then the link to open an issue will come up.

Link to comment
Share on other sites

16 hours ago, Arthmoor said:

Logging in with your usual password would be expected since the account data has migrated trackers a couple of times, originating from here when we were still using Tracdown.

I just tried that and I used the same username and password, but nope I cannot login.

Link to comment
Share on other sites

I think I've mention that earlier and that has to do with what e-mail address I used when I joined here, because if my e-mail address, on the bug tracker, is what I think it is then no I cannot use the passwork retrieval.

The reason for that is quite simple, I lost my password and reset it in order to get a new password is out of question since only Fliggerty can do that.

Believe me I have tried to do that myself without being able to change my password for a certain e-mail address.

Link to comment
Share on other sites

The email address on file with the forum is the same one you have listed in the tracker. If that's invalid, then so is the one you listed here on the forum, and I'd then seriously question WHY you'd use an invalid address to register with.

If you want that changed and can't do it, PM me a new one to put in there and then you can retrieve your password via the tracker's controls.

This is why thinking one is being cute by submitting bad info to thwart spammers ultimately doesn't work.

Link to comment
Share on other sites

Like Leonardo, I do use invalid emails for some sites. I'm a security engineer, among other things.... But I never expected spam from this site, and have signed up for following topics, so my email is good here.

Anyway, I did as you suggested and did the lost password thing. So now I have different passwords for the tracker and the forums. (I hadn't updated my forum password since Jan 2013, before you switched to https.) Hopefully that's not a problem going forward.

Link to comment
Share on other sites

9 hours ago, Arthmoor said:

The email address on file with the forum is the same one you have listed in the tracker. If that's invalid, then so is the one you listed here on the forum, and I'd then seriously question WHY you'd use an invalid address to register with.

If you want that changed and can't do it, PM me a new one to put in there and then you can retrieve your password via the tracker's controls.

This is why thinking one is being cute by submitting bad info to thwart spammers ultimately doesn't work.

Thanks Arthmoor. :unworthy:

Your post got me on the right track and now my login on the bug tracker works as intended.  Thanks again. :D

4 hours ago, DayDreamer said:

Like Leonardo, I do use invalid emails for some sites.

First, unlike you I do NOT use invalid e-mails on any site whatsoever, because in my case my e-mail issue I got for one e-mail address is something have no control over.  I would do something about that, only if I could.

Link to comment
Share on other sites

  • 3 weeks later...

Hello.

I'm not sure if this has anything to do with USLEEP, but I'm putting it here to let you know.

The world encounter Orcs Fighting Forsworn seems to be bugged. Just north of the Lover stone is a spawn point for, among others, this world encounter, and each time I pass this place more and more hunters and forsworn are gathered here. I counted 12 hunters, but there may be more, there is a large number of forsworn warning me against getting to close.

I mention it because I noticed this encounter was modified regarding the hostility of the hunters against the player character. Of course it could be just my save file messing this up.

Edit;

Travelling further north, no people gathering between Bthardamz and Deep Folk Crossing. But just north of Dragontooth Crater, west of Druadach Redoubt, was three hunters and 4 forsworn who I have seen here for a while. (The game has always spawned a new encounter when passing; this time was a nord hunter with his dog.)

The orcs and the hunters just isn't hostile against each other, and so the encounter doesn't end with the normal death of the orc hunters.

Link to comment
Share on other sites

I've always been able to soul trap my own summoned creatures in the game. What Arthmoor said in the ticket is entirely correct. Ash guardians aren't unique in this respect unless you have some other mod that makes changes to this somehow. The note on UESP is wrong in this case.

Link to comment
Share on other sites

As I keep saying (to no avail), I do not have any gameplay-changing mods. Doing a Google search on "skyrim soul trapping summons" turns up the same result. There is even a mod to make soul trapping summons possible. Maybe you are mixing this up with Oblivion?

Link to comment
Share on other sites

No, he's not mixing it up with Oblivion. You have always been able to soul trap summons. Bethesda took no steps to block that from being possible. UESP is wrong and just because someone else made a mod to block it doesn't make the issue any more true than when we closed the ticket as invalid.

Link to comment
Share on other sites

The final beta for USLEEP is now online. Second post has the details. We expect this process to last about 2 weeks, and we may need to update this beta along the way since we're still going to squeeze in some last minute stuff if need be.

Once this release goes live, we will not be doing anymore updates unless a hotfix is required for something this update might have broken. Yes yes, we know, terrible USLEEP always breaking shit. No project is perfect. You all play mods with a lot more problems than this one :P

Link to comment
Share on other sites

The final version of USLEEP is now live. There were updates since the beta was launched so you should make sure you grab this copy to be completely up to date.

No further updates will be made barring a hotfix for something that didn't get caught for 3.0.13 itself.

Link to comment
Share on other sites

I hate to be that guy but the 5 following scripts only have their source code embedded in the archive, the compiled versions are missing :

  • defaultsetstageondeathrefalias.psc
  • dlc2dunseekerinvisscript.psc
  • qf_tg04_00021550.psc
  • udbp_qf__03056632.psc
  • uskp_tif_freeformmarkarthj_030528f7.psc

Some of them look like leftovers from the old stand-alone patches but I'm not sure about it. Are these scripts still needed ?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...