Jump to content

[RELz/WIPz] Unofficial Skyrim Patch


Arthmoor
 Share

Recommended Posts

Heads up - a beta for 2.0.2 is now available. This is a fast tracked update with a relatively light changelog. The big thing that needs major attention is more eyes on the Soul Trap stuff. Beat on it. Pound it. Make it scream. It would be greatly appreciated if several people could hammer away on this and report back.

 

The plan is to have this into the general public's hands ASAP, so the more eyes on this the better. I'm looking to have this go sometime in the afternoon (it's just after midnight now my time) and would prefer to have more than just my own "yes, it's working" seal of approval on it - cause we know how well THAT worked out already.

Link to comment
Share on other sites

I've had a run around the wilderness between Riften and Largashbur. Several times, both before before applying the Beta and afterwards.

Tried all combinations I can think of:-

Spell + normal weapon

Enchanted weapon

Spell + Bound Bow

Bound Bow + Soul Stealer Perk

Spell + enchanted weapon

Spell + Bound Bow + Perk

 

Logs clean both before and after applying the beta. Spell has the projectile, target shows the Soul Trap "glow".

Game History:-

Note. All DLCs and associated patches exist, they are just not enabled

USKP 2.0.1 Beta (Feb 1st), SBBasement, no killcams from the start
All 4 UPs updated to 2.0.1 (Feb 9th) after save 51
USKP/UDGP updated to 2.0.1a (Feb 13th) after save 92
USKP updated to 2.0.2 Beta (Feb 17th) after save 126

Load Order:-

Update.esm
USKP
SBBasement.esm
no killmoves, no killcams, no killbites.esp

If there's anything specific you want testing, just ask ;)

Link to comment
Share on other sites

Nothing worth reporting from my setup, USKP 2.0.2 retroactive update completes, no spam ( I am using an enchanted glass bow with soul trap, captured a few horker souls and frostbite spider ) ..


[02/17/2014 - 12:15:03PM] Papyrus log opened (PC)

[02/17/2014 - 12:15:03PM] Update budget: 1.200000ms (Extra tasklet budget: 1.200000ms, Load screen budget: 500.000000ms)

[02/17/2014 - 12:15:03PM] Memory page: 128 (min) 512 (max) 76800 (max total)

[02/17/2014 - 12:15:35PM] VM is freezing...

[02/17/2014 - 12:15:35PM] VM is frozen

[02/17/2014 - 12:15:35PM] Reverting game...

[02/17/2014 - 12:15:58PM] Loading game...

[02/17/2014 - 12:15:59PM] VM is thawing...

[02/17/2014 - 12:15:59PM] error: File "HearthFires.esm" does not exist or is not currently loaded.

stack:

<unknown self>.Game.GetFormFromFile() - "<native>" Line ?

[alias Player on quest DLC2Init (05016E02)].DLC2InitCrossDLCScript.OnPlayerLoadGame() - "DLC2InitCrossDLCScript.psc" Line 39

[02/17/2014 - 12:16:00PM] USKP 2.0.2 Retroactive Updates Complete

[02/17/2014 - 12:17:31PM] Info: *Achievement 39 awarded - a winnar is you!*

[02/17/2014 - 12:19:35PM] VM is freezing...

[02/17/2014 - 12:19:35PM] VM is frozen

[02/17/2014 - 12:19:37PM] Saving game...

[02/17/2014 - 12:19:49PM] VM is thawing...

[02/17/2014 - 12:20:04PM] VM is freezing...

[02/17/2014 - 12:20:04PM] VM is frozen

[02/17/2014 - 12:20:04PM] Saving game...

[02/17/2014 - 12:20:04PM] VM is thawing...

[02/17/2014 - 12:20:19PM] VM is freezing...

[02/17/2014 - 12:20:19PM] VM is frozen

[02/17/2014 - 12:20:21PM] Saving game...

[02/17/2014 - 12:20:21PM] VM is thawing...

[02/17/2014 - 12:24:00PM] VM is freezing...

[02/17/2014 - 12:24:00PM] VM is frozen

[02/17/2014 - 12:24:02PM] Saving game...

[02/17/2014 - 12:24:02PM] VM is thawing...

[02/17/2014 - 12:24:49PM] VM is freezing...

[02/17/2014 - 12:24:49PM] VM is frozen

[02/17/2014 - 12:24:51PM] Saving game...

[02/17/2014 - 12:25:00PM] VM is thawing...

[02/17/2014 - 12:28:15PM] Info: *Achievement 39 awarded - a winnar is you!*

[02/17/2014 - 12:30:16PM] Info: *Achievement 39 awarded - a winnar is you!*

[02/17/2014 - 12:36:29PM] Info: *Achievement 39 awarded - a winnar is you!*

[02/17/2014 - 12:40:15PM] Info: *Achievement 39 awarded - a winnar is you!*

[02/17/2014 - 12:42:14PM] Info: *Achievement 39 awarded - a winnar is you!*

[02/17/2014 - 12:43:33PM] VM is freezing...

[02/17/2014 - 12:43:33PM] VM is frozen

[02/17/2014 - 12:43:35PM] Saving game...

[02/17/2014 - 12:43:35PM] VM is thawing...

[02/17/2014 - 12:44:43PM] VM is freezing...

[02/17/2014 - 12:44:43PM] VM is frozen

[02/17/2014 - 12:44:45PM] Saving game...

[02/17/2014 - 12:44:45PM] VM is thawing...

[02/17/2014 - 12:44:45PM] error:  (0003E538): has no 3d, and so cannot have its motion type changed.

stack:

[ (0003E538)].MaceTrap.SetMotionType() - "<native>" Line ?

[ (0003E538)].MaceTrap.OnCellDetach() - "MaceTrap.psc" Line 45

[02/17/2014 - 12:45:08PM] VM is freezing...

[02/17/2014 - 12:45:08PM] VM is frozen

[02/17/2014 - 12:45:08PM] Saving game...

[02/17/2014 - 12:45:08PM] VM is thawing...

[02/17/2014 - 12:45:15PM] VM is freezing...

[02/17/2014 - 12:45:15PM] VM is frozen


Fairly clean as usual, which was also the case before 2.0.2 update with my setup ..

 

.. but no mods which would trigger it so results are as expected really.

 

Only had half hour so far, so will keep a game going during my time off today and see if anything else crops up.

Link to comment
Share on other sites

The main issue with the Soul Trap spell happened with mods that altered the Soul Trap magic effect, or created a new spell that used the Soul Trap script, but didn't use the USKP paramaters. SkyRe and Mighty Magic are known to do the former, while the Apocalypse spell packages includes a spell that is known to do the latter. (That specific spell being "Cloak of Souls")

 

If there is no log spam from both of those cases, then I'd consider the USKP script to work. Otherwise, it will need more pounding.

Link to comment
Share on other sites

Then pound. Not everyone has those mods and it's not appropriate for us to install them into our testing environments and I don't want them in the load order for my regular game so I would have no reason to test it under those conditions.

 

This kind of thing needs MORE eyes, not just more jobs for those already looking. The community seems awfully quick to expect to have their cake and eat it too without expending much effort to arrive at that point. We can't do everything with the limited time available to us.

Link to comment
Share on other sites

Murphy is earning his pay this month. Hotfix 2.0.2a has bee released:

 

Two AI pack scripts that were fixed to stop script spam ended up unleashing a previously unknown bug that caused the final scenes from Speaking With Silence (TG05) to run again, which led to the game screen ultimately being blacked out with no solution and no access to controls.

Link to comment
Share on other sites

 Am I missing something obvious here because I don't see a post stating 2.0.2 has been released ? The last post mentioning 2.0.2 beta is here (post 478) - nothing between then and now to indicate a full release (2.0.2) has been released, yet the 1st post now says 2.0.2a and the 2nd (reserved for betas) is empty and you're issuing a hotfix for a non-existent - or at least unannounced - release?

 

Many of us, me included, rely on "release" posts in this thread, or more precisely the attendant email notifications, to know that a new version is available - this doesn't seem to have happened this time around.

Link to comment
Share on other sites

Yeah - has been a bit, er, interesting, of late ;)

Fortunately I reverted to 2.0.1a, after testing the Soul Trap stuff in the 2.0.2 beta, as I'm quite close to doing TG05. Phew! Quite why I did that I'm not sure as I usually run with the current betas, when they're available. Guess I must be psychic :scared:

Link to comment
Share on other sites

Thanks for this very quick hotfix. Opening USKP 2.0.2a in TES5Edit throws the following warnings at the end of the loading process log :

 

[00:17] Background Loader: Found a struct with a negative size! (2) 24C5DEA6 < 24C5DEA4  for Script Fragments Quest

[00:17] Background Loader: Found a struct with a negative size! (2) 24C5DEA6 < 24C5DEA4  for Script Fragments Quest
[00:17] Background Loader: Found a struct with a negative size! (2) 24C5DEA6 < 24C5DEA4  for Script Fragments Quest

 

Should we care about it ?

Link to comment
Share on other sites

After Stormcloaks take Whiterun, Heimskr is wearing prison clothes when he should not be. I tried to add it to TracDown but I seem to be unable to

This was fixed a while back with USKP v. 2.0.1. Are you sure you have properly updated? It is fixed in my game.

Link to comment
Share on other sites

Heimskr is the new Blood on the Ice. Yeah. He's jacked yet again. Will be dealt with on the next update though. Really getting sick of that guy and the convoluted mess that is the CW scripts.

I stand corrected then. He is fine in my game, but something must still be up that I'm not aware of.

Link to comment
Share on other sites

This may be a false alarm, the mod "Clothing and Clutter Fixes" makes changes to the outfits of every NPC that wears robes and touches on Heimskr. It's usually well kept with the latest USKP but it may not have caught up to the newest versions.

 

Apologies to everyone

 

Edit: Just saw Arthmoors post, I guess it wasent just me after all

Link to comment
Share on other sites

Got another one for you boys,

 

I know some work was done on the Potema quests in the last update, well, I approched Elisif just now and found that she was offering me the second part of it. The one where she wants me to make an offering at a Talos Shrine? Well normally that would be fine, except for one thing... I had not even started the first Potema quest yet!!

 

If it means anything, I had already discovered the cave for the first quest but had not been in it yet. And I was still able to accept the first quest from Falk

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...