Jump to content
WrinklyNinja

[RELz] LOOT - Load Order Optimisation Tool

Recommended Posts

On 7/12/2020 at 5:43 PM, wolfranger said:

LOOT no longer recognizes Kalilies NPCs Cutting Room Floor and AI Overhaul patch.

That seems to be a new patch, the masterlist only has metadata for a AIO or CRF patch.

I'll open an issue for it to be updated.

Share this post


Link to post
Share on other sites

I have a problem with 3DNPC Alternative Locations.esp

The message I get from LOOT is "This plugin requires a new game", even though I have no game in progress.  There are no saves.  I have Live Another Life Alternative Start and 3DNPC, so I have all the required mods loaded.  Can't get rid of the error message.

Share this post


Link to post
Share on other sites
18 hours ago, aristotle99 said:

I have a problem with 3DNPC Alternative Locations.esp

The message I get from LOOT is "This plugin requires a new game", even though I have no game in progress.  There are no saves.  I have Live Another Life Alternative Start and 3DNPC, so I have all the required mods loaded.  Can't get rid of the error message.

It's supposed to be a warning, not an error message, so just ignore it if it's not applicable. Warnings are used when something might be wrong, but LOOT can't tell, and errors are for when LOOT knows something is wrong.

Share this post


Link to post
Share on other sites

I have a problem regarding two mods: Dawnstar by Arthmoor and AI Overhaul by mnikjom.

I'm using MO2, and installed Dawnstar first, AI Overhaul second, running latest version of loot for load order, and LOOT is placing Dawnstar below AI Overhaul, while AI Overhaul should override Dawnstar.

 

Share this post


Link to post
Share on other sites

I got warning my SKSE 64 is not last version, but it IS the last version skse64_2_00_19

I'm running LOOT Version 0.15.1 (Build 82c756e1)

Share this post


Link to post
Share on other sites

Still same issue:

Version 0.16.0 (Build b1094e67) says I don't have the last version of SKSE but I have SE build 2.0.19 (runtime 1.5.97) what is the last version.

 

 

Share this post


Link to post
Share on other sites

I am using LOOT Version 0.15.1 (build 82c756e1) and I know the version I use isn't the latest, but I have no issues.  Of course I haven't installed any mods yet, but plan to do that soon.

Just updated LOOT to the latest and no issues on my end.

Version 0.16.0 (build b1094e67)

Share this post


Link to post
Share on other sites

in SSE, using LOOT  Version 0.16.0 (build b1094e67), i get this notice: "You seem to be using Majestic Mountains, but you have not enabled a compatibility patch for this mod. A third party patch is available here: Better Dynamic Majestic Mountains"

but: i'm using this https://www.nexusmods.com/skyrimspecialedition/mods/36248?tab=description instead, which replaces the patch LOOT recommends completely.

Share this post


Link to post
Share on other sites

I have done everything possible to fix this, but no matter what I do, it cannot be fixed

 

Quote

Cyclic interaction detected between "Sacrosanct - Vampires of Skyrim.esp" and "Vokriinator Black - CACO patch.esp":

Sacrosanct - Vampires of Skyrim.esp
 [Masterlist Load After]
Better Vampires.esp
 [Master]
BVandRoyalBloodline_Patch.esp
 [Group]
Vokriinator Black.esp
 [Master]
Vokriinator Black - CACO patch.esp
 [Group]
Sacrosanct - Vampires of Skyrim.esp

And I can't modify load rules because they don't fully appear in the list, because all that cyclicing error. So i'm screwed and cannot fix my load order.

Share this post


Link to post
Share on other sites
50 minutes ago, Shiara384 said:

I have done everything possible to fix this, but no matter what I do, it cannot be fixed

Quote

 

Cyclic interaction detected between "Sacrosanct - Vampires of Skyrim.esp" and "Vokriinator Black - CACO patch.esp":

Sacrosanct - Vampires of Skyrim.esp
 [Masterlist Load After]
Better Vampires.esp
 [Master]
BVandRoyalBloodline_Patch.esp
 [Group]
Vokriinator Black.esp
 [Master]
Vokriinator Black - CACO patch.esp
 [Group]
Sacrosanct - Vampires of Skyrim.esp

 

And I can't modify load rules because they don't fully appear in the list, because all that cyclicing error. So i'm screwed and cannot fix my load order.

Sacrosanct - Vampires of Skyrim.esp and Vokriinator Black.esp are in the same group (Skills & Perks), and there is no set order for those two plugins.

That by itself won't cause a sorting error, but you do have plugins from an earlier group (default) that are loading after both plugins separately. That will cause a sorting error.

LOOT can't decide which set of plugins should have priority.

Set A)  Sacrosanct - Vampires of Skyrim.esp -> Better Vampires.esp -> BVandRoyalBloodline_Patch.esp

Set B)  Vokriinator Black.esp -> Vokriinator Black - CACO patch.esp

To fix it you just need to pick a winner between Sacrosanct - Vampires of Skyrim.esp and Vokriinator Black.esp.

Share this post


Link to post
Share on other sites

I dunno why, but it seems LOOT doesn't handle the masters of the Keld-Nar -  Trade and Barter Patch.esp properly.

Before I changed it LOOT didn't moved the Keld-Nar.esp after the Trade & Barter.esp when using the Keld Nar - Trade and Barter Patch.esp.  That happen even if I use the latest master list in LOOT.

Share this post


Link to post
Share on other sites

Yes.  I am sure, otherwise the color for the Keld-Nar - Trade and Barter Patch.esp would be green in WB wouldn't it.

8 hours ago, Leonardo said:

Before I changed it LOOT didn't moved the Keld-Nar.esp after the Trade & Barter.esp when using the Keld Nar - Trade and Barter Patch.esp.

 

Share this post


Link to post
Share on other sites

It would be green if the patch's masters are in the expected order, but my question is whether or not the order the patch wants is actually correct.

Share this post


Link to post
Share on other sites
On 10/28/2019 at 3:11 PM, Art2DW said:
Spoiler

 

Hello

I've been having some problems with the LOOT tool... I'm not complaining I just want to report what I had experienced, and try to find out any help

I use Mod Organizer ("one") have at least 200 plugins active at the same time I have 16 GB of RAM and a GTX 750 Ti and a core i7 kind of old (idk if this could help)...

when I use LOOT it tends to fail (crash) most of the times after it tries to detect the last updated masterlist (while using the "order plugins") but when it starts it doesn't stops easily, and the next times when it happens can happen at the start of the program (LOOT)

I can spend up to 40 mins trying to make it work until it just works...
Something that I had detected is that I can improve the possibility that it works while playing a video (I tried that using youtube) so, I suspect is something that needs to activate the same process

also I had noticed that at the task manager for a brief secs appears a 4th task related to LOOT but just for a few secs, when this didn't present it's when it becomes more possible that the program crash

My RAM and CPU usage keeps under the 30% & 10% usage respectively while LOOT is working... that's why it's weird that the program crashes.

I just want to know if someone knows anything about it or maybe even a possible solution to this (something I could do).
I'm using the current version of LOOT and this happens since 7 months ago, maybe a little more (I use LOOT since 2 years ago)

LOOT.png

 

 

I solve this myself:

I'm using Mod Organizer 2 & 1 (but that's not the issue) to solve this on the "modify executables" at the loot application on the arguments section I used the command as follows:

-Xmx2048m "C:\Steam\...\LOOT\LOOT.exe" in case you have a nice graphics card (GPU) or

-Xmx1024m "C:\Steam\...\LOOT\LOOT.exe" in case your GPU doesn't have enough vRAM, what is between quotation marks is the folder path where you have installed your LOOT app, this command as I learned allows the application to use more vRAM prioritizing it (2048 MB in my first example and 1024 MB in my second example, this value needs to be Below the total capacity of your GPU, for this to work properly), so, apparently newer versions of LOOT since 2 years or something, require a little bit more vRAM this could be trigger if you use a lot of plugins from many mods, in my case it was above 220 plugins, this command also could be helpful for any app to work a little faster (this could be obvious, but closing other apps like your internet browser helps in some cases too).

I'm just sharing this with the community in case this becomes useful for someone, this problem gave me headaches many times.

if someone wants to thank me use my nickname: Art2DWooky :)

It's ever a pleasure to be helpful 

Share this post


Link to post
Share on other sites
17 hours ago, Leonardo said:

I dunno why, but it seems LOOT doesn't handle the masters of the Keld-Nar -  Trade and Barter Patch.esp properly.

Before I changed it LOOT didn't moved the Keld-Nar.esp after the Trade & Barter.esp when using the Keld Nar - Trade and Barter Patch.esp.  That happen even if I use the latest master list in LOOT.

LOOT doesn't sort plugins based on the order of a plugins master files.

What would it do if another plugin had a different order for the same masters?

It will sort a plugin after all its master files.

Share this post


Link to post
Share on other sites
13 hours ago, Arthmoor said:

It would be green if the patch's masters are in the expected order, but my question is whether or not the order the patch wants is actually correct.

You tell me, as I assume the correct order is what WB show. :shrug:

4 hours ago, cptmcsplody said:

LOOT doesn't sort plugins based on the order of a plugins master files.

What would it do if another plugin had a different order for the same masters?

It will sort a plugin after all its master files.

I wonder when was that changed, because as I recall it LOOT has never done that before.

If that happen then the user need to solve a conflict between two mods and LOOT would probably give the user a message about it.

Share this post


Link to post
Share on other sites

I'm getting a false positive from LOOT:

"Cutting Room Floor.esp
You seem to be using RS Children Overhaul, but you have not enabled a compatibility patch for this mod. A third party patch is available here: RS Children Patch Compendium
You seem to be using RS Children Overhaul, but you have not enabled a compatibility patch for this mod. A third party patch is available here: RS Children Overhaul Cutting Room Floor Patch
"

Except I also have Realistic RS Children overwriting all that, and Realistic RS Children does have a patch for Cutting Room Floor included.

LOOT should detect its presence and account for it - the file is called RRSC-CRF-Patch.esp.

Share this post


Link to post
Share on other sites
On 10/5/2020 at 3:00 PM, Erundil said:

I'm getting a false positive from LOOT:

"Cutting Room Floor.esp
You seem to be using RS Children Overhaul, but you have not enabled a compatibility patch for this mod. A third party patch is available here: RS Children Patch Compendium
You seem to be using RS Children Overhaul, but you have not enabled a compatibility patch for this mod. A third party patch is available here: RS Children Overhaul Cutting Room Floor Patch
"

Except I also have Realistic RS Children overwriting all that, and Realistic RS Children does have a patch for Cutting Room Floor included.

LOOT should detect its presence and account for it - the file is called RRSC-CRF-Patch.esp.

@Erundil

Realistic RS Children Overhaul

Some of the original patches aren't needed when using Realistic RS Children.

Quote

RS patches for newly added children will work fine alongside this mod, so feel free to use them to get rid of the dark faces on added children. On the other hand, patches that alter vanilla children will be incompatible (I need to make my own patch)
Let me know which patches you want to see.
(you won't need the corresponding RS patch if I've made one myself)

So only some of the patch messages may need to be hidden and redundant patches should be deleted if RealisticRSChildren.esp is installed.

It will probably take a while to update and test those, so we can open an issue for it first at https://github.com/loot/skyrimse/issues.

Share this post


Link to post
Share on other sites
On 9/19/2020 at 11:21 AM, Leonardo said:

You tell me, as I assume the correct order is what WB show. :shrug:

I wonder when was that changed, because as I recall it LOOT has never done that before.

If that happen then the user need to solve a conflict between two mods and LOOT would probably give the user a message about it.

@Leonardo It changed when Trade & Barter was added to the Economy Group.

Looking at it in xEdit, T&B after Kel-Nar is fine as Keld-Nar reverts one dialogue change.

You'll only need the patch `Keld-Nar - Trade and Barter Patch.esp` from Trade and Barter - Patches if you want to use that order.

image.thumb.png.b23e4d330c80498b38694ef214ef681e.png

The `Trade and Barter - Keld-Nar Patch.esp` plugin from Patches by Phoenix and Umgak actually integrates T&B changes to Keld-Nar, so it looks like a better option.

It also has the wrong master files order, it still needs to be T&B after Keld-Nar.

image.thumb.png.b5906d2dfe196b336aa659c7b4dac1c6.png

image.thumb.png.587c6e9df7beef376a825da470939e38.png

 

Edit: Neither patch is needed with latest version of Keld-Nar.

Quote
  • Version 2.0.5

    • Tilvur's investment dialogue is not checking the proper gold amount. This is a fix being applied which is detailed in USSEP Bug #29335.
    • USSEP 4.2.3 or greater is now a requirement for this mod.

 

Share this post


Link to post
Share on other sites
On 10/6/2020 at 9:09 PM, cptmcsplody said:

You'll only need the patch `Keld-Nar - Trade and Barter Patch.esp` from Trade and Barter - Patches if you want to use that order.

That is the mod patch I use and still LOOT doesn't detect its masters for the patch correctly, I mean doesn't place them in the correct order that WB detected the masters for the mod patch.

Share this post


Link to post
Share on other sites

It's a moot point now anyway since that conflict was due to a wild edit in Keld-Nar and I just updated it to address the bug that the earlier report pointed out and removed the wild edit while I was at it. So that patch is no longer necessary.

Share this post


Link to post
Share on other sites
1 hour ago, Arthmoor said:

It's a moot point now anyway since that conflict was due to a wild edit in Keld-Nar and I just updated it to address the bug that the earlier report pointed out and removed the wild edit while I was at it. So that patch is no longer necessary.

That explains it.  Thanks, Arthmoor. :)

I guess I need to update Keld-Nar to the latest and remove the mod patch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

Patreon
×
×
  • Create New...