Jump to content

[RELz] LOOT - Load Order Optimisation Tool


Recommended Posts

  • Replies 856
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

LOOT A plugin load order optimiser for TES IV: Oblivion, TES V: Skyrim, TES V: Skyrim Special Edition, Fallout 3, Fallout: New Vegas and Fallout 4. Introduction Setting the right load o

Here's a "State of LOOT" update because I haven't posted much about it in a while: Since LOOT's last release (v0.11.0, in May), I've fixed a few bugs in the LOOT API: A crash-on-sort due to

I suppose that would be fine since SSE has a limited set, but I'll be leaving the entire tag set on the main ESP file for future support when it comes along.

Posted Images

That tells me nothing...  How do I go about fixing this issue?  I have uninstalled 3.16, then re-installed 3.14, which worked yesterday.  Now, after installing 3.16 no version works.  Or are you going to say it is an MO2 issue...?

 

Nevermind...  It seems that it was the group editor thing. 

 

Link to post
Share on other sites

I am periodically receiving an error when applying LOOT to load order of Skyrim SE.  Error is 'cannot read property 'getElementsByClassName' of null'.  A copy of debug log is attached.  Other than the message appearing, no other issue as best I can tell, though I can only assume LOOT if functioning, and sorting load order, correctly.  About box shows Version unknown (build unknown)

 

Please advise.  Thank you.

LOOTDebugLog.txt

Link to post
Share on other sites
11 hours ago, bubbawood said:

I am periodically receiving an error when applying LOOT to load order of Skyrim SE.  Error is 'cannot read property 'getElementsByClassName' of null'.  A copy of debug log is attached.  Other than the message appearing, no other issue as best I can tell, though I can only assume LOOT if functioning, and sorting load order, correctly.  About box shows Version unknown (build unknown)

 

Please advise.  Thank you.

LOOTDebugLog.txt

@bubbawoodAre you running LOOT through MO2 when this happens?

Link to post
Share on other sites
On 11/30/2018 at 3:16 PM, FoxyLord said:

Hi, I updated to the new loot version, and I am now getting the error

Error

Oh no, something went wrong! You can check your LOOTDebugLog.txt (you can get to it through the main menu) for more information.

LOOTDebugLog.txt

14:45:43.498450] [error]: Chromium console message from http://loot/ui/app.bundle.js at line 5658: Failed to check for LOOT updates, details: Failed to fetch
[14:45:45.850375] [error]: Exception while executing query: Git operation failed. Details: -1; failed to send request: A connection with the server could not be established
: libgit2 error
[14:45:45.852352] [error]: Chromium console message from http://loot/ui/app.bundle.js at line 5026: Error: Oh no, something went wrong! You can check your LOOTDebugLog.txt (you can get to it through the main menu) for more information.
    at onFailure (http://loot/ui/app.bundle.js:5026:5818)
[14:45:57.090229] [error]: Exception while executing query: Git operation failed. Details: -1; failed to send request: A connection with the server could not be established
: libgit2 error

@WrinklyNinja Same as this issue? https://github.com/loot/loot/issues/953

Link to post
Share on other sites
On 11/30/2018 at 3:16 PM, FoxyLord said:

Hi, I updated to the new loot version, and I am now getting the error

Error

Oh no, something went wrong! You can check your LOOTDebugLog.txt (you can get to it through the main menu) for more information.

LOOTDebugLog.txt

 

9 hours ago, cptmcsplody said:

14:45:43.498450] [error]: Chromium console message from http://loot/ui/app.bundle.js at line 5658: Failed to check for LOOT updates, details: Failed to fetch
[14:45:45.850375] [error]: Exception while executing query: Git operation failed. Details: -1; failed to send request: A connection with the server could not be established
: libgit2 error
[14:45:45.852352] [error]: Chromium console message from http://loot/ui/app.bundle.js at line 5026: Error: Oh no, something went wrong! You can check your LOOTDebugLog.txt (you can get to it through the main menu) for more information.
    at onFailure (http://loot/ui/app.bundle.js:5026:5818)
[14:45:57.090229] [error]: Exception while executing query: Git operation failed. Details: -1; failed to send request: A connection with the server could not be established
: libgit2 error

@WrinklyNinja Same as this issue? https://github.com/loot/loot/issues/953

Not quite, maybe a firewall or antivirus blocking the connection?

21 hours ago, bubbawood said:

I am periodically receiving an error when applying LOOT to load order of Skyrim SE.  Error is 'cannot read property 'getElementsByClassName' of null'.  A copy of debug log is attached.  Other than the message appearing, no other issue as best I can tell, though I can only assume LOOT if functioning, and sorting load order, correctly.  About box shows Version unknown (build unknown)

 

Please advise.  Thank you.

LOOTDebugLog.txt

That looks like #1032, but I don't know why it happens.

Link to post
Share on other sites
8 hours ago, WrinklyNinja said:

 

Not quite, maybe a firewall or antivirus blocking the connection?

That looks like #1032, but I don't know why it happens.

Yes, you're spot on. I'd set a rule up when I first started using LOOT a few years ago, and expected it to be ok still, but for some reason it's blocking LOOT since I updated. It works ok when I pause the firewall, so until I have some time to work out why it's suddenly started blocking LOOT I will run it that way.

 

TY.

Link to post
Share on other sites

All:

While modding SSE, I am getting the following message from MO2

'You have a normal plugin and at least one light master sharing the FE load order index. Deactivate a normal plugin or all your light masters to avoid potential issues.'

I have not engaged any of the Steam Workshop mods, so not sure why this may be happening.  That said, how can I identify the specific mods that are causing this error.  I have tried some trial & error, reduced & retry, without success.

Version 0.13.6 (build e013793f)

 

 

Link to post
Share on other sites

All:

 

While modding SSE, I am getting the following message from MO2:

Failed to sort plugins. Details: Cyclic interaction detected between "RSC Keld-Nar Patch.esp" and "Complete Alchemy & Cooking Overhaul.esp". Back cycle: Complete Alchemy & Cooking Overhaul.esp, Black Sacrament Armor - Consistency Patch.esp, Immersive Citizens - AI Overhaul.esp, CFTO.esp, Keld-Nar.esp, RSC Keld-Nar Patch.esp

Visual inspection of the dependencies does not seem to support the error message.  How should I best go about debugging this load order?  Please advise.

Version 0.13.6 (build e013793f)

 

 

 

Link to post
Share on other sites

On your message about light masters, you've got mods which have the ESL flag on them and are also using up the FE slot with something else. You need to get rid of that something else. The FE slot is not usable by normal mods in SSE or FO4 because it's reserved by the engine for ESL flagged plugin files. If you don't resolve the error it's giving you, you will end up with corrupted saves. It also has nothing to do with Steam Workshop because SSE does not use it.

Link to post
Share on other sites
6 hours ago, Arthmoor said:

On your message about light masters, you've got mods which have the ESL flag on them and are also using up the FE slot with something else. You need to get rid of that something else. The FE slot is not usable by normal mods in SSE or FO4 because it's reserved by the engine for ESL flagged plugin files. If you don't resolve the error it's giving you, you will end up with corrupted saves. It also has nothing to do with Steam Workshop because SSE does not use it.

@horkerborn, thank you for the response.  I follow what you say.  Please tell me -- what is the best way to identify which mod has the ESL?  Anything faster and as effective as opening each mod in SSEEdit to check for the ESL flag?  I look forward to your response.

Link to post
Share on other sites

Hi Loot team!

I have just encountered a Cyclic error which is flummoxing me. I'm used to digging out problems with these Cyclics, but I cannot for the life of me suss this one out. It seems to have arrived on the last Master List update, whereas previously I had no problems sorting.  (I will continue to look for the error.)

It is something to do with Alternate Start, Whiterun Forest Borealis and Landscape Grass fixes.  You'll see from the attached Loot Load order I prefer to cluster Whiterun Forest Borealis and some other tree / landscape mods towards the end of my load order. This is to run the Skyrim Tree Project.

The attached load order is not sorted (and I can't sort it anyway) because I was in the midst of jiggling a couple of mods and the updated Minty Lightning Mod - so it will look wonky at the end.  I have my own load order rules for the Joy of Perspective through to the end, but none of them (so far as I can tell) cause a cyclic interaction. Most of them are a simple "Load After" ruling.  I have manually dragged the offending mods into the right order that LOOT expects, but I still have the Cyclic issue with them.

Please, any ideas where I might be fouling up, I'd be grateful. 

Thank you!

Load order 12 Dec.txt

LOOTDebugLog.txt

Link to post
Share on other sites

@Bluegunk

Whiterun Forest Borealis -> Landscape Grass fixes -> Alternate Start

This Is the order set by after rules in the master list, you'd have to match that order.

Landscape Grass fixes is in the early loader group by default, this is to make sure it doesn't revert changes made by location mods.

You'll need to update its group

223 df     Whiterun Forest Borealis.esp
224 e0     Bent Pines.esp
225 e1     Enhanced Landscapes Oaks Standalone.esp
226 e2     Landscape Fixes For Grass Mods.esp
227 e3     Landscape Fixes For Grass mods - Cutting Room Floor Locations.esp
228 e4     Alternate Start - Live Another Life.esp

  - name: Landscape Fixes For Grass Mods.esp
    group: Early Loaders
    after:
      - Enhanced Landscapes.esp
      - S3DLandscapes NextGenerationForests.esp
      - Whiterun Forest Borealis.esp
      - Verdant - A Skyrim Grass Plugin SSE Version.esp

  - name: Alternate Start - Live Another Life.esp
    group: High Priority Overrides
    after:
      - My Home Is Your Home.esp
      - Landscape Fixes For Grass Mods.esp

So you can't load Whiterun Forest Borealis.esp after ASLAL with those rules. 
I can remove the after `Landscape Fixes` rule from `ASLAL` since they're seperated by groups.
But you may run in to addtional errors.

Is there something specific conflicting that you're choosing to load them after other mods?

On 12/12/2018 at 9:07 PM, Bluegunk said:

Skyrim Tree Project

What is that?

Link to post
Share on other sites

So you can't load Whiterun Forest Borealis.esp after ASLAL with those rules. 
I can remove the after `Landscape Fixes` rule from `ASLAL` since they're seperated by groups.
But you may run in to addtional errors.

Thank you for the help!  You have clarified for me what is going on here. 

I had spotted the Landscape Grass Fixes and the Whiterun Forest Borealis grouping, and switched them to default group for my load order. But I still can't clear this cyclic interaction notification when sorting; I guess additional rules are stalling me. I'm really just digging my own grave, I suppose.   :geek:

The "Skyrim Tree Project" is a bit of a nebulous title (sorry - I had forgotten I gave it the name). It comes from this YouTube "Ultimate Trees Installation" video by Wazalang: https://www.youtube.com/watch?v=i2uHZLNeXqo .  It is working around this with my texture packs that has caused me to end up working the way I do.  

I'd rather not cause you to remove rules from ASLAL.  I think I need to sit down and re-evaluate how I am approaching my mods in MO2 rather than fighting LOOT's grouping rules.

OK, I'll leave it at that, take your advice and have a re-think. Sorry to have used your precious time but thanks for helping!

 

 

 

 

Link to post
Share on other sites
2 hours ago, fdger5bnfd said:

Would be nice if LOOT has an option to visually show differences between old load order and new load order after sorting (something like github's diffs) which would make it easier to figure out which mod positions have changed.

Sounds like #377, which has been requested since 2015, but isn't something I plan on doing myself any time soon.

Link to post
Share on other sites

Hi, y'all!

First off, I'd like to say "Thanks!"  for a great tool! A friend of mine told me about it after I told her how slow my PC had been running and how I'd been having issues with a couple of my mods in Skyrim, and ever since I installed LOOT and ran it (plus another mod that was recommended for cleaning my plugins), my game has been running so much more smoothly!  

I have one question about messages I keep seeing in a couple of my plugins. They aren't warnings or errors, so I'm guessing they're just there to tell me something, but I haven't been able to find out anything on what it is they're trying to tell me, so I figured I'd pop in here and ask! :) They're in Skyrim's Update.esm and the 3 DLC plugins (Dawnguard, Hearthfire, and Dragonborn), and they're all in green letters. Here are some examples:

In Update.esm:

C.Encounter, C.Location, C.RecordFlags, Delev, Names, Stats

In Dawnguards.esm:

C.Location, C.RecordFlags, C.Regions,Delev, Graphics, Invent, Names, Relations, Relev, Stats

 

That's a general idea. These haven't gone away even after running the cleaning program, and since they aren't listed as warnings or errors, I'm guessing they're not really a problem. I was just wondering what they meant and if I needed to do anything about them.

 

Thanks again for the awesome program!

Link to post
Share on other sites
2 hours ago, NiamhDream said:

Hi, y'all!

First off, I'd like to say "Thanks!"  for a great tool! A friend of mine told me about it after I told her how slow my PC had been running and how I'd been having issues with a couple of my mods in Skyrim, and ever since I installed LOOT and ran it (plus another mod that was recommended for cleaning my plugins), my game has been running so much more smoothly!  

I have one question about messages I keep seeing in a couple of my plugins. They aren't warnings or errors, so I'm guessing they're just there to tell me something, but I haven't been able to find out anything on what it is they're trying to tell me, so I figured I'd pop in here and ask! :) They're in Skyrim's Update.esm and the 3 DLC plugins (Dawnguard, Hearthfire, and Dragonborn), and they're all in green letters. Here are some examples:

In Update.esm:

C.Encounter, C.Location, C.RecordFlags, Delev, Names, Stats

In Dawnguards.esm:

C.Location, C.RecordFlags, C.Regions,Delev, Graphics, Invent, Names, Relations, Relev, Stats

 

That's a general idea. These haven't gone away even after running the cleaning program, and since they aren't listed as warnings or errors, I'm guessing they're not really a problem. I was just wondering what they meant and if I needed to do anything about them.

 

Thanks again for the awesome program!

They're Bash Tag suggestions, used by Wrye Bash and Mator Smash, they're typically just informative.

Link to post
Share on other sites
  • 2 weeks later...

Hello.

The masterlist dated desember 28 reports that TES5Edit has found 117 ITM's in USLEEP 3.0.13a (for original Skyrim). Only Lanterns of Skyrim are above USLEEP. I also get 3 ITM for Kynesgrove 1.1.6 and 1 ITM for Shor Stone 1.0.3 (both by Arthmoor). The previous list didn't report any of these. What is correct?

LOOT also now report 17 ITM's in Unique Border Gates 2.2.

Unique Border Gates

Link to post
Share on other sites

Hi,

Hope this is the correct place to report the following, if not a Mod please move it where it belongs.

I am using the latest LOOT and getting 2 warnings;

Vigilant.esp

 1.3.0 2E278EC6

SSEEdit v3.2.84 EXPERIMENTAL found 52 ITM records. A guide for running Quick Auto Clean can be found here.

ForgottenCity.esp

  E6DC78C3

SSEEdit v4.0.0 found 7 ITM records. A guide for running Quick Auto Clean can be found here.

I have run both these through SSEEdit v4.0.0 repeatedly and never get any ITM records, I am feeling these warnings are a false positive, could the warning either be verified or removed.

 

TIA

Link to post
Share on other sites

I'm suddenly running into a problem today with LOOT crashing when I try to sort my mods. It was fine yesterday; all I'm finding wrong today is from LOOTDebugLog:

[16:05:05.823632] [warning]: Blocking load of resource at https://fonts.googleapis.com/css?family=Roboto+Mono:400,700|Roboto:400,300,300italic,400italic,500,500italic,700,700italic
[16:05:07.148824] [warning]: No masterlist present at C:\Users\somnomania\AppData\Local\LOOT\Skyrim\masterlist.yaml

I've reinstalled, same problem. I am launching it through MO, because otherwise it doesn't see my mods and is therefore of no use to me.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...