Jump to content

I got two Dawnbreaker during Meridia's Daedric quest


Recommended Posts

Everything you need to know about vanilla testing has already been posted in this topic, so if you want to make a specific topic go ahead.

Might also be worth mentioning for anyone dedicating themselves to the task, to steadily build up a good range of vanilla saves (with as few quests as possible completed), over a range of levels.

Occasionally I find I make mistakes which are costly in time wasted (continuing and ruining a vanilla save with my usual mod setup back installed again, or the odd hard drive / OS issue putting a spanner in the works .. or being tired and deleting all of your saves when you decide to start over for other reasons, and then realise you just also wiped your vanilla saves - Aaaagh! :) yes I speak from experience, too much)

 

Edit : Actually, one more thing to mention ..

Dont use anyone elses ideas of how your game ini's should be. Hit the Reset button in the games launcher, or delete them all from you documents, and use the games launcher to set up your INIs for your machine how they should be set.

Then you will not get any spurious memory issues causing script lag for example, and a thousand and one other potential issues with badly edited INIs

Link to post
Share on other sites
  • Replies 55
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

All the info is on the UESP page for the quest http://en.uesp.net/wiki/Skyrim:The_Break_of_Dawn Usually you have to wait for a beacon to appear in any Boss chest and pick it up to start the quest

What's your level for your PC? If it's below 12 then you need to use the console to level up, so to speak, to let say level 15-20 then goto to Embershard Mine as it's fairly close to Helgen and t

Sounds like you need to spend some time leveling up then and searching dungeons once you hit level 12. Proper bug testing requires playing the game the proper way. That's why it often takes us so

Posted Images

Yep, the console breaks stuff- in this case it's most likely to be minimal as it's only triggers and activation etc. But I have not studied in detail the other factors in this scenario enough.

If it's to be done the snail way, then then there'll have to be (as @ALt suggested) a repository of vanilla saves at various quest points and levels. Quite an undertaking- but considering this ones progress through it we are looking at centuries.

Screwball was quite helpful at this, but now he's gone, and there is none willing to play the game without mods at all.

Quote

but if I have to use that save to load up again .. ALWAYS quit to desktop first, and load up the entire game and the save. If you die and then immediately load up your save, you may have residual memory states mess up the results of the normal progression of things.

Thought this was one of the things supposed to be fixed in SSE- or still deja vous all over again.. :( 

...

It looks like this particular exploit/bug might be reproduced by a significant load on the engine by mods, especially scripted ones perhaps even the armor & weapons mods Leo has. Try running the Skyrim Performance monitor through the scene and post back the results.

I can post back results here using the aforementioned console just out of interest- take it or leave- but otherwise it'll be a long wait. Sorry.

Link to post
Share on other sites
51 minutes ago, lmstearn said:

- but otherwise it'll be a long wait. Sorry.

No worries, as mentioned previously when I get off shift next week I will be able to go through it, probably take me about three days but I enjoy doing this stuff anyway when most others consider it a bit too much to bother.

Link to post
Share on other sites
4 hours ago, alt3rn1ty said:

Everything you need to know about vanilla testing has already been posted in this topic, so if you want to make a specific topic go ahead.

I know, but that was not what I meant aside for posting a new thread.  What I mean was to use what strategy, just to make vanilla bug testing less boring perhaps a little interesting at the same time.

Link to post
Share on other sites

New game commenced in vanilla state, Data has been cleaned out of all mods and loose resource files, INIs at defaults, not even using the USSEP :(

Just got a new game a few days ago on GOG called "Kingdom Come : Deliverance" and it is seriously taking me away from doing anything else :), so going to have to be strict with myself for a few days and just do this quest instead.

 

Link to post
Share on other sites

I got bored levelling and went for it at level 19. Good One handed, Blocking, Archery and sneak is all I needed for this anyway.

Spent the last couple of hours reloading from just before meeting Malkoran and his shades, having him in the room launch all sorts of spells at me while he was stood by the pedestal, while also launching my own scroll of fireball and fireballs from a staff at him, plus using unrelenting force at full power at him and the pedestal, also tried a lot of landing some explosive runes on the pedestal and close by to be triggered by Malkoran or his shades near the pedestal ( and lots of drinking healing potions for me :) )  .. Then reloading and taking a different approach of luring out the shades one by one up the corridor while sneaking, to pick them all off individually before luring Malkoran out of there and repeatedly hitting him with every poison I had on successive arrows until all were dead and had no chance themselves to accidentally hit the pedestal, so I could concentrate hitting the pedestal from all angles with many fireballs ..

 

= I cant reproduce the issue. That sword with just vanilla setup, no mods, no mesh replacers, no console commands, no ini tweaks, all progress up to that point via the normal progression .. Will not blow free of the pedestal. Or at least .. Not in Skyrim Special Edition anyway ( I will not be doing oldrim :P ), it may have a heap of other bugs ( the game horrifies me without the USSEP installed ), but not with this sword.

I agree with lmstearn, it just dont budge.

 

I have replayed and searched the area thoroughly five times now today - Dawnbreaker does not have a vanilla bug enabling it to fly free of its pedestal.

Here's some screens, and a video of just using many fireballs .. But be assured I did try quite a lot of shouts, electric attacks and explosive runes aswell, but personally I think the strongest area of effect spell for this purpose is probably the fireball at close proximity, so for the video run I just used a lot those ...

 

BTKFoJW.jpg

xBrOQEw.jpg

AtlvQA3.jpg

 

And here's an mp4 video created with Win 10 Game Bar, of just using many fireballs from all angles with Malkoran already dead so I could search the area after.

https://www.dropbox.com/s/0zp845s8x4hvsfx/Skyrim Special Edition 16_03_2018 16_35_58.mp4?dl=0

Link to post
Share on other sites

I can do that too if you want, now I have a save just outside the temple anyway, I can install USSEP and continue into the temple from there with it installed ..

.. Save you doing the whole thing from start and levelling with just the USSEP installed, I am already there and can test it thoroughly.

I seriously doubt the USSEP would introduce this, and the UESP / TES WIKIs all claim it to be a vanilla bug ..

Maybe it was a vanilla bug at one time with oldrim, and / or having mods somehow shakes it loose, script timing, chaos engine being flaky when the machine is stressed with non standard settings or going too high in the fps department, or too many scripts firing in loops, too much memory being used etc etc etc .. Anyway, will test it just to clear that once and for all that it is both not a vanilla bug, and not a USSEP introduced bug aswell - Beyond that though I am not going to be testing any mods, I want to go back to my own setup after this (which I also know cannot reproduce the issue).

 

Edit : preparations already done :) (and if anyone is wondering .. No I am not even using a bashed patch)

 

Ujny3oI.png

Link to post
Share on other sites

@Arthmoor I can reproduce it ..

.. But its not due to the USSEP being installed (as Leo wondered), nor do I think its a Vanilla bug that can be prevented :

 

First I could not repro it with no mods installed (see previous posts) nor could I repro it with USSEP installed, so I had a think about whats likely to happen for most people here : Death and reloading (especially if they try it at level 12 when you are likely to receive Meridias Beacon).

I wondered if this could be a strange memory state thing (as mentioned earlier, the mines scenario in Fallout 4 being a good example, all beth games suffer from memory state issues which is why you should always quit to desktop and then load up) ..

So I tried with USSEP installed, getting killed, and letting the game reload automatically without quitting to desktop ..

I did not even have to hit the pedestal with any area effect, after luring the shades out and Malkoran to kill them one by one in the corrider, I then walked in to the pedestal, and Dawnbreaker was already on the floor ..

hRtEUCk.jpg

 

If you quit to desktop, then reload ^^ That does not happen

I think that the memory state if you have not quit to desktop is part of the issue here.

I also then tried without USSEP again, went from the save I have prior to entering the temple again and made another save just prior to entering the area where Malkoran is so that I had a quick load save in the vicinity of the problem ..

.. Fought on, and let myself die, then let the game auto reload from the closest save = Bingo the Dawnbreaker was on the floor again in the same position without any mods installed - But also prior to dying, I hit Malkoran with a long shot just to get his attention to kick off the fight, he immediately casts some kind of spell on himself next to the pedestall while he is turning to face you and commence the fight .. So possibly this with an auto reload could be the method by which the duplicate ends on the floor in the position in my screenshot.

 

So I think to repro it you need to do the following (whether with mods or not does not matter I think)

1. Have a save close to entering the fight.

2. Sneak down the corridor until you can see Malkoran next to the pedestal, Attack malky long range with a bow, he should make some kind of protection spell while turning to face you

3. Fight until dead

4. Let the game auto-reload

5. Fight until win = You may find Dawnbreaker on the floor somewhere near the pedestal

 

If you quit to desktop at step 4. Then load up the game afresh, you will not find Dawnbreaker on the floor at step 5.

Thats why I think this is memory state linked .. And also means its a game engine bug = Not fixable

 

So the age old advice of always quitting to desktop instead of letting auto loads happen (or even manually reloading without quitting to desktop) still stands for SSE aswell. Always quit to desktop before loading up again to play on. Unless of course you want to cheat and have (not so unique daedric artifacts) and dual wielding Dawnbreakers :P

Link to post
Share on other sites

So what you're saying is that this is likely what's causing that glitch regardless if one are using mods or not.

If it's then I consider that glitch to be an engine bug and I think that could probably be impossible to fix, unless there is a work around.

Link to post
Share on other sites

@Leonardo no, I dont think this is a baked in save issue, I think its a memory state issue on auto-load. When that happens the game does not wipe all memory states of objects.

If you quit to desktop completely (so that all memory of the game is wiped) before loading up again, you dont get the duplicate (with or without any mods).

I reckon people die there often, and the majority of people do not quit to desktop on death, because they dont know about memory state issues and its easier / quicker to let the auto load happen. So the duplicate (however it is being made to jump on the floor as a memory state corruption .. personally I dont know the technical detail of what is happening there) will probably happen for a lot of people dying and reloading there.

Link to post
Share on other sites
16 hours ago, lmstearn said:

One of the big hopes of SE was a permanent end to the memory bug. Oh well. :shrug:

 

Hoping for that in SSE was a bit silly since even FO4 still has that same bug. Reloads in the same cell always have the chance to cause trouble.

@alt3rn1ty At least now we know why it happens. It could be "fixed" by swapping the placed copy with a static model that can't move no matter what. Then at least it won't be laying on the floor where it doesn't belong. Not sure why Bethesda didn't do it this way to begin with.

Link to post
Share on other sites

Sounds good to preserve the uniqueness of the weapon, so long as that method does not prevent grabbing it from the pedestal ..

No doubt there's going to be a few moans about fixing this though :rolleyes:

But if peeps want a second one its easy to use console player.additem <whatever refid it is> 1

 

Edit : I think I will keep my saves handy for testing a future USSEP

Link to post
Share on other sites
1 hour ago, alt3rn1ty said:

Sounds good to preserve the uniqueness of the weapon, so long as that method does not prevent grabbing it from the pedestal ..

No doubt there's going to be a few moans about fixing this though :rolleyes:

Sounds good to me too.

What you do expect, people always complain about fixing bugs that can be easily triggered in-game.

Link to post
Share on other sites

@alt3rn1ty Can you send me a copy of the save you have just prior to entering his chamber to get the sword?

After checking the CK again, I'm seeing no possible way to fix this but I want to see what exactly is going on firsthand. The pedestal is already a static object with no means of knocking the sword loose because the sword simply isn't there for real. When you go to activate it, it disables one model to replace it with an empty pedestal model and then gives you a copy of the sword. So I can't actually see any possible way for being killed to result in generating one on the floor after a death reload that then results in a functional copy of the sword.

Link to post
Share on other sites

Yep here you go https://www.dropbox.com/s/da52zlz6lrnenkp/Save28_33BA3D06_0_4C756E6B_KilkreathRuins03_001216_20180316160920_19_1.7z?dl=0

Save is just before entering the chamber where Malkoran and all the Shades are, my approach is to just pick them off one by one but hit Malkoran first :

I think the key to making this work without the area effect spell, is to provoke Malkoran so that he does something which somehow dislodges the Sword from its housing, maybe he has some kind of area effect spell, or I had a thought that the sword itself has its own explosive area effect spell for Vampires and undead .. Maybe hitting Malkoran somehow gets him to trigger the swords area effect and it blows itself out of the pedestal ...

.. Whatever it is, something occasionally (but not all the time) makes the sword end up on the floor. I found it only happens if an auto reload has happened from this save (as opposed to a quit to desktop and then reload). It may take a couple of tries but thats how I made it happen, attack Malky with a sneaky arrow, put some Frostbite spider venom on it for good measure, then withdraw and pick them all off one by one. Your initial attack will have made Malky perform some kind of spell while he is next to the pedestal. Now during the first fight die and auto reload. Then commence with a serious approach to wiping them all out.

Luring them down the corridor and up the steps has the advantage that wherever the sword drops on the floor, it does not get further bounced around the room during the battle and end up in the rafters or somewhere daft.

 

Edit : And yep I know I get that the sword is not actually there to start with .. But somehow it ends up in the room afterwards. The pedestal is being activated somehow and not by the player.

If you want to try the fireballs, I have a scroll in that save, but also Malky has a staff of fireball.

I dont have anything else, for trying out all other area of effect spells (which did not work anyway) I did a separate load and used player.additem to get a few spell books for explosive runes etc, I know using console, but that was just to see if any other area of effect spells would have influenced the pedestal instead of fireball, which turned out to be fruitless.

The save you have there though has never seen a console command all the way from the game start to that point.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...