Jump to content

[RELz] LOOT - Load Order Optimisation Tool


WrinklyNinja

Recommended Posts

The About LOOT window does not yet list Skyrim VR as a supported game.

Thinking about the "use instructions" at the bottom of the groups editor .. they take up quite a lot of valuable vertical space within the groups editor. Instead, what about some sort of "Need Help?" button, possibly in the top right corner, that would link to a document that get's shipped with LOOT, which would explain all the important aspects about groups / using the groups editor?

Link to comment
Share on other sites

Loot doesnt detect all my plugins. It worked like charm, but when i reinstall Skyrim/LOOT/MO the problem occurred. 
I google myslef, some people get this problem too, but none of them solved it.

Basicly,  LOOT seems to detect only vanillia plugins (Skyrim, Update, HearthFires, Dragonborn, Dawngard). I tried to reinstall (with registry cleaning, manualy removing files from appdata). Did not help.

-----
LOOT Version: 0.12.5 (installer, i tried dev build - did not help)


My path is seems to be right:
    branch = "v0.10"
    folder = "Skyrim Special Edition"
    repo = "https://github.com/loot/skyrimse.git"
    type = "Skyrim Special Edition"
    registry = "Software\\Bethesda Softworks\\Skyrim Special Edition\\Installed Path"      (can i do it manualy, where?)
    name = "TES V: Skyrim Special Edition"
    local_path = "" 
    path = "E:\\The Elder Scrolls V - Skyrim SE\\"
    master = "Skyrim.esm"

(i put Skyrim outside steamapps folder, i tried to reinstall with Skyrim in steamapps, no effect).
And ofc. i run LOOT skyrim trough MO, tried to use desktop shortcut - no effect.

Loot Debug info:
https://pastebin.com/Q9Nt1raK
-----------
ModOrganizer: 2.1.3 (again, tried with dev build). Its strange that when i put mod in DATA Skyrim SE folder, LOOT recognized added plugin. But i don't think is MO problem, MO fires added mods like charm. 

-------
Tes5edit have same issue,  detecting only vanillia plugins.

-----



 

1.jpg

Link to comment
Share on other sites

5 hours ago, Minafisto said:

Loot doesnt detect all my plugins. It worked like charm, but when i reinstall Skyrim/LOOT/MO the problem occurred. 
 

Tes5edit have same issue,  detecting only vanillia plugins.

This is an issue with your current set-up.

Have you launched skyrim since reinstalling it?

Running LOOT through MO2 is not supported.

If it's only happening through MO2 then you'll have to ask them on discord.  https://discord.gg/cYwdcxj

Link to comment
Share on other sites

3 hours ago, cptmcsplody said:

This is an issue with your current set-up.

Have you launched skyrim since reinstalling it?

Running LOOT through MO2 is not supported.

If it's only happening through MO2 then you'll have to ask them on discord.  https://discord.gg/cYwdcxj


Yes, I launched vanillia skyrim to generate ini files (also I delete all registry files, and user metadata).  Really don't know what caused problem. I just format my E disc (where i install skyrim, clean reinstall with Skyrim and all skyrim tolls eg. LOOT, MO2, Tes5edit, WyreBash etc.), and reinstall it. Before everything working good, strange. 

Also i did not update my windows/drivers. Everything that has changed was format, and Skyrim reinstall. 

Thanks for that tip with discord, i will go that way. 
 

Link to comment
Share on other sites

1 hour ago, cptmcsplody said:

I'm guessing formatting that drive might have something to do with it. Quick format?

 

I tried to install in diffrent partition - problem still occurs. 

It was format with USB Disc Storage Tool + defragmentation + Eraser - erasing disc with 01010 option + again defragmentation. No any BAD DATA. Also LOOT read mods in DATA Skyrim folder even if Skyrim is installed on E (my fromated drive), and LOOT installed on C/D drive.

I think its not format issue. 
 

Link to comment
Share on other sites

On 5/27/2018 at 4:59 PM, pStyl3 said:

The About LOOT window does not yet list Skyrim VR as a supported game.

Thinking about the "use instructions" at the bottom of the groups editor .. they take up quite a lot of valuable vertical space within the groups editor. Instead, what about some sort of "Need Help?" button, possibly in the top right corner, that would link to a document that get's shipped with LOOT, which would explain all the important aspects about groups / using the groups editor?

I've added missing references to Skyrim VR, and made some adjustments to the groups editor UI, in this build. It now links to the groups editor docs page, which I've also rewritten to hopefully be more accessible, let me know what you think.

Link to comment
Share on other sites

untitled1i9six.jpg

I would suggest to decrease the white space between "Add a new group" and "Group name", as well as "Group name" and the horizontal line beneath "Group name". That way it would be consistent with other such textboxes.

Maybe also increase the distance between "View Documentation" and "Add a new group" a bit.

 

untitled2qbs2s.jpg

Furthermore, how about putting the line beneath "Group name" on top of the bottom horizontal line of that rectangle? That way there wouldn't be an unused empty space at the bottom of the rectangle, yet the blue highlighting of the line beneath "Group name" would be 'functional'.

 

Regarding the rewritten article on groups, I think it's mostly fine. I think it would be great to also mention that Ctrl + Left Mouseclick opens a rectangle that can select multiple groups at once.

I'm not so sure about the first example given under the "Cycle Avoidance" heading. The explanation of that example seems to be off.

Link to comment
Share on other sites

18 hours ago, cptmcsplody said:

 

Perhaps a different colour for master-list groups/ primary path arrow as  Light grey & Dark Grey might get confusing.

snip

How would you prefer to distinguish them?

6 hours ago, pStyl3 said:

untitled1i9six.jpg

I would suggest to decrease the white space between "Add a new group" and "Group name", as well as "Group name" and the horizontal line beneath "Group name". That way it would be consistent with other such textboxes.

Maybe also increase the distance between "View Documentation" and "Add a new group" a bit.

 

untitled2qbs2s.jpg

Furthermore, how about putting the line beneath "Group name" on top of the bottom horizontal line of that rectangle? That way there wouldn't be an unused empty space at the bottom of the rectangle, yet the blue highlighting of the line beneath "Group name" would be 'functional'.

 

Regarding the rewritten article on groups, I think it's mostly fine. I think it would be great to also mention that Ctrl + Left Mouseclick opens a rectangle that can select multiple groups at once.

I'm not so sure about the first example given under the "Cycle Avoidance" heading. The explanation of that example seems to be off.

I decreased the space above and below "Group name", the + icon button was messing things up a little. The space below the "Group name" horizontal line isn't unused though, that's where error messages get displayed, even though it looks a little unbalanced without anything there. Try adding a group that already exists to see one.

And yeah, in that example I got the plugin names the wrong way around, so it doesn't actually cycle...

Link to comment
Share on other sites

Before I start catching up on the many, many messages in this thread I haven't read yet, is there a primer on what's changing (at least masterlist syntax wise) for 0.13.0 somewhere?

Link to comment
Share on other sites

32 minutes ago, Freso said:

Before I start catching up on the many, many messages in this thread I haven't read yet, is there a primer on what's changing (at least masterlist syntax wise) for 0.13.0 somewhere?

There's a metadata syntax changelog? Also see the example in the docs for what group syntax looks like in use. The LOOT API changelog and LOOT changelog are also available.

Link to comment
Share on other sites

Quote

Left-clicking and dragging an empty space will move the whole graph, while left-clicking a and dragging a node will move it.

One a too much.

Also, the box in the top right corner of the groups editor is not getting displayed correctly, if the dark theme is used. And speaking of the dark theme, the group names within the group editor are currently displayed with black text on white background. How about them being displayed as white text with transparent background, if the dark theme is used?

Link to comment
Share on other sites

9 hours ago, pStyl3 said:

One a too much.

Also, the box in the top right corner of the groups editor is not getting displayed correctly, if the dark theme is used. And speaking of the dark theme, the group names within the group editor are currently displayed with black text on white background. How about them being displayed as white text with transparent background, if the dark theme is used?

Fixed and fixed, thanks. I had completely forgotten to check with the dark theme...

9 hours ago, pStyl3 said:

Open the metadata editor for any plugin, apply-close it immediately without changing anything. The "Has User Metadata" icon will be displayed for that plugin, even though no data has been added.

Darn, it's the same old problem of how to indicate that the group value (and priority value before it) hasn't changed so should be ignored...

OK, new build with those fixes.

Link to comment
Share on other sites

Would it improve the situation, if the apply button would only be usable once the user changes some data within the metadata editor? So with other words, make the button greyed out, as long as no change has been registered. That way, using the (activated) Apply button would mean, that some data has definitly been changed and you wouldn't have to check for that after the button was used.

Link to comment
Share on other sites

27 minutes ago, pStyl3 said:

Would it improve the situation, if the apply button would only be usable once the user changes some data within the metadata editor? So with other words, make the button greyed out, as long as no change has been registered. That way, using the (activated) Apply button would mean, that some data has definitly been changed and you wouldn't have to check for that after the button was used.

I don't think so, that would just add another layer to go wrong, since the current logic for displaying the icon just checks if the user metadata saved is non-empty. If the check to see if there were edits failed, you could end up being unable to save your changes, which would be a lot more annoying than an icon appearing when it shouldn't.

Link to comment
Share on other sites

Then I would say, you're good to go with the release, it's time to get this out (and that the recent changes to v0.10 masterlists find their way into the new v0.13 branch). I'm actually already working on the Nexus page, need to redo the images there aswell.

Link to comment
Share on other sites

So, I updated to the new 0.13.0 release and it's no longer able to sort my load order. Showed the "this is usually because <plugin file location> is read-only." Checked, no it's not. Log file says 
[21:07:44.953325] [error]: libloadorder failed to set the load order. Details: The game's main master file must load first
[21:07:44.953474] [error]: Exception while executing query: libloadorder failed to set the load order. Details: The game's main master file must load first: Libloadorder error

The problem is, Fallout4.esm is indeed set first in the load order. And nothing has changed since the last time I ran LOOT besides me installing one tiny esp, and changing from LOOT 0.12.5 to 0.13.0

So, troubleshooting steps I tried:

Uninstalled the new esp. Rebooted computer and LOOT. Attempted to sort. Still throws the same error. Eliminates the new ESP as the culprit, but I kept it uninstalled just in case for the rest of the troublehsooting steps.

Uninstalled LOOT including all metadata and whatnot. Reinstalled 0.13.0. Still throws same error.

Uninstalled LOOT, including all metadata and whatnot, reverted to 0.12.5. It sorts and sets load order fine. Reinstalled the possibly questionable ESP. Still sorts/sets load order fine.

Reinstalled back to 0.13.0 for a final check. Still throws the same error.

So I think that narrows it down entirely to something in 0.13.0? Anything else you'd have me try?

Link to comment
Share on other sites

3 hours ago, Nautilee said:

So, I updated to the new 0.13.0 release and it's no longer able to sort my load order. Showed the "this is usually because <plugin file location> is read-only." Checked, no it's not. Log file says 
[21:07:44.953325] [error]: libloadorder failed to set the load order. Details: The game's main master file must load first
[21:07:44.953474] [error]: Exception while executing query: libloadorder failed to set the load order. Details: The game's main master file must load first: Libloadorder error

The problem is, Fallout4.esm is indeed set first in the load order. And nothing has changed since the last time I ran LOOT besides me installing one tiny esp, and changing from LOOT 0.12.5 to 0.13.0

So, troubleshooting steps I tried:

Uninstalled the new esp. Rebooted computer and LOOT. Attempted to sort. Still throws the same error. Eliminates the new ESP as the culprit, but I kept it uninstalled just in case for the rest of the troublehsooting steps.

Uninstalled LOOT including all metadata and whatnot. Reinstalled 0.13.0. Still throws same error.

Uninstalled LOOT, including all metadata and whatnot, reverted to 0.12.5. It sorts and sets load order fine. Reinstalled the possibly questionable ESP. Still sorts/sets load order fine.

Reinstalled back to 0.13.0 for a final check. Still throws the same error.

So I think that narrows it down entirely to something in 0.13.0? Anything else you'd have me try?

I'm pretty sure this is #956, try the fix posted there.

Link to comment
Share on other sites

OK, another build to improve the situation with Fallout 4 Creation Club plugins. I'd like to release this today and would appreciate if others could give it a spin to make sure I haven't broken anything, since I made the changes in a hurry.

This main change in this build is that LOOT will enforce hardcoded plugin positions using data it gets from libloadorder (which is a hardcoded list of plugins extended with the contents of Fallout4.ccc/Skyrim.ccc), instead of relying on masterlist metadata to specify them. This is important enough to get another release out quickly because Fallout 4 has a lot of Creation Club plugins, which have their positions specified in Fallout4.ccc, and most of them aren't in the masterlist.

They could be added to the masterlist, but each hardcoded plugin needs to have every hardcoded plugin that loads before it in its after metadata list, so you end up with a very verbose, repetitive set of metadata entries. The masterlist would also have to be kept up to date with CC mod releases, since as of 0.13.0 it's an error to try putting a hardcoded plugin anywhere other than its hardcoded position.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...