Jump to content

Recommended Posts

Was told to post this here?tried installing Wrye Bash for the first time and it failed and provided the link to post information here.
This is what appeared when it failed:

Traceback (most recent call last):
  File "bash\bash.pyo", line 227, in main
  File "bash\bash.pyo", line 393, in _main
  File "bash\basher\__init__.pyo", line 3981, in Init
  File "bash\basher\__init__.pyo", line 4018, in InitData
  File "bash\bosh\__init__.pyo", line 1955, in refresh
  File "bash\bosh\__init__.pyo", line 1702, in _modinfos_cache_wrapper
  File "bash\bosh\__init__.pyo", line 1810, in refreshLoadOrder
  File "bash\load_order.pyo", line 300, in refresh_lo
  File "bash\load_order.pyo", line 250, in _update_cache
  File "bash\games.pyo", line 227, in get_load_order
  File "bash\games.pyo", line 246, in _cached_or_fetch
  File "bash\games.pyo", line 676, in _fetch_load_order
KeyError: bolt.Path(u'Skyrim.esm')
 

Help would be appreciated, thank you.

Share this post


Link to post
Share on other sites
On 12/22/2018 at 10:16 AM, Theleb_Kaarna said:

Attempting to launch Wrye through Vortex for Skyrim SE (target path to Wrye's .exe set-up properly in Vortex's dashboard as far as I know). Get the following error:

Traceback (most recent call last):
  File "bash\bash.pyo", line 227, in main
  File "bash\bash.pyo", line 260, in _main
IOError: [Errno 13] Permission denied: u'C:\\Program Files\\Black Tree Gaming Ltd\\Vortex\\BashBugDump.log'

Wrye works perfectly fine if I just launch it via it's own executable, just not through Vortex.

Please let me know if I'm doing something wrong=) Thanks again for all you guys do.

As mentioned in the sticky posts on the Nexus we don't use NMM, MO2, or Vortex. It isn't that we are unwilling to help, I really don't know how to help configure a program we have never used.

Share this post


Link to post
Share on other sites
8 hours ago, Sharlikran said:

As mentioned in the sticky posts on the Nexus we don't use NMM, MO2, or Vortex. It isn't that we are unwilling to help, I really don't know how to help configure a program we have never used.

Appreciate the response,  my apologies for missing the sticky. Totally understand. Just following Wrye's request to post the error on this Forum and thought I'd inquire. I'll pursue a remedy on the Nexus Forums. Thanks again=)

Share this post


Link to post
Share on other sites
On 12/22/2018 at 1:16 PM, Theleb_Kaarna said:

My first post here=) First-off, immense THANK YOUS to YOU Sharlikran, and The Team, for your huge contributions to the Modding Community over the years. YOU ARE APPRECIATED!

Attempting to launch Wrye through Vortex for Skyrim SE (target path to Wrye's .exe set-up properly in Vortex's dashboard as far as I know). Get the following error:

Traceback (most recent call last):
  File "bash\bash.pyo", line 227, in main
  File "bash\bash.pyo", line 260, in _main
IOError: [Errno 13] Permission denied: u'C:\\Program Files\\Black Tree Gaming Ltd\\Vortex\\BashBugDump.log'

Wrye works perfectly fine if I just launch it via it's own executable, just not through Vortex.

Please let me know if I'm doing something wrong=) Thanks again for all you guys do.

Just a wild guess for that particular one though - try installing Vortex outside of the UAC protected Program Files dir - then you may be able to run Bash

 

New link with updated fomod installer: https://www.dropbox.com/sh/3s5m6k0iq2wbpaf/AADCmdGQKUIZlSSZUEAB5t8Fa?dl=0&lst=

 

Share this post


Link to post
Share on other sites
16 hours ago, Utumno said:

Just a wild guess for that particular one though - try installing Vortex outside of the UAC protected Program Files dir - then you may be able to run Bash

 

New link with updated fomod installer: https://www.dropbox.com/sh/3s5m6k0iq2wbpaf/AADCmdGQKUIZlSSZUEAB5t8Fa?dl=0

That totally fixed it, you were right!! Can't believe I didn't pay attention to: "... Permission denied: u'C:\\Program Files\\Black Tree Gaming...". Should've tipped-me-off *smacks forehead*

Appreciate you taking the time and for the link to the latest WB., but I'm confused. When unzipping the first downloadable option, I don't see an installer, but a bunch of folders full of files and 9 executables (which all seem to be of the same version). Is updating WB a simple matter of just replacing my existing .eve (v307.2018.704.57) with one of the 9 latest ones? Or do I need to replace other folders/files as well?

Share this post


Link to post
Share on other sites

Hi,

With Wrye Bash 307.2018 12 24 1806 I got the message box below. Too many files, etc...

Wrye Bash 307.2018 10 22 1913 worked, just fine, without any issue at all.

Am I making something wrong?

Thanks! (I use MO 2)

Jegyzet 2018-12-25 222223.jpg

Share this post


Link to post
Share on other sites
7 hours ago, Theleb_Kaarna said:

That totally fixed it, you were right!! Can't believe I didn't pay attention to: "... Permission denied: u'C:\\Program Files\\Black Tree Gaming...". Should've tipped-me-off *smacks forehead*

Appreciate you taking the time and for the link to the latest WB., but I'm confused. When unzipping the first downloadable option, I don't see an installer, but a bunch of folders full of files and 9 executables (which all seem to be of the same version). Is updating WB a simple matter of just replacing my existing .eve (v307.2018.704.57) with one of the 9 latest ones? Or do I need to replace other folders/files as well?

1

What is the first downloadable option? 

If it's an exe then you run it - or use the  Wrye Bash 307.201812241806 - Standalone Executable.7z - Unzip it and replace the mopy folder you use with  that one

9 minutes ago, KranaZoli said:

Hi,

With Wrye Bash 307.2018 12 24 1806 I got the message box below. Too many files, etc...

Wrye Bash 307.2018 10 22 1913 worked, just fine, without any issue at all.

Am I making something wrong?

Thanks! (I use MO 2)

Jegyzet 2018-12-25 222223.jpg

 

No you are not I guess that 307.2018 10 22 1913 has support for esls that is not built into 307.2018 12 24 1806

Share this post


Link to post
Share on other sites
4 minutes ago, Utumno said:

What is the first downloadable option? 

If it's an exe then you run it - or use the  Wrye Bash 307.201812241806 - Standalone Executable.7z - Unzip it and replace the mopy folder you use with  that one

No you are not I guess that 307.2018 10 22 1913 has support for esls that is not built into 307.2018 12 24 1806

4

Thank You!

I didn't know what that sound at the background. I thought it is comes from WB. :D Wow!

And just saw, you replied. :)

Share this post


Link to post
Share on other sites
3 hours ago, Utumno said:

What is the first downloadable option? 

If it's an exe then you run it - or use the  Wrye Bash 307.201812241806 - Standalone Executable.7z - Unzip it and replace the mopy folder you use with  that one

Cool, thanks. I just downloaded the standalone option and replaced my existing Mopy Folder with the latest version.

You asked: "What is the first downloadable option?"

Well it's not what it says it is. What I mean specifically is that if you click the link you provided it takes you to a page entitled: "ganda-380-fomod" with 3 download options. If you hover your cursor over the first option it reads: "Wrye Bash 307.201812241806 - installer.exe". When you download said first option and un-zip it, you get a folder entitled: "Unconfirmed 621692". Inside this folder, there is no "installer.exe" present, just a bunch of folders full of files and .exe's...

Share this post


Link to post
Share on other sites
3 hours ago, Theleb_Kaarna said:

Cool, thanks. I just downloaded the standalone option and replaced my existing Mopy Folder with the latest version.

You asked: "What is the first downloadable option?"

Well it's not what it says it is. What I mean specifically is that if you click the link you provided it takes you to a page entitled: "ganda-380-fomod" with 3 download options. If you hover your cursor over the first option it reads: "Wrye Bash 307.201812241806 - installer.exe". When you download said first option and un-zip it, you get a folder entitled: "Unconfirmed 621692". Inside this folder, there is no "installer.exe" present, just a bunch of folders full of files and .exe's...

Wait for it to download completely...

Share this post


Link to post
Share on other sites
12 hours ago, Utumno said:

What is the first downloadable option? 

If it's an exe then you run it - or use the  Wrye Bash 307.201812241806 - Standalone Executable.7z - Unzip it and replace the mopy folder you use with  that one

No you are not I guess that 307.2018 10 22 1913 has support for esls that is not built into 307.2018 12 24 1806

4

I thought the main goal now, ATM id to handle more plugin then 255.

Have no idea what esis is. If I have plugins less then 255 in my opinion Smashed Patch is better choice.

Will that "esis support" build to this version, as well?

 

Thank You!

Share this post


Link to post
Share on other sites
On 12/25/2018 at 1:26 PM, KranaZoli said:

Hi,

With Wrye Bash 307.2018 12 24 1806 I got the message box below. Too many files, etc...

Wrye Bash 307.2018 10 22 1913 worked, just fine, without any issue at all.

Am I making something wrong?

Thanks! (I use MO 2)

Correct, 307.2018 10 22 1913 has the ESL support the community asked about on the Nexus. However, it doesn't have the additional updates that Utumno (the current maintainer) has made. I usually only contribute record definitions. I added all the additional game modes (Skyrim, FNV, FO4,) with help from Valda and an old contributor Lojack.  Originally there was just Oblivion and the original 13 records that were defined for Skyrim. Lojack helped with VMAD and it needs updated.

I am usually the impatient one and want the tangible features (patchers) working.  So I experimented with the patchers several years back and posted about it on the old Bethesda forums. CptMcSplody recently made some patcher updates which smoothed things out so the patchers I was experimenting with work better for Skyrim now. I also added the ESL support and made some other various updates.

That's why the versions are different. The official ones are what Utumno has been linking. If you have bugs or he needs testing you will need to use his versions.

I was working with his new code he updated to get things better in sync but it appears there are some differences of opinion that might cause an issue. To prevent any further issues or discontent I'm gonna take a break from things while I work out some details.

Thought I'd mention it so there wasn't any confusion. Plus it's the holidays still until after the new year so probably best for me to focus on family anyway.

Share this post


Link to post
Share on other sites

With the latest build, I can't install or uninstall any package. If I try to, it just throws an error.

The bug dump looks like this:

Spoiler

Wrye Bash starting
Using Wrye Bash Version 307 (Standalone)
OS info: Windows-10-10.0.17763
Python version: 2.7.15
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_US', 'cp1252')
filesystem encoding: mbcs
command line: ['E:\\Modding\\Games\\TES5 Skyrim Special Edition\\Mopy\\Wrye Bash.exe', '-d']
Using scandir 1.9.0
bash.pyo  388 _import_bush_and_set_game: Searching for game to manage:
bush.pyo   87 _supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   89 _supportedGames:  Oblivion: E:\Program Files (x86)\Steam\steamapps\common\Oblivion
bush.pyo   89 _supportedGames:  Skyrim Special Edition: e:\program files (x86)\steam\steamapps\common\Skyrim Special Edition
bush.pyo  147 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  153 _detectGames: Set game mode to Skyrim Special Edition based on sOblivionPath setting in bash.ini:  E:\Program Files (x86)\Steam\steamapps\common\Skyrim Special Edition
bush.pyo  168 __setGame:  Using Skyrim Special Edition game: E:\Program Files (x86)\Steam\steamapps\common\Skyrim Special Edition
mods_metadata.pyo  230 __init__: Using LOOT API version: 0.13.2
testing UAC

I don't think anything in it is very useful to this particular issue, but it's there just in case.

EDIT - This appears if I use "Anneal All".

Spoiler

Traceback (most recent call last):
  File "bash\balt.pyo", line 2495, in __Execute
  File "bash\balt.pyo", line 1605, in _conversation_wrapper
  File "bash\basher\installers_links.pyo", line 194, in Execute
  File "bash\bosh\bain.pyo", line 2538, in bain_anneal
  File "bash\bosh\bain.pyo", line 2482, in _remove_restore
  File "bash\bosh\bain.pyo", line 2512, in _restoreFiles
  File "bash\bosh\bain.pyo", line 2285, in __installer_install
  File "bash\bosh\bain.pyo", line 1024, in install
  File "bash\bosh\bain.pyo", line 1208, in _install
  File "bash\bosh\bain.pyo", line 1197, in unpackToTemp
  File "bash\archives.pyo", line 106, in extract7z
bash.exception.StateError: SMIM SE 2-08-659-2-08.7z: Extraction failed:
7z.exe return value: 7

It might be of use.

EDIT 2 - Uninstalling works fine.

Edited by Pabulum
Added the traceback

Share this post


Link to post
Share on other sites

I can confirm this

 

The last 2 WIP give the same issue

7zip.exe errors out with a code 7   command line error

reverting to an older WIP solves the problem. This started with the merging  of the FOMOD installer.

Share this post


Link to post
Share on other sites

I won't have time to set up tests or minimal installers but commit d2482ed breaks non FOMOD installers. In short I can't get the BA2/BSA or the plugin to install consistently whether or not it's a FOMOD installer or non FOMOD installer. Also commit 176991c doesn't resolve the 7zip issue. It is the commit that introduces the regression for 7zip.

So for now I'll be sticking to my version (which has the FOMOD support without the tweaks) until after the holidays. As I mentioned I'd rather focus on family right now anyway. However, it looks like Elminster is making more progress with TES3Edit so I may get sucked into that.

 

Share this post


Link to post
Share on other sites
13 hours ago, Pabulum said:

With the latest build, I can't install or uninstall any package. If I try to, it just throws an error.

The bug dump looks like this:

  Reveal hidden contents

Wrye Bash starting
Using Wrye Bash Version 307 (Standalone)
OS info: Windows-10-10.0.17763
Python version: 2.7.15
wxPython version: 2.8.12.1 (msw-unicode)
input encoding: None; output encoding: None; locale: ('en_US', 'cp1252')
filesystem encoding: mbcs
command line: ['E:\\Modding\\Games\\TES5 Skyrim Special Edition\\Mopy\\Wrye Bash.exe', '-d']
Using scandir 1.9.0
bash.pyo  388 _import_bush_and_set_game: Searching for game to manage:
bush.pyo   87 _supportedGames: Detected the following supported games via Windows Registry:
bush.pyo   89 _supportedGames:  Oblivion: E:\Program Files (x86)\Steam\steamapps\common\Oblivion
bush.pyo   89 _supportedGames:  Skyrim Special Edition: e:\program files (x86)\steam\steamapps\common\Skyrim Special Edition
bush.pyo  147 _detectGames: Detecting games via the -o argument, bash.ini and relative path:
bush.pyo  153 _detectGames: Set game mode to Skyrim Special Edition based on sOblivionPath setting in bash.ini:  E:\Program Files (x86)\Steam\steamapps\common\Skyrim Special Edition
bush.pyo  168 __setGame:  Using Skyrim Special Edition game: E:\Program Files (x86)\Steam\steamapps\common\Skyrim Special Edition
mods_metadata.pyo  230 __init__: Using LOOT API version: 0.13.2
testing UAC

I don't think anything in it is very useful to this particular issue, but it's there just in case.

EDIT - This appears if I use "Anneal All".

  Reveal hidden contents

Traceback (most recent call last):
  File "bash\balt.pyo", line 2495, in __Execute
  File "bash\balt.pyo", line 1605, in _conversation_wrapper
  File "bash\basher\installers_links.pyo", line 194, in Execute
  File "bash\bosh\bain.pyo", line 2538, in bain_anneal
  File "bash\bosh\bain.pyo", line 2482, in _remove_restore
  File "bash\bosh\bain.pyo", line 2512, in _restoreFiles
  File "bash\bosh\bain.pyo", line 2285, in __installer_install
  File "bash\bosh\bain.pyo", line 1024, in install
  File "bash\bosh\bain.pyo", line 1208, in _install
  File "bash\bosh\bain.pyo", line 1197, in unpackToTemp
  File "bash\archives.pyo", line 106, in extract7z
bash.exception.StateError: SMIM SE 2-08-659-2-08.7z: Extraction failed:
7z.exe return value: 7

It might be of use.

EDIT 2 - Uninstalling works fine.

I can confirm this too, except mine is a return value of 2 when trying to install anything in Oblivion. Uninstalling works fine.

Share this post


Link to post
Share on other sites

Damn! - plus now I have to reply in two places (there's discord too). Will give it another whirl - getting error cocde 2 too (that's a very helpful "Fatal error")

Share this post


Link to post
Share on other sites
14 hours ago, Utumno said:

New version on utumno-wip should fix the error code 2/7, please test if it fixes tmp folders with spaces in the filename too

New version errors out on launch:

	Wrye Bash encountered an error.
Please post the information below to the official thread at:
https://www.afkmods.com/index.php?/topic/4966-wrye-bash-all-games/& or 
https://bethesda.net/community/topic/38798/relz-wrye-bash-oblivion-skyrim-skyrim-se-fallout-4/
Traceback (most recent call last):
  File "bash\bash.py", line 185, in main
    _main(opts)
  File "bash\bash.py", line 360, in _main
    app.Init() # Link.Frame is set here !
  File "bash\basher\__init__.py", line 3980, in Init
    self.InitData(progress)
  File "bash\basher\__init__.py", line 4017, in InitData
    bosh.modInfos.refresh(booting=True)
  File "bash\bosh\__init__.py", line 1956, in refresh
    forceRefresh=hasChanged or _modTimesChange, forceActive=deleted)
  File "bash\bosh\__init__.py", line 1703, in _modinfos_cache_wrapper
    lord_func(self, *args, **kwargs)
  File "bash\bosh\__init__.py", line 1811, in refreshLoadOrder
    cached_active=not forceActive)
  File "bash\load_order.py", line 307, in refresh_lo
    _update_cache(lo, active)
  File "bash\load_order.py", line 257, in _update_cache
    fix_lo)
  File "bash\games.py", line 227, in get_load_order
    cached_active_ordered)
  File "bash\games.py", line 246, in _cached_or_fetch
    cached_active)
  File "bash\games.py", line 558, in _fetch_load_order
    return self.__calculate_mtime_order()
  File "bash\games.py", line 553, in __calculate_mtime_order
    mods.sort(key=lambda x: not self.in_master_block(self.mod_infos[x]))
  File "bash\games.py", line 553, in <lambda>
    mods.sort(key=lambda x: not self.in_master_block(self.mod_infos[x]))
  File "bash\games.py", line 323, in in_master_block
    mod_info = self.mod_infos[modname]
  File "bash\bolt.py", line 1255, in __getitem__
    return self.data[key]
KeyError: ModInfo<u'Oblivion.esm'>

Share this post


Link to post
Share on other sites

Hi,

The only thing I know, that I am confused about WB.
There are several nicknames here and there who upload WB version. Different Forum topics, several of them. You are the smart one, if it is good, that let it be.

I have one question:

For me(!)

Only the SkyrimSSE WB interesting which is will be able to handle more than 255 plugins.
Instead, I should play Sherlock Holmes, please some authentic person share with me(maybe us), exactly where can I(we) found that version.

I am also very busy with our 3 children, and do not have time to found out that magic.

Thank You, and
Happy 2019 new years for everyone!

party-062.GIF

Share this post


Link to post
Share on other sites
On 12/28/2018 at 4:22 AM, Sharlikran said:

I won't have time to set up tests or minimal installers but commit d2482ed breaks non FOMOD installers. In short I can't get the BA2/BSA or the plugin to install consistently whether or not it's a FOMOD installer or non FOMOD installer. Also commit 176991c doesn't resolve the 7zip issue. It is the commit that introduces the regression for 7zip.

So for now I'll be sticking to my version (which has the FOMOD support without the tweaks) until after the holidays. As I mentioned I'd rather focus on family right now anyway. However, it looks like Elminster is making more progress with TES3Edit so I may get sucked into that.

 

This version works fine on my side.

Skyrim SE; 255+

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×
×
  • Create New...