Jump to content

[RELz/WIPz] Unofficial Fallout 4 Patch [UFO4P]


Recommended Posts

21 hours ago, kawaksallas said:

BTW, let me ask - what's the fate of that bugfix related to the prydwen being shown as a settlement? I remember it worked until patch 1.5 or 1.6, then bethesda did something in one of those updates that invalidated your fix. Later I read in the patch notes that the fix was removed because of these reasons I just explained. The current situation as in the latest patch both official and unofficial - prydwen and airport ruins are shown as settlement icons in the map. Is it now unfixable? Are you planning to "re-fix" it?

We are not planning to re-fix it because the only solution was what we had done before and that no longer works.

Link to comment
Share on other sites

  • 1 month later...

UFO4P 2.0.1 is now in beta. Second post has the details.

Took awhile, but IRL issues are slowing things down around here. We're planning to leave this in testing for the next 2 weeks at minimum.

Link to comment
Share on other sites

Thank for your work over the years team!

Is it possible that something got borked at Thicket Excavation during this update? After updating to 2.0.1 the distant LOD doesn't fade and I'm walking around in the site with the LOD still in place... or should I look else where for the problem? Thanks again.

 

EDIT:

I reinstalled UFO4 and reloaded the game and all was well at the excavation. Sorry, I should have done that before I posted.

Link to comment
Share on other sites

On 20.05.2017 at 4:14 PM, Sclerocephalus said:

@InsanePlumber There's another one you could help us with if you have some time left to do it:

https://afktrack.afkmods.com/index.php?do=details&task_id=22285&order=category&sort=asc&pagenum=5

I started to take care of this, and other similar ones that suffer for the same or other reasons.

Meshes\Landscape\RetainingWall\River\RWRiverPieceRailCircleCustom01.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailCurveL01.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailCurveR01.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailHalfCircle01.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailHalfCircle02.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailHalfCircle02Short01.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailShiftL01.nif
Meshes\Landscape\RetainingWall\River\RWRiverPieceRailShiftR01.nif

Link to comment
Share on other sites

14 hours ago, Khugan said:

Thank for your work over the years team!

Is it possible that something got borked at Thicket Excavation during this update? After updating to 2.0.1 the distant LOD doesn't fade and I'm walking around in the site with the LOD still in place... or should I look else where for the problem? Thanks again.

 

EDIT:

I reinstalled UFO4 and reloaded the game and all was well at the excavation. Sorry, I should have done that before I posted.

The LOD issue is actually an engine bug that dates all the way back to Oblivion. Simply exiting the game and reloading will resolve it, but there's nothing we can do to fix that and it will always affect the same areas when it happens. FO4 is usually limited to the quarries where it's most obvious, but I've seen it once or twice in the badlands of Nuka-World too.

Link to comment
Share on other sites

First of all, thanks to the team for all your work in patching this game. I'm currently running the latest patch, 2.0.1, and ran into a problem today at the National Guard Armory. As soon as I tried to disarm any laser tripwire, I'd get a crash to desktop. Since I've done this mission before, I tried revalidating my Steam files -- no love. Then I tried rechecking my mods with FO4Edit to see if they were clean. I normally do this before installing any mod. The last one I checked was UFO4P -- and I found 47 identical to masters in there. Cleaning the patch didn't solve my problem, but disabling it allowed me to disarm those tripwires. Any idea what's causing this?

Link to comment
Share on other sites

Wow, thanks for the quick reply.

Here's my mod list:
1x1 craftable foundation pieces
better settlers
companion infinite ammo (version made by me using the creation kit, since the published version was made with FO4Edit and gives some error messages)
craftable castle wall patches
craftable turret stands
darker nights
easy lockpicking
egret tours marina bridge
far harbor ammo in the commonwealth
gibson pier bridge
*immersive vendors
improved map with visible roads
*lever action reload fix
longer power lines
outfit switcher
quieter settlements
*safely scrap covenant turrets
salvage beacons
snappable junk fences
stackable concrete foundations
unofficial fallout 4 patch
*vault-tec workshop overhaul
vertibird beacon
plus a few texture only mods

The ones marked with * are new since my last play through. I first tried disabling these new mods but I still got a crash until I disabled UFO4P. I also rebooted my computer during all of this and that didn't work either.

I try to run a very stable game and avoid questionable mods based on comments made about it and my own limited experience. So as an aside, if you see something you're concerned about then let me know.

Link to comment
Share on other sites

I'm running Windows 7-64 Professional with the latest Microsoft updates. I also just tried re-downloading the UFO4P from this site, since the one I'm running came from Nexus. Installed the copy from AFK and still had a crash.

Ok, just remembered that I had a copy of UFO4P v2.0.0 on my back-up drive. Installed that and still got that same crash. So the problem isn't with the newest version. Not positive, but I think I played FO4 with version 2.0.0 before with no problem. I've tried loading different saves before going into that bunker but still get a crash. I think the computer gods have just decided to crap on me.

Link to comment
Share on other sites

A hotfix has been issued for the following 3 bugs:

  • Fixed a crash when telling Longfellow the trappers were already dead. Crash was caused by a freak incident of game data corruption due to fixing an unrelated record in the quest. (Bug #22462)
  • Fixed crashed caused by trying to disarm/trigger/shoot a laser tripwire when running on a new save game. An unforeseen scripting issue was to blame. (Bug #22463)
  • Fixed an issue that was causing clapping monkey traps to not function on the first time visit to a cell. A line needed to initialize them on cell load was commented out when it should not have been.
Link to comment
Share on other sites

  • 2 weeks later...

Been a while since I've been to Croup Manor, but realized today that the concrete pillar glitch no longer works in repairing walls. I believe UFO4P addresses navmesh issues there so I tried disabling the patch and the pillar glitch worked fine. Is the glitch disabling an unintended consequence of fixing the navmesh or is this something that can be corrected? I disabled UFO4P, fixed the manor and re-enabled the patch. I think this is probably a bad idea -- I've read previous posts by Arthmoor -- but didn't know what else to do.

Link to comment
Share on other sites

First - definitely don't ever disable the patch like that and then reactivate it on a save you intend to keep. That's a fast track to eventually corrupting things.

Second - I don't know what this "pillar glitch" even is. The navmesh at Croup Manor was fixed because the NPCs would often end up gathered down on the shoreline and then be unable to get back up into the settlement where they belong.

Link to comment
Share on other sites

Fortunately I kept a save before deactivating the patch so can go back to it.

The pillar glitch is similar to the rug glitch, but works on wall construction pieces with snap points.  It allows you to "glitch" a wall piece into a destroyed section of the house.   You place a concrete pillar close to the wall piece and hold select to highlight both.  Then you can place the combined pieces anywhere that the pillar would normally be placed.  If you search for Croup Manor on Youtube and go to a vid by norespawns you'll see how it works.  He also has an older video comparing the rug glitch with the pillar glitch.  All his work is done using the PS4, but it also works on pc and I've used it numberous times.

I understand the navmesh needed fixing, so no complaints about that.  Just wondered if the glitch I spoke of was incompatible with the fix.

Link to comment
Share on other sites

Could be that the glitch only happened because the navmesh was broken and in fixing that it fixed the other too. We're obviously not going to remove a repaired navmesh for the sake of another glitch like that.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...