Jump to content

Mole Rat game freeze bug is baffling me....


Recommended Posts

OK, so I have observed a situation whereby a molerat ambush triggered during 2 quests so far has resulted in a game freeze. (well, to be accurate the game does not freeze until you either try to save or exit the cell once the trigger has occured.) 

This occurs in "Hole in the Wall" quest (Vault81Secret cell) and Shamrock Taphouse - when entering the room with the microbrewing protectron. 

The issue is also described here - https://www.afkmods.com/index.php?/topic/5304-a-problem-with-molerats-not-the-disease-something-else/

I did a bunch of testing and I think I have found at least part of the problem, but I can't for the life of me figure out what mechanic is actually causing it.

A series of run's through Vault81Secret with various different conditions set reveals that the mod "Scrap Everything" will cause the issue with 100% repeatability when it is enabled. If this mod is disabled then the issue does not occur. 

So, great, that identifies the culprit right? Well, maybe, maybe not. I have also noticed that even with this mod active, as long as the Mole rats do not actually detect the player (or companion I guess) and become hostile then the issue does not occur. - and it is this part which confuses me. I can't find anything in the Scrap Everything .esp which would impact the mole rats actual behaviour or that explains the subsequent freeze. 

In both Hole in the Wall (Vault81Secret) and Shamrock taphouse there appear to be actual trigger markers which will trigger the mole rat ambush. It is the point where these trigger that the problem will start from but...it's more complicated than that it seems...

Testing conditions. (all testing so far has been in vault81secret)

coc vault81secret from recent save inside vault81 or load up really old save and enter "Hole in the Wall" from start (inside vault81) = no difference to outcome. 

All run's were performed from the same save point's with console initiated save's made at 3 subsequent points (or until the game breaks)

Testing save points = Before first trigger. After 2nd Trigger and Inside Curies lab. - failure would normally occur after first trigger. 

  • All mods on. = Issue does occur.
  • All mods off. = Issue does not occur. 
  • All mods ON except Scrap Everything = Issue does NOT occur
  • All mods OFF except Scrap Everything = Issue does occur
  • (UFO4P enabled / disabled makes zero difference)

On the nexus pages for Scrap Everything the author makes some comment related to a report of this bug that .ini edit's of bUseCombinedObjects should not be used, however testing with bUseCombinedObjects=1 or bUseCombinedObjects=0 - or indeed no entry at all seems to make no actual difference. All conditions were tested with this variation and in itself it made no difference. As long as Scrap Everything is active in the load order then the game will freeze. 

HOWEVER (and here is where it gets interesting.)

Having established that the mod Scrap Everything is part of the problem I did several run throughs with various AI toggles in order to try to identify the actual mechanism that breaks the game.

  • tAI - Has no effect. The ambush is still triggered by passing the trigger point and while the mole rats will not exit their tunnels the game will still be broken from that point. 
  • tDetect = inhibits the molerat AI from detecting player or companion. - With this toggled the issue does NOT occur! The mole rat ambush will still be triggered by trigger markers when you pass them, but the mole rats will not aggro and it is possible to save and/or exit the cell without freeze. 
  • Toggling tDetect back at any point after then allows the mole rats to aggro and....the problem occurs. 

So, the problem also seems linked to the mole rat behaviour. It seems in fact to be the point at which they aggro which breaks the game. - and that is the mechanic that I cannot understand. 

I looked through Scrap Everything - Ultimate Edition.esp with FO4Edit and yes, the plugin does have the mole rat ambush furniture in it. - But even removing all reference to these in the plugin has zero impact. 

I also can't really understand why it would be the mole rat aggro which is the point where the break occurs rather than (for example) the appearance of the mole rat tunnel exit decals, the tunnels or mole rat carcasses as these things might be the kind of thing included in a scrap mod. 

I'm going to drop a comment on the mod page itself, but if anybody with better knowledge of these things can offer any insight at all into why this happens and what the mechanic is then it would be very much appreciated. I really would like to understand the game mechanic a little better and who knows? One day maybe I'll fix a mod or make one myself. 


Link to comment
Share on other sites

Whats you line of thought there? I'll give it a try tomorrow and let you know the result. 

I had thought the issue may be related to their dead bodies (which might reasonably have been included to a scrap mod) and their seems to be a mole rat that starts dead in vault81secret anyway. But if I use tDetect to stop the remaining ones from going into combat mode their standard walking around ai kicks in and it's still possible to save and/or leave the cell even though the ambush has triggered and the mole rats are active. Can't remember at that point if I have then killed them and what the impact of that is. I'll try disable on them and get back to you. 

Am also going to see what impact toggling the combat ai off has, think I saw a console command for that online. 

Link to comment
Share on other sites

  • 1 month later...

Hi there somethingbrite,

you are definitively not alone with this bug. It is mentioned on steam a couple of times:



And I think I have seen discussions about it on Reddit as well, although no one has ever found a real solution for it.  I just wanted to thank you for the trick with "tDetect". I have been dealing with this bug for months now, and I have been researching all over the internet but unfortunately haven't found a real solution yet. Until now I always just used the "killall" command before I have even seen the molerats. However your work-around seems to be a bit more immersive. If you ever find a better and more permanent fix for this, I would be glad you could share this here.  :)


Edit: I just noticed something weird. If I use tdetect and my NPC's trigger the molerat-aggression (not me, as they can't detect me), then the bug doesn't occur either.

Other observations;

- the bug only occurs if the molerats are in an indoor cell, not if they are outdoors

- however, when playing through "South of the Sea" I found that it also affects radscorpions that are encountered underground (they aren't found underground in Vanilla Fallout 4)

- for me disabling Scrap Everything didn't solve the problem, and I also didn't have the faulty mesh from CBBE. So the same bug can be triggered by various causes.


Thinking out loudly:

- do both molerats and radscorpions have the same attack script?

- is that script different if triggered underground?

- is that script so badly written that it can corrupt at a whim? - potential for streamlining that script?

Edited by aufisch
Added new information
Link to comment
Share on other sites

  • 2 months later...

I'm going to add myself to this.

I have the same issue and have been almost to the point of running around trying to fix this issue and been close to murdering my PC, as well as getting extremely angry at why I can't figure it out.

I've done the "tDetect" command trick and didn't have the issue.


I was going to post this at least 3 hours earlier as I was testing to narrow this down, but I'm getting odd mixed results, so far I've narrowed it down to possibly being a Sim Settlements companion mod, or just something that happens no matter the save 98% of the time.

Link to comment
Share on other sites

Its happened in the last 3 play throughs for me but never happened before that - as far as I can work out the issue most likely began on an iteration of the game from late 2017/early 2018, running through in tdetect sorts it out - I can kill them as normal, save as normal and leave the cell as normal- If not using tdetect and the mole rats aggro on me the game freezes if I try to save or go through a load door.

Using tdetect is fine for me - a pc junkie - not gonna be a useful solution for a consol player'

Just to confuse the issue I don't use Sim Settlements or Scrap Everything. Never used Sim Settlements but have used Spring Cleaning, cleaned of cell edits and alongside VlitS's Spring Cleaning Compatability Patch - however neither of those mods has changed in far longer than I have had this mole rat issue (last mod edits are in April 2017) and neither touches Curies secret vault, the cave behind Red Rocket, or Shamrock Taphouse, so its difficult to see how they could be the cause of it.

Also here


same issue so maybe add to the comments there?


Link to comment
Share on other sites

I'm assuming that site has a different login as it's not accepting this.

However, as I was trying to narrow down more I ended up with it now crashing when I have Sim Settlements disabled, so no idea what is going on now.

Link to comment
Share on other sites

  • 2 weeks later...

Interesting research so far. 

I've never run Sim Settlements and yet I have experienced the bug. Make of that what you will. 

Indeed I have observed that exterior cell molerat ambushes don't appear to cause the issue, however I guess I thought at the time it must have been because of a different trigger. (Proximity rather than specific location) but this would not explain the tDetect workaround where the specific location triggers the ambush but not being visible to AI means the mobs don't aggrieved and their combat AI kicks in. 

...and I am wondering if that's it. If it's actually the combat AI that gets tangled. - because all is fine just so long as they don't aggro. 

Link to comment
Share on other sites

On 2/7/2019 at 11:47 AM, McKaby said:

However, as I was trying to narrow down more I ended up with it now crashing when I have Sim Settlements disabled, so no idea what is going on now.

Yup. Even disabling a mod can crash a game if there are a lot of things that the mod adds or changes which are suddenly not being steered properly. 

I have never installed Sim Settlements but I have indeed experienced the bug so I'm not 100% it's related. (Although Sim Settlements could likely make changes that could cause this. I've just not looked.) 

Link to comment
Share on other sites

On 12/2/2018 at 12:06 PM, aufisch said:


Thinking out loudly:

- do both molerats and radscorpions have the same attack script?

- is that script different if triggered underground?

- is that script so badly written that it can corrupt at a whim? - potential for streamlining that script?

Regarding the ambush itself. 

Interior ambushes of Hole in Wall and Shamrock Taphouse seem very location specific. - different from what I imagine to be proximity triggers for the exterior attacks. 

However, the cave under Red Rocket is an interior cell with an ambush and that never glitches for me. (As far as I can recall.) - so examination required to check these cells and see if these are different.


The ambush trigger itself doesn't really explain the tDetect workaround. The ambush will trigger just fine - but the mole rats don't become aggressive. So...it must be something else.

Indeed, as noted if it's possible for a companion NPC to trigger the aggro but the glitch to not occur just so long as mole rat combat AI doesn't detect the Player Character (fDetect?) then we are looking at something else. 

In Hole in the Wall this would make sense if it were related to the disease that the player character can contract as there must be a script for that. 

In Shamrock Taphouse, not so much unless some damn fool at Bethesda just copy pasted mole rat scripts from one quest to the other. 

Link to comment
Share on other sites

I am currently at another play-through, and I have that bug again.

Yes, you are correct if you say that the cave underneath Red-Rocket is an exception, as I observed exactly the same. I didn't encounter the bug there. And even though I haven't installed a single new mod since I killed those mole-rats at the Red-Rocket cave, I now have to deal with this bug again. And I don't have Sim-Settlements installed either (never had in this play-through).

I am not so sure about your theory about the bug being related to specific locations, as the bug also affects mole-rats from mods:

Wild-Wasteland: - the R.O.U.S-mole rats at the gambling bunker

South of the Sea: - the mole-rat just to your right when you leave Necropolis

And the bug also occurs in the Vim-Pop-Factory from the Far-Harbor DLC.

 ....of course there is also the possibility that the modders copy-pasted that buggy mole-rat script as well. That could also explain the "missing activator" or "activator set to attack furniture"  from Gentester's link above. If the modders just copied one of the mole-rats which did have a faulty activator, then that could account for the bug showing up in mods as well. So the bug may not be due to a universal buggy script, but to single individual buggy mole-rats that get copied-pasted all over the place (still doesn't explain as to why it occurs only in indoor-cells and not above ground as I assume that indoor and outdoor mole-rats are identical).

Unfortunately I have only understood about half of what Gentester wrote in his post, and I currently don't have enough knowledge of CK in order to apply those fixes he described.

Link to comment
Share on other sites

Hello everyone,

I've encountered this issue in my latest play through having never encountered it before and I've spent the weekend researching and looking for clues and coming up with very little, until I found threads on these forums.

I don't run with scrapping mods at all, but, I do run with SimSettlements and various addons for that mod, including a mod that adds a security base that can generate a 'tame' mole rat, and I wonder if there is a relationship between SimSettlements and possibly the mod that adds the mole rat and this bug in the secret vault in Vault 81.

I am going to try and start a version of the game that disables the SimSettlements addons, one by one, to see what effect, if any, doing that has on this issue. I feel bad for doing this because I know that disabling mods is going to cause me an issue, but the game I'm playing has got literally months of time invested, and it's broken, which is frustrating, so nothing ventured, nothing gained. I will also make a post over on the SimSettlements forums to see if anyone has seen anything like this over there. If I get any feedback from there I will pass it along.

Link to comment
Share on other sites

On 2/18/2019 at 11:51 PM, aufisch said:

And the bug also occurs in the Vim-Pop-Factory from the Far-Harbor DLC.


You are so right! I too have experienced this bug at Vim in Far Harbour! (but apparently forgot about it.) And it's the exact same issue. 

Where does THAT leave us? Mole rats which bug out in Interior locations consistently? 

- Regarding Red Rocket - I have had a thought..

Is that an ambush or are the rats already active? 

Because as I recall there are also mole rats in Concord civil defense. (Also an interior location.) 

There is also the junk-pile south of Starlight Drive In (on the road to 10 Pines Bluff) but I can't remember if the game treats this as an exterior location. - and it is also a one time only attack? 

Is it simply because most players don't install mods until later in game that these are less buggy experiences or because these attacks are different? 

Link to comment
Share on other sites

I have also got the same behaviour in the mole rat den under red rocket.

what I am seeing is that the mole rats spawn, but rather than attack me, they simply remain in place, unmoving, but obviously hostile. If I engage with them, the game will freeze if I leave the mole rat den or try to save. If they spawn and I simply leave the instance everything is fine.

I have posted on SimSettlements, but no replies. I am at a loss as to what contributes to this problem. My next step is to start a new game with nothing but UFO4P enabled, then, after leaving the vault, I will try to start a game with Sim Settlements and various thinks like workshop framework and the addon packs enabled. I will report back with any conclusions I can come up with.

Link to comment
Share on other sites

Okay, I can report back with my findings.

I created a new game with only UFO4P installed. I left the vault and ran directly to Red Rocket. Entered the mole rat den and everything worked as it should.

I then proceeded to Vault 81 via a COC command, entered the vault, went down to engineering and TCL'd through the wall, entering the secret vault. Go through the vault and get to the mole rats which spawned and attacked me. I had enabled god mode at this point so I wasn't one-shotted by the turrets and protrectron. Everything worked as it should.

I repeated this over and over adding one mod after another, Sim Settlements, Workshop Plus, Workshop Framework and all the Sim Settlements addon packs. Nothing changed. I proceeded to add other mods, one at a time, until all that were left were texture mods which will obviously have no effect.

I could find NOTHING in my load order that changed behaviour of the mole rats.

I went back to my game that has the problem in it - once again went to the mole rat den outside of Red Rocket and the problem persists. The mod list in my game that has the issue matched the mod list in the new game that I added mods to one at a time. At this point, I'm absolutely beaten by this bug, and I can only assume that the game I'm playing is corrupt, and that's normally my signal to start over. Thankfully with Transfer Settlements I can quickly rebuild the settlements I made, so all is not lost. It's just one of them things, I guess.

Link to comment
Share on other sites

I wish to add this to my previous, but I just did "Hole in the Wall" without this issue, but still get it at the Red Rocket den.

Link to comment
Share on other sites

I get it in Vault 88 now, when you are asked to explore the different areas of the vault. In some areas, Mole Rats spawn, and boom - there goes your game!

Link to comment
Share on other sites

  • 5 weeks later...

just to add to this. I had totally forgot that I get the same issue at the Vim Pop Factory in Far Harbor as well, exactly the same as soon as those mole rats spawn my game will not allow me to leave the cell or save without freezing.

I also get it with  Bloodworms in Mad mulligans mine in Nuke World - as do others judging from what I read elsewhere. https://www.reddit.com/r/FalloutMods/comments/9td0py/fo4_save_freeze_or_game_freeze_after_fighting/

I was reading something the other day about this bug which says that in mods which have put radscorpions underground that get triggered to ambush the same thing occurs - in main game the only underground radscorpions I can think of are in the vault you build and as by then I am in tdetect due to the molerats I suspect I wouldn't have noticed the issue.

I have been through my load order with a fine toothcomb, i have nothing (other then the UFO4Patch) which edits anything to do with  these critters, holes, furniture in any way (even my scrap mod doesn't reference them in its lists).

So as I don't think for one minute that the patch has caused the issue I am wondering if anyone from the team has the problem or if its being looked at at all - or is it one of those weird bugs that only affects those of us born in  a certain month at a certain phase of the moon and who have blue eyes or something equally obscure rofl

Link to comment
Share on other sites

  • 4 weeks later...

I wanted to add my latest findings here:

1) Yes, I can confirm that Mad-Mulligans Mine in Nuka-World is another place where the bug occurs.

I just set myself to work through Vault81 again, for the first time in this play-through (where I already encountered the Mole-Rat freezing bug). So I made a hard-save at just the place where you can save for the last time when you enter the secret part of the vault. I then unloaded all my plugins and started to fight the first group of Vault81-Mole rats, always starting from the same hard-save and, wearingthe same Vanilla Armor and using the same Vanilla Weapon. Here is what I found;

2) It became already clear during the play-through if the game would freeze during saving or not. If the save would work, the mole-rats were much much more agressive and active.

3) There wasn't a specific plugin responsible, for the freeze to happen. It was more a matter of plugin load and plugin combination. If I reached around 62 esp-Plugins, the freeze would occur with almost any additional plugin I would add, as long as the plugin was a workshop/building-mod. For example, adding SMM (Settlement Menu Manager) was no problem, but adding Snappy House-Kit or Settlement Object Expansion, would then trigger the freeze.

4) However; running all the plugins which in that moment would trigger the freeze (in my load order that happened to be workshop/building mods like Settlement Object Expansion Pack, Snappy House-Kit, Snap-Beds, Thematic and Practical....) by themselves or as a big workshop package (just with the vanilla esm's and all the esl's plus all my other workshop mods) would not cause the freeze.

5) Moving the first specific plugin that caused the freeze (in my case Settlement Object Expansion Pack) in the load order from last to the top just right below the esm's/esl's did not solve the freeze either. Not related to load order?

6) After that 62 esp-Plugin-Boarder, I could not load any more Workshop/Building mods before the freeze would happen

7) Unloading all esm's that had to do with workshop/building did not change that fact that the previously problematic building mods would still trigger the freeze

8) Unloading all other esm's as well as the Unofficial Patch, did not solve the freeze either, in combination with one or more of the problematic workshop mods

9) However, I still could load Quest-Mods (even huge ones like Fusion City rising), and Weapon- and Armor-Mods, withouth triggering the freezing

10) Upon further testing I found that the freezing problem is caused by a combination of several mods, which do not seem to be 100% compatible with each other (for example "Commonwealth Cleanup" with some of my Building mods), However, there are more mods involved (likely around 10 mods in my load order) and even after x-reloads, I haven't found out the exact culprits yet.


..... and now I am at an even greater loss than before. What in the hell have the indoor critter-attacks to do with the workshop mods? Is this really a conflict between the workshop mods and other mods, which is not load-order related??? I run over 30 workshop mods alone, and trying to find out what is going with what and what is not, will be short of impossible (not even trying to calculate the possible combinations here)


well.......that was a sunday well spent..... (sarcasm off)

Link to comment
Share on other sites

  • 1 month later...

I wish to put an addition to this which is something that I've noticed not entirely related to this, but is an interesting issue:

I recently have been able to replicate the "no longer saving" issue several times, by a quick save and a lot of quick loading, I noticed this only recently after adding in a bunch of mods that had some heavy scripts, so I'm wondering if that's something to look into.


And on this front, I've had the insta-freeze when molerats attack in the Taphouse, was fun trying to rescue Buddy.

Link to comment
Share on other sites

  • 3 weeks later...

Guys I figured it out, at least for my load order!!

The problem is Sim Settlements running too many scripts, breaks the mole rats/autosave/curie. Just go into mod configuration menu or use the SimSettlements holotape, performance tab. Set max scripts from either 10 (default) or 30 (max) to ZERO. Run the quest. If the mole rats are moving to attack you and the game is saving without freezing, the quest is working properly. Then set max scripts back to whatever it was when finished. Done. No need to uninstall scrap everything, sim settlements, other building mods, etc. Works also for Vault 88, haven't tried it yet at the Shamrock pub but I'll let you know if and when I get there. 

You still need to do the thing where you push Curie into the office, or you won't be able to dismiss her later. That's an unrelated problem, super annoying when you have EFF and you have like 6 companions in power armor in there and she never makes it to the right spot. 

Hope that helps some people! Good luck and don't get bit!

Link to comment
Share on other sites

doesn't help me as I don'tr use Sim Settlements in the first place :)

I actually use very few scripted mods and never have an issue with Curie. Only problem from my end is the mole rat/bloodworm game freeze, but I have one mod for multi companions (Liga) and 2 quest mods and that's more or less it for anything scripted other than the fire once type things - had the mole rat bug before I installed the 2 quest mods and I doubt Liga is causing it.

It's almost certainly something in a script that's causing the problem, but who what how is beyond my competence to sort out, especially as people find solutions for their own game which don't apply to other people with the issue. 

Basically I'm stumped and have been for the nearly 2 years I have had the problem so now I just Tdetect the relevant areas and ignore it as a Bethesda/user fubar. 





Link to comment
Share on other sites

It opens an interesting avenue though. 

When I was getting this bug I had a really heavily modified game and a lot of those were probably script heavy mods. 

Lots of scripts running increases the chances of a script NOT running properly. 

And the molerat ambush is a script. 


But there is a further complicating factor...

The molerat mound is a furniture....


Really wish afkmods would chime in on this thread. I think I've seen an old ticket regarding the ambush script and how there was a bug regarding the cleanup of the molerat hole (which is a furniture) 

I'm pretty sure that cleanup mods (spring clean etc) probably have a list which includes molerat mounds as tagged "scrapable" - and that is another possible conflict area.

Link to comment
Share on other sites

Yep, you are completely right somethingbrite. Scrap Everything allows you to scrap molerat-mounds, as well as (certain) ambush-markers. And guess what I usually do after I have defeted my first mole-rats in the tunnel underneath the red rocket (the only molerats that don't freeze for me), and activated the workbench there? I scap the red-rocket area INCLUSIVE those mole-rat mounds!!  I will have to start a new re-run though to confirm your theory.


Ah, and not using SimSettlements here as well, and Fallrim Tools says I have only like 6 active scripts in my save-game. I kind of get confirmed though in my belief that this particular script is so excruciatingly badly written that it gets corrupted by looking crossed-eyed at a daffodyl.

Link to comment
Share on other sites

Ok, so I wanted to confirm the theory about scappig mole-rat mounds.

- I started my game with all my current mods installed (including Scrap-Everything), but with the savegame I made when I had left Vault 111 for the first time. I went to Sanctuary Hills, did the tour with Codsworth and proceeded to Red Rocket, where I killed all the Molerats and cleaned out that cave underneath. No freeze.

- I then made a hard-save, cleaned up some stuff but not the molerat mounds, and went to Fairlane Hills, where there is the Gamblers Bunker from the mod "Wild Wasteland". I made a hard save just before I entered the Bunker. Quit Fallout to Desktop, restarted Fallout 4 (in order to give to bug time to bake itself into the save-game file), and went down into the Bunker, killed the molerats, hit the Qucksave-Button, and no freeze.

- I proceeded to Shamrocks Taphouse, did another hard-save, quit Fallout 4 again, restarted and went into the Taphouse where I killed the molerats in the basement - no freeze

So far so good, now I had to just prove the opposite. so I loaded my save from before I cleaned up some stuff at Red-Rocket. This time I made sure I scapped ALL the mole-mounds as well. Then I proceeded EXACTLY like above......and I didn't encounter any freezes or problems. Sigh..........However, when I first went into the Gamblers-Bunker without having reloaded the game, the mole-rats didn't trigger at all. 

Grrr, I can honestly say that I meanwhile loathe that mole-rat attack script.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...