Jump to content

SSE Creation Kit Crashes Upon Saving Oldrim .esp File


Pokestar
 Share

Recommended Posts

Hello everyone,

I've been trying to port a personal companion mod I'm currently working on from old Skyrim to Special Edition, where I'd like to continue my work having finalized her appearance.

To do so I've tried several times now loading up my .esp plugin file in the new Creation Kit for Special Edition and simply save it so it becomes converted to the new format. Every time upon trying to save it, though, the Creation Kit immediately crashes. The only thing I noticed happens every time I do this is that a file with the extension ".tes" with the same name as my .esp plugin file is created in my Data folder. :cry:

This issue is really beginning to give me a headache, so if anyone of you might be so kind to lend me a hand with it, I've attached my .esp file here and would greatly appreciate either any feedback on what to do or even the .esp file succesfully converted to the new format, in case someone actually manages to convert it. :wallbash:

Greetings and a happy new year to everyone! :teehee:

Link to comment
Share on other sites

Maybe the Creation Kit could be tricked somehow into thinking that FaceGenData is allright? In case this is the issue, I could provide FaceGenData if someone has an idea for a workaround.

By the way, does anyone know what's that .tes file and why it's created every time Creation Kit crashes?

Link to comment
Share on other sites

The .tes file is how the CK saves something. If it succeeds in writing the file only then is the .esp file overwritten. A safety measure basically. Just delete that file as it's of no use to you.

The SSE CK will insist on updating facegen no matter what you do so having it ahead of time won't help since the CK will be trying to convert it to SSE format. You should not use Nif Optimizer on those files.

Since it crashes even when all I have is your .esp file then I can only conclude it's not happy about generating facegen based off the data in the file, though I'd have no idea why.

Link to comment
Share on other sites

Does the mod actually work in LE format? I'm seeing some odd setup in the race record, so just wondering.

Also, you'd be far better off keeping and working in LE format until you're finished anyway, then convert. SE CK does not generate LIP files, which you'll need for her.

Link to comment
Share on other sites

I'm going to attach the rest of my files for you to check here very soon.

It doesn't create .lip files? Then I might actually be better off working on her on LE format, hmm.

Please tell me, though, what you mean by odd setup in the race record?

Link to comment
Share on other sites

In old Skyrim the NPC itself worked just fine in-game, yes, see the screenshot.

I just tried saving the plugin two more times:

One time with the FaceGenData not optimized with SSE Nif Optimizer, and one time with all FaceGenData deleted completely.

The outcome stays the same, though: The Creation Kit crashes.

Even though I might actually better stay on LE format to continue my work on my companion mod for voice implementation and everything, I'd still like to be able to test certain things before finalization in Special Edition, her appearance for example, and being unable to do so in this very basic state of my mod already feels worrisome for me to say at the least. :cry:

Here you are, one file attached contains my companion mod for Special Edition with everything optmized except for FaceGenData and the .esp file of course, the other file contains the version completely for old Skyrim. Maybe someone might find a way to fix this issue having the entire mod ...

 

 

 

Link to comment
Share on other sites

Curious (sorry Pokestar) : does SE process LIP files anymore or does it have it's own new embedded lip animation class?

Once we know the LIP file format- then it should be a trivial process to convert the output of a program like this to SE. Easier said than done perhaps- looks like a fair bit of trial and error involved.

Link to comment
Share on other sites

You have broken textures:

"fjs01thalia\eyes\eyegreen_e.dds" is 0 length

"fjs01thalia\body\femaleunderwear_n.dds" is DX10 format even though I downloaded the Oldrim version (which means it never worked in Oldrim at all). SSE supports DX10 textures now, but I'm not so sure if CK does. Convert to ordinary dds format just in case.

Link to comment
Share on other sites

Plaese explain further, I could easily save them to another DXT format in Paint .net. Or shall I convert them in any other way? I'm not as experienced in this area so any further feedback would be highly appreciated.

Also, what is wrong about my eyegreen_e.dds file and how to fix it? I don't understand, sorry.

Link to comment
Share on other sites

Do you have an ...\eyeblue_e.dds? Make it the same size as that- (copy + rename + edit)

Convert to a commonly used DXT format- @Alt3rn1ty has a great post on all that here. :)

Quote
  • DXT1: use this format for typical textures with no alpha channel.
  • DXT3: use this format for typical textures with an alpha channel with sharp gradients.
  • DXT5: use this format for typical textures with an alpha channel with smooth gradients.

 

Link to comment
Share on other sites

Hey there, I've gone through the LE version of your mod and found the CK throwing quite a few errors, any one of which could be the cause of the SE CK choking (its very sensitive and unforgiving). These need to be fixed first before trying to convert again.

Race Record

> Skin should point to your new FJS01ThaliaBodySkin (otherwise body does not show up in preview) and not in NPC record

Head Parts

> FACEGEN: Could not find (and apply) race morph 'FJS01NordicHighHalfElfRace' in TRI file 'Actors\Character\Character Assets\FemaleHeadRaces.tri' for geometry FemaleHead.
> FACEGEN: Could not find (and apply) race morph 'FJS01NordicHighHalfElfRace' in TRI file 'Actors\Character\Character Assets\FaceParts\FemaleHeadBrowsRace.tri' for geometry FemaleHeadBrows.

- Were these tri files edited to include your new race? If not, remove the Race Morph and Chargen Morph entries  in all your head parts records.

> FACEGEN: No morphs found in TRI file "meshes\actors\character\FJS01Thalia\Hair\hair.tri". Please do not use empty TRI files
> FACEGEN: No morphs found in TRI file "meshes\actors\character\FJS01Thalia\Hair\hairline01.tri". Please do not use empty TRI files

- No idea where you got these tri files but they are no good. Might as well not indicate tris in the head part record.

NPC Record

> Remove Skin
> Voice type different than Race Record - since it's a dedicated race to this NPC, it should be the same

Models

> MODELS: BSBodyMorph::InterpSkinnedGeometryUnPacked() Model vertex counts between morph models don't match. '0' (3591), '1' (3584)

- This means femaleHands_0 and femaleHands_1.nif - are different sizes, will cause distortion when weight not 0 or 100.
                                                                                - has Has Normals Yes, should be No
                                                                                - same with 1stperson hands meshes

- femalebody_0, _1.nif - has Has Normals Yes, should be No
                                   - partitions are incorrect, may cause problems with armor/clothing

- femalefeet_0, _1.nif - has Has Normals Yes, should be No

Textures

> DEFAULT: TEXTURES: texture does not contain mipmaps & will not be used : textures\actors\character\FJS01Thalia\Eyes\eyegreen_e.dds
> TEXTURES: Texture Set missing texture textures\actors\character\FJS01Thalia\Eyes\eyegreen_e.dds.

- as zilav mentioned above, the file eyegreen_e.dds is corrupt, a 0kb file. Either redownload from wherever you got it or recopy the vanilla cubemap and rename.

> TEXTURES: BSFaceGenNiNodeSkinned : FJS01ThaliaEyesHP is missing an environment map

- this is the facegen file, saying the same as above, it won't use the corrupt _e.dds file

> DEFAULT: TEXTURES: texture does not contain mipmaps & will not be used : textures\actors\character\FJS01Thalia\Body\femaleunderwear_n.dds
> TEXTURES: Texture Set missing texture textures\actors\character\FJS01Thalia\Body\femaleunderwear_n.dds.
> TEXTURES: FJS01Thalia (02003882) -> Thalia (02000D62) : bra is missing a normal map

- these are all saying what zilav mentioned above, it cannot use the texture femaleunderwear_n.dds because it is in the wrong format.

- femalebrow_n.dds has no mipmaps
- eyegreen.dds has no mipmaps
- mouthhuman.dds has no mipmaps, no alpha doesn't need to be dxt5

You can resave any of these in paint.net to the proper format.

Link to comment
Share on other sites

Thank you very much, all of you, for every bit of information and feedback so far that partly even went beyond my initial issue, it is highly appreciated and of great value to me. :)

@HanaThank you very much for your further investigation on the issue and explaining every error the Creation Kit threw in exact detail. This really does help me a lot, I'm going to try and fix all the errors you listed by hand just a little later. I'll report back then.

Link to comment
Share on other sites

I'm back with excellent news: Having fixed all the errors listed by Hana, saving my plugin in the new Creation Kit has finally been succesfull, no crashes or anything! :) And ingame, just ignore the underwear for now, her appearance also just works absolutely great, see the screenshots!

In order not to carry forward any more errors in my very fundamental implementations into further development, though, I'd like to provide you guys with this current version of my mod for you to give me feedback one more time on whether the erros in my plugin and texture files you spotted have been fixed properly for good. Again, please ignore the body meshes for now.

I've gone throgh Hana's entire list and looked into the issues with my textures zilav mentioned as well. The only thing I'm not quite sure about is whether I handled the thing about her voice type right: I finally implemented her very own one and just set that to either my custom race's default and my NPC's voice type. Apart from that, everything else should be fixed now I think. :innocent:

Any more feedback is highly appreciated!

 

 

 

Link to comment
Share on other sites

Hey Pokestar,

Nice, looking good. Just a couple more things;

- underwear_n.dds was not converted back to DXT1 format (if you're not going to release an LE version then fine, don't worry about it)
- still getting errors about hair.tri and hairline01.tri - meaning these files are useless, remove the ref in the headpart records
- none of the meshes were fixed

Regarding the Voice Type. The way you did it is perfect, but only if you're getting a voice actor to record new lines for her. Otherwise, just use a vanilla voice type - one of the ones that a vanilla follower already uses so she can use the follower dialogue.

Almost there! :D

Link to comment
Share on other sites

Thanks for pointing these out, should be all fixed now at last! :D

There is one very last thing about her appearance that still bothers me, though, maybe someone has an idea what the problem is:

Do you notice that very slight neck seam she has? I know about the body meshes needing to be fixed with "Has Normals - No" and that you should only install entire texture sets that fit together but I made sure to do all this, so I wonder what the cause might be ... Maybe something about her FaceGen texture is off?

Mod for both versions of Skyrim attached, if someone might help me wrap things up about her appearance and its port to SSE by identifying the cause for the neck seam I'd be really glad. Though as far as I can tell it also exists in the version for old Skyrim, hmm ... :huh:

Skin textures are from here, CBBE version for SSE, UNP for old Skyrim.

 

Link to comment
Share on other sites

Nah, I think I just figured it out myself: When porting my plugin to Special Edition, the Creation Kit gives me these warnings:

Quote

Should have been converted offline
Should have been converted offline
femalehead.nif : FemaleHead is missing a facegen tint map
femalehead.nif : FemaleHead is missing a facegen detail map
Should have been converted offline
Should have been converted offline

I guess I should get these additional texture maps from vanilla game files and link to them in Thalia's FaceGen mesh to fix the neck seam?

Does anybody know what these files are, though? "FaceGen Tint Map", "FaceGen Detail Map"? :peer:

Where are these located? And more importantly, which file paths to link where in NifSkope?

Link to comment
Share on other sites

Ok, so ..

1. Neck seam

Relooking at the meshes I missed a few things, namely vertex color flags missing. So instead of going through an explanation for you, take these fixed meshes and replace the LE version files.  Then re-convert with Nif Optimizer. This may or may not "fix" the issue. UNP is well known for having neck seams and not much can be done except to minimize it.

new body meshes.7z

 

2. Warnings in CK

Ignore them. But lets make sure your process is right.

Before running Nif Optimizer on your meshes, follow this warning from the author;

Use the head parts option on ONLY head parts, without exception!
So it's better to temporarily copy/paste all those heads, eyes, hairs to a separate folder for optimization.

So, remove Brows, Eyes, Hair, Head and Mouth folders from your archive and put them somewhere else. Also, remove the FaceGen folder (not needed, never run facegen through nif optimizer).

Run Nif Optimizer on your body folder. Now run Nif Optimizer on your temp folder with your head parts (excluding faceegen) with the proper options. Put all your folders back together into your mod folder, except FaceGen.

Open the mod in SSE CK. It will auto-create its own proper facegen for you when you save. Test. (I don't actually have SSE so I probably can't help you any further if you're still having issues.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...