Jump to content

Decifering papyrus log ?


Recommended Posts

Hello afkmod's people !


I'm usually asking questions in places with larger audiences, but considering the subject and the amount of people who "know everything about everything, but actually not that much" on large audience forum, I thought I'd better ask here :P I'm assuming the knowledge/head ratio here is propably the highest I can find on a Skyrim's modding forum.



The only decent topic I could find about papyrus log was an old thread by Giskard on steam forums, and yet, he's mostly explaining that modders are too bad to prevent log error in their mods, than providing actual informations about how to read, analyze and exploit papyrus logs.



If someone have some good links to learn about it, I'd be glad if he could post it here :P


If not, here are some specific point I'd like explained, if anyone can : 



Some scripts / functions are called to [None] objects... I checked the sources of various said mods that dumped this error, recompiled them to be sure, checked the implementation of the mod in both TES5Edit and the CK... nothing seems wrong. I tried to make new, clean games, no errors for thoses... 

So, how is it possible that at one point, the script is trying to be applied to a non-valid object ? 

"Because the object himself have been deleted in your savegame". Ye, thought so, but what if the said script actualy extends ActiveMagicEffect ? Those are supposed to be dispelled on the actor's death if I'm not mistaken ? Still, I can admit this make for a decent explaination of this one...



The other I'm worried about, even more odd : 

"Property XXXX on script XXXXX attached to XXXXXX (formID) cannot be initialized because the script no longer contains that property"


What the hell could this means ? I just don't understand how a property could "disappear" from a script, so I'm assuming it's actually the VMAD that's failing at some point to link the script's property to an in-game reference... yet, as I said, I checked in the CK : The property is properly linked to its reference...


To say it before anyone ask, yes, I tried various tool supposed to "fix" scripts instance in savegame.
I would even say that the second error is most likely due to one of those tools...

But they're only working on savegames... should I conclude that the property-reference link is actually stored in the savegame, and thus not re-read by the game in the plugins everytime you run the game ?



I hope someone can enlight me a little bit... 






Edit : Well, it look like I'm not so good at browsing forums... thx zilav

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...