Jump to content

Forum Update - IPB 4.5.x


Recommended Posts

We've just updated the forum to the latest IPS 4.5.x release. It's a major jump, so as usual there's going to be stuff that probably isn't working right. If you spot something, let us know.

One thing there's no need to mention is the garbage default font these guys keep forcing on us. I've got a question in to the theme designer to see if there's a way to get back the one we had before, so bear with us until that's dealt with. Assuming it even can be. I swear these updates take away more choice from site operators with each iteration.

One thing that you will need to take note of is that IPS is going to drop BBCode support in some future update and they're taking steps to discourage its use now. So don't be surprised if something that did work before no longer does - they're not going to fix it because they think BBCode is the devil's work.

Link to comment
5 minutes ago, Arthmoor said:

OK, thanks to Nam we've got the font issue fixed :P

Trying a quote ^^, followed by text <<>> followed by a spoiler about Batman ..

Wears his pants on the outside

^^ Ended spoiler, followed by a manual quote ..

Wishful thinking, it may just all work if IPB allow it again

^^ .. ended quote .. Followed by another note :

 

Signing in as an anonymous mouse is conspicuous by its absence, not really bothered personally but it may be a thing that has gone the way of Bulletin Boards :)

Link to comment
3 hours ago, Arthmoor said:

One thing that you will need to take note of is that IPS is going to drop BBCode support in some future update and they're taking steps to discourage its use now. So don't be surprised if something that did work before no longer does - they're not going to fix it because they think BBCode is the devil's work.

If they do that then the community have another NodeBB crap to deal with and already having one forum software is bad enough, but two forum software is a disaster IMO.

Should this happen then it is time to drop IPS for good and replace it with something else that still support BBCode.

 

EDIT:  Oh, IPS have removed the Edit post button and place the editing to the top right there you see " --- " and clicking on it brings up a pop up menu.  Anyway, just notice my kudos had dropped from 85 I think to 51.

Link to comment

Noticed a slight issue but I'm not sure there's much you can do about it (may require the IPS folks to change their code). Since the update, the JS on the site seems to be acting slower. All other sites are fine and it's only since the update here

Link to comment

I wonder if I'm the only one who thinks the font size is significantly larger than it was before? This is font size 12 that I'm sure was default before. Now it's 14?

Not that I'm complaining, not ashamed to admit had to squint to read before lol. :lmao:

Now if only we could get rid of the forced new line space.

Link to comment

I wouldn't even know where to begin to try and address something like slow JS. I'm not noticing anything significant. In any case it would definitely be something IPB would have to do themselves. Aside from the theme we're running stock IPB.

As far as fonts, it's certainly possible that the size is larger than before. Updating the forum code required installing a fresh copy of the theme to get rid of garbage left behind from the old version. The only thing I did was hack in a change to force the use of the Arial font since all of the default choices suck. The forced newline can be overcome by using SHIFT+ENTER. We can't change the default because it'll get applied to every old post on the site and that would screw up the formatting.

Link to comment

Could a bug report be opened with them? It may not be the JS but there's definitely a performance hit in the update. I've tested it with three devices using 87.0.4280.88 and the issue persists on all of them. I've tested it with my phone, a four year old Ultrabook, and a new one I just got two weeks ago.

Edit:

Disabling the blurred background and sticky nav bar options under the "Customizer" at the top seems to have helped quite a bit but there's still a small added sluggishness at play.

Edited by deaths_soul
Link to comment
  • 2 weeks later...

When I click on the "Link" button I see the cursor between two lines e.g there you either manually add a link or paste a link and the second line below.

Is that intentional or is it a bug in IPS 4.5.x? :shrug:

Link to comment
On 1/18/2021 at 11:03 PM, Arthmoor said:

The cursor should be defaulting to the input box for the URL.

The cursor will only be *defaulted* to the URL box after clicking on the link line and not what I see now (the cursor is placed in the bottom frame and below the link line the URL box).

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...