Jump to content
Sign in to follow this  
Jebbalon

Crash near POIFallForest05 / Redwater Den

Recommended Posts

I am getting a CTD when loading in Tamriel cell 33, -19 which is POIFallForest05 in vanilla Skyrim. It changes to Redwater Den exterior with Dawnguard installed. I am getting crash with or without Dawnguard loaded. Also crashes with USSEP loaded.

This is in the Creation Kit by the way. The crashes I mean. Very sort of frustrating as I'm trying to edit a cell nearby ( 32, -21 ) and 33, -19 loads in it crashes.

How can I track down what is causing CKit to crash ?

I have searched bug tracker (nothing about ctd) google (some things but no resolution). I'm sure if it was not just me there would be more.
In xEdit it shows about 100+ objects in temporary and 4 or 5 in persistent world space. Nothing stood out to me.

The CKit will crash with bad meshes sometimes and (from previous experience) if a mod has conditions with Parameter #3 not set to -1. But, the mod I'm working on is fine unless I go to that one near 33, -19. Others south of there have no problems. It crashes with only skyrim.esm loaded too. So, I'm at a loss as to what it is.

Do I need to look at all the meshes from that cell or what should I look for in xEdit ?

Share this post


Link to post
Share on other sites

When I was updating my Skyrim Map Markers mod I placed a map marker there without knowning that cell already had a vanilla map marker, but I remove it when someone got two map markers there in-game.

Now, I don't remember what version I had a map marker there.  So, if you're using my mod make sure you update to the latest version, because I checked in TESxEdit after temporary changes and if I find anyone I removed them.

Other than that I have no clue what is causing your CTD, sorry.  Maybe Arthmoor know something.

Share this post


Link to post
Share on other sites

Thanks, but this is crashing CKit with only loading Skyrim.esm.
I double click on Skyrim.esm, don't click on active file and click ok to load up CKit.

Today I just single clicked on POIFallForest05 in cell window which doesn't load up the render window. I was able to look at list of objects then in object window I searched each and opened the Preview window to view the objects. No problems, so at least the meshes were displayed in that way.
Then double clicking on the cell. I watched it load up in the render window and after 3-5 secs it will crash. I saw several trees and shrubs and a collision or trigger box show up before crash. Not long enough to see more than that.

Is there a way in xEdit to list all the persistent objects from a particular cell?

Share this post


Link to post
Share on other sites

You probably need to have Steam revalidate your game data. It sounds like you have corrupted vanilla assets.

If that's not the issue, then make sure you're not trying to load assets from another mod because of a forgotten entry in the archive load list for the CK.

Share this post


Link to post
Share on other sites

What Arthmoor said, but don't forget to clean the official masters and not doing that could also cause a CTD.

 

Share this post


Link to post
Share on other sites

That is the last resort - verify cache I mean. I will do it though.. just kinda want to solve this is all.

It is only Skyrim.esm so cleaning masters won't help right now. They are clean from last update. Thank you for reminder though. ( to do it after verify )

Why only that cell ? ... doesn't make sense. I was editing several other cells across the map ( with the More Bandit Camps mod ) then I get to that one nearby the POI and all this happens. Haven't had much time to dig into this... will do more tonight.

Anyway... thank you for suggestions

Share this post


Link to post
Share on other sites
Posted (edited)

Well... I found the offending mod...

Embers HD

In that cell are 2 FireplaceWood01Burning [MSTT:00035F4A] sort of back to back [ edit: they are overlapping ] (to fill the space) in the fireplace of the ruined house. Embers HD does replace that mesh.

But, I can't figure out why it would crash the CK. NifOptimizer didn't flag anything and no mention on the mod page. The esp doesn't edit the M.Static nor that cell.

So random....
Anyway, back to what I was doing before all this...

I'll actually look a bit more to see if I have enough to make a bug report there. Doesn't feel like I do currently.

Edited by Jebbalon
reworded the back to back to overlapping if that means anything

Share this post


Link to post
Share on other sites
Posted (edited)

Okay... final note...

Did another test - with embers installed - I loaded up skyrim.esm only again but without that one mesh. No crash. With mesh it crashes loading that POI cell. Then I went to WindhelmPalaceUpstairs02 (where Ulfric's room is) There are five instances of that mesh there.(not so in ..01 with same fireplaces) No crashes!

What could that mean? The overlapping meshes in outdoors placement maybe casting light on each other? Indoors and placed in separate rooms - though sort of touching in the back to back fireplaces. 

EDIT: I take that back - it did crash when I touched the mesh to look at it in upstairs02 - bad mesh - I guess CK doesn't like it.

Strange! 

Edited by Jebbalon
it does crash

Share this post


Link to post
Share on other sites

Definitely something to report to the mod's author. Crashing in the CK almost always means it'll crash the game too so they ought to want that fixed but they may not know about it.

Share this post


Link to post
Share on other sites

Yeah, I'm going to do that tonight.

Looking at that object in xedit - It is used about 110+ times and the 2 at that POI are the only ones in Exterior world space. All others are inside in fireplaces - Including Riverwood Trader. That's mainly why I'm sceptical, more would report crashes.

I'll try downloading it again, make sure I'm up to date on NifOpt - just to try and give good report before pointing the finger.

Share this post


Link to post
Share on other sites

The fact that they're in an exterior space means they're subject to weather effects so it's not impossible for there to be something wrong with the asset. We once had an issue like this in the unofficial patch where a mesh fix for Labyrinthian would only crash the game if the weather was clear. A random collision rebuild fixed that.

Share this post


Link to post
Share on other sites

That Labyrinthian mesh issue was caused by a bug in the compressed mesh type collision calculations of NifTools which has been corrected in the meantime. If the meshes in question had their collisions built with the latest version of NifTools, there should be no weather issues (and if they have no compressed mesh type collision, it shouldn't matter anyway).

From my own experiences with faulty meshes, the CK is much less forgiving than the game. Thus, the lack of crash reports does not necessarily support the integrity of the meshes. It just tells us that few (if any) users of that mod are doing work in the CK.

About three years ago, I posted a note on frequent FO4 armor and clothing mesh errors. Any mesh with one of these errors still works in the game but crashes the CK immediately [NB: if there wasn't that killer reply by Insane Plumber which basically says that you must be a complete idiot if you allow for faulty meshes being a problem in your game, there might have been replies by other people and a discussion could have been started. Unfortunately though, with that post in place, anyone posting a reply related to the topic would have had to admit that he's a complete idiot too, so it's not a big suprise that nobody did. Let's just hope that this guy doesn't earn his living as a teacher.]

Oldrim behaves in the same way as FO4 in that respect, but SSE appears to be somewhat less forgiving.

Share this post


Link to post
Share on other sites

Interesting.
The mesh in question has a collision that is Convex Vertices shape (also doesn't fit the object) - others in same folder have that Compressed type.
Possible that an old mesh got in there.

Thanks for info. We'll see what the response to bug report is.

Share this post


Link to post
Share on other sites
On 1/9/2020 at 5:28 AM, Jebbalon said:

Possible that an old mesh got in there.

Or the MA for the Embers HD mod wasn't aware of that mesh had wrong collision.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Support us on Patreon!

Patreon
×
×
  • Create New...