Jump to content
Sign in to follow this  
aufisch

MS11 - "Blood on the Ice" - can't interact with clues in Hjerim

Recommended Posts

I just now experienced for the first time while using USSEP the bug that I can't interact with any of the clues in in Hjerim (but I can interact with anything else just fine). I googled the topic and which lead me to USSEP.

USSEP version 4.2.2

How I tested:

Made a hard save from before I entered Hjerim for the first time then:

1) unticked USSEP in Wyre-Bash and let it untick the slew of mods that require USSEP automatically - Result: I was able to interact with the clues in Hjerim normally.

2) re-ticked USSEP in Wyre-Bash but left the slew of mods that require USSEP unloaded - Result: I was not able to interact  with the clues in Hjerim

3) Unloaded all Mods except Skyrim and it's DLC's and the USSEP Patch: coc'ed directly from the main menu to the house of Clan Shattershield - started "Blood in the Ice" by console and brought it up to stage 50 - went and talked to Jorleif about getting access to Hjerim - got the key from the Clan Shattershield lady - entered Hjerim and waited for the message "search for clues" to pop-up - Result: I was not able to interact with the clues

4) Exact same Setup as in 3), but this time without USSEP (only Skyrim and DLC's loaded) - Result: I was able to interact with the clues just fine

I tried looking in xEdit under "cell" but USSEP only seems to change the amulet. Is this an activator problem?

I know that has been a problem before but I thougt that was fixed again? Or did I go somewhere wrong in testing? Unfortunately using the original hard-save with only Skyrim and USSEP loaded doesn't work, as Skyrim then claims that that save-game is "corrupted".

Edited by aufisch
added USSEP Version number, and corrected Result for 2)

Share this post


Link to post
Share on other sites

This is not a USSEP issue at all. There's a thief mod (I forget the name) that is actually responsible for this happening and a lot of people for reasons unknown blame us for it instead.

Your testing approach is also not valid because disabling mods in an active save will break them permanently.

Share this post


Link to post
Share on other sites

Hi Arthmoor, thanks for your reply.

You were (partially) right with the Thieves mod. I have two Thieves-Mod installed ("Opulent Thieves Guild" and "Thieves Guild for the Good Guy"), and if I unload these games the following happens:  although I can not interact with the clues themselves, I can interact with the objects. The chest can be opened as chest, the hidden cabined can be opened, but the Butchers diary can't be picked up. Note that I tested this directly from the Main-Menu, not just from the save I created before I entered Hjerim for the first time.

I understand that testing from a current game can often be unclear (and of course I always continue my game from before I started testing, so that my current save-game has no removed mods). Which is why I tested directly from the main menu (steps 3 and 4 from my first post). I assumed since Skyrim creates a complete new character, that this would be a suitable form of testing? My current character is a female level 49 Breton, but if I start from the main menu a standart level 1 male Nord with Iron Armor gets created. Or did I misunderstand something?

 

I have attached three save-games in a zip:

HjerimBugClues.ess   - from inside Hjerim with my current mods loaded (except the two Thieve Guild Mods) but started directly from the main-menu with a new standard character . Limited interaction with the objects but no interaction with the clues themselves (you were definitively correct about that one of these mods (I don't know yet exactly which one) has a negative influence on the clue-activators)

HjerimUSSEP.ess     - Just outside Hjerim before entering it for the first time. Again started directly from the Main-Menu with just Skyrim, the DLC's and USSEP loaded. No interaction with the clue or the objects themselves (hidden cabinet can't be opened)

HjerimNoUSSEp.ess  - The same as above but this time without USSEP loaded. Eveything works normally.

 

At least that is the situation on my current system, where I have also SKSE mods loaded. I therefore can't completely rule out additional interference or some other form of interaction with USSEP.

 

HjerimClues.7z

Share this post


Link to post
Share on other sites

That was the one, "Thieves Guild for the Good Guy". Unfortunately from what I gather, having that mod installed on the save at all will permanently break the interactions inside Hjerim. There is no way to correct the problem other than starting a new game.

If by testing from the "main menu" you mean using console commands directly from the opening menu screen, don't. That kind of testing is grossly unreliable, especially in quest situations like this. The game will not even have properly initialized your status, let alone properly initialized anything to do with any quests. Hjerim in particular requires the quest to progress properly through several stages before the interior will be correctly enabled to advance things.

Share this post


Link to post
Share on other sites

Thanks again for the info, I still have a clean and 100% mod-free save-game from where I just left Helgen cave. I will try and use that save-game and go to Windhelm to start the quest manually.

Just for info. I did start "Blood on the Ice" by console whenever I tested directly from the menu up until stage 50 "get access to Hjerim", from then on I proceeded manually and the next stage 60 "look for clues" would always trigger normally as soon as I would enter Hjerim. I will let you know what I found tonight.

Share this post


Link to post
Share on other sites

Hi Arthmoor,

I did some 4way testing using a mod-free save-game from my current character (as she just left Helgen cave in a vanilla only game). I teleported this character into Windhelm, then went into candlehearth hall and initiated the quest via console. However, I played 4-times through every step of this quest up to the point where we have to interact with the clues in Hjerim manually, and every single quest-stage triggered normally. My findings are as follows:

- Skyrim Vanilla: everything works
- Skyrim with USSEP only: no interaction possible, neither with the containers nor the clues in Hjerim
- Skyrim with "Thieves Guild for the good guys" only: interaction with the clues works normally and is possible. Only difference was the the guard, guarding the body was walking around and arrived at the crime-scene only after I had questioned the witnesses.
- Skyim with USSEP and "Thieves Guild for the good guys" together: no interaction with the clues and containers possible, and guard arrived late at the crime scene.

This still seems to indicate USSEP as one of factors, as both versions without it work normally and this time no single mod has been removed and Skyrim was loaded properly from a very basic save-game. I have attached all four save-games (just before entering Hjerim with the key I got from Thora for the first time) for you.

HjerimClues2.7z

Share this post


Link to post
Share on other sites

You don't seem to be understanding what you're being told. DO NOT USE CONSOLE COMMANDS. Any results you get from that are invalid and unusable.

You've also been told precisely what the problem is and for whatever reason are refusing to accept this. We don't have time for this kind of blame gaming. Please test things correctly before you try to make this our fault, because it's not, and BOTI works perfectly fine in every single test we've conducted with our fixes in place.

Share this post


Link to post
Share on other sites

And you don't seem to understand a simple scientific principle: If all of your samples are treated the same but you get a difference in the outcome, then that outcome is most likely due to the parameter that is the variable and not due to the completely equal treatement of the samples. And in this specific case that variable has been USSEP whether you like it or not. You also seem to completely ignore the fact that not using the console didn't help me the tiniest bit, when I encountered that but initially.

In a  previous post you complained that nobody provided you with a save-game. So I went through the effort and provided you with a host of save-games, including positive and negative controls, but you refuse to even look at them. Instead you accusing me of playing some "blame-game". Yeah right, I have nothing better to do than spending my time playing four times through the same quest carefully documenting my findings. No you're right of course, it is all just because I absolutely want to blame this on a specific mod. Under no circumstances would I have been happy to find out that something else was interfering and maybe fix it....If you find sarcasm in my last few scentences you can keep it.

....and to think that I actually did this to help you....

 

 

Share this post


Link to post
Share on other sites

There's a reason we're not willing to entertain this type of testing. We've tested it the proper way, numerous times, and regardless of what you or others are going to claim, the results are the same every time. The quest advances as expected and the objects inside the house are interactible without incident.

The only common factor in the failure reports is the thief mod you have already said you're using, which is corroborated by others who have used it as well. We CANNOT be responsible for breakage caused by some other mod.

So we're done here. You insist on being right, even though all evidence says you're wrong. You can keep that if you want. This topic is closed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

Support us on Patreon!

Patreon
×
×
  • Create New...