Jump to content

New small problem - animations/GFX with beta 2.0.8?


Recommended Posts

Hello,

I am back to the game after around 6 months, and have FO4 1.10.138.0 installed, all DLCs, and the latest 2.0.8 UFO4P. I use no mods, except UFO4P and the following DLC (plugin) modules:

  • Chinese Stealth Armor
  • Hellfire Powerarmor
  • X02 Powerarmor
  • Antimateriel Rifle
  • Modular Backpack
  • Armor Paintjobs: Minutemen and Railroad

Load order for the plugins is automatic, the only mod is UFO4P, and it is loaded after the official DLCs. So the installation seems to be fine? I started a new game with UFO4P 2.0.7 and 1.10.138.0, and then updated to the beta version 2.0.8.

My PC: Windows 7 64, 32 GB, GTX 1080 Ti, Driver 399.24. Except the newer driver this is exactly the setup I played with before.

I have a curious problem: Every time I either build a robot (workbench in Red Rocket) or modify Ada, all works well, if I save the game, end the game and later load it up, Ada and the new robot (at this time only Ada and Jezebel, which I just built) have 'lights' at them. After installing the radar beacon on Ada, she had a very intense red light, just like some sentry bots. After building Jezebel an new body both Jezebel and Ada had sparks at their feet. The first case was visible immediately after Ada left the workbench. I saved and reloaded, and this did not fix it.

It is only annoying, not damaging, and it can be fixed by putting the robot into the workbench again, with or without changing something. This seems to fix the effect for good. In the picture added you can see the sparks effect on Ada and Jezebel both, on Ada it is pretty clear. No idea why this happens and as I said it can be fixed by putting the robot into the workbench and releasing it again. I never had this problem before, this is new, either by the new game version and the plugins or an effect of UFO4P.

I do not want to downgrade to UFO4P 2.0.7 but if you want me to, I will try it with an extra save. I also will watch this and report if I find more information.

 

As a side note: The new UFO4P now has very tangible and nice effects, I think because of the script fixes. For example there is now a morse code sound in Railroad HQ near the lady at the terminal, and other things seem to work now much smoother! I am very happy with the UFO4P, thank you for your work!

Bug-Anim.png

Link to post
Share on other sites
  • 4 weeks later...

Hello,

I do not want to open a new thread for this: In my game practically all merchant guards have no clothes, only armor parts. While this is not new, in earlier versions (and with earlier versions of UFO4P) only several guards ran around this way. In the picture I am over level 50, and often the problem corrected itself when the guards also had a higher level, as the entire world levels up more or less with the player.

I always thought, that the reason for this is a sloppy list of clothing, with clothes which cannot be used with armor, and therefore the clothes are not equipped. But now I am unsure. It looks awful - can anything be done? It's not important for the game, but it is a bug I think.

Also - should not their equipment level too? I watch this now with new settlers (who arrive at a new settlement and sometimes even introduce themselves) and with merchant guards: I am quite sure that in earlier games settlers and guard slowly had better weapons with increasing player level. Now they still have pipe pistols and pipe rifles, nothing more. I just did the 'Castle' quest (Fort Independence) and the Minutemen with Preston were really bad equipped, they all had pipe weapons (even Preston!!) and despite trying it several times two of them died always even before the Mirelurk Queen entered the scene. I am quite sure that this also is new, in earlier versions at least the weapons leveled a bit up to combat rifles and combat shotguns. Why Preston no longer has his laser musket is unclear, since he was always in Sanctuary, I never did take him with me and never gave or took from him anything.

I think there is some problem (maybe introduced with one of Bethesda's patches?) with NPC equipment, but only for friendly and neutral NPCs, Enemies have normal leveled equipment.

 

FO4Screenshot20.jpg

Link to post
Share on other sites
  • 1 year later...

In reply to my own topic, a bit late:

I started a new game, latest UFO4P, and latest FO4 version, and use only one mod besides UFO4P, namely 'BetterCompanions'. This is an old mod, but does what I want. I also recompiled the script for this mod with the current CK. Works fine. and does not change a lot anyway.

In my post above I mentioned a problem with the Minutemen Quest for the Castle. They arrived (previous version of UFO4P, latest game version, essentially the same setup as now, only older UFO4P) with pipe weapons - including Preston! As a result only Preston and the essential Minutemen survived.

Now I just did this quest again, with the new UFO4P: This time they arrived with adequate weapons and survived, all of them! So - either I just had bad luck the last time or whatever caused this problem was fixed in the new UFO4P! Just wanted to report this...

Actually the previous version of UFO4P was the only version where it happened. But maybe UFO4P has nothing to do with it and it is random - no idea...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...