Jump to content

"A Night To Remember" Ysolda/Wedding Ring bug.

Recommended Posts

The only mention of the "A Night To Remember" quest (DA14) that I can find in this forum, refers to a much older version of the patch - in which all it does is move the enablement of Moira the Hagraven up to stage 100 from stage 10 of the quest? Things may even have changed since then.

However... I ran into a problem which I think is related, that Ysolda won't take the ring back, and there is no dialogue option to even present her with it.

I suspect this is because the quest has been moved on to a later stage: currently appears to be on stage 135.

How this can happen, is by Persuading, Intimidating or simply paying 2000 gold to Ysolda, doing this skips the "wedding ring" stage of the quest. (Likewise the whole "Rorikstead Goat" stage can be skipped by going straight to Whiterun, or even to Morvunskar... this quest is a nightmare for order-of-operations if things are done out of order.)

The trouble with this is, that you can BOTH talk to Ysolda to ask about your fiancee (unlocking Witchmist Grove) AND persuade / intimidate / pay her (learning about Morvunskar) in the same conversation.

If you talk about the fiancee first, this (a) puts Witchmist Grove on the map, (b) sets the quest stage to 100 and (c) I believe, following the Unofficial Skyrim Patch, enables Moira (without the patch, she's enabled earlier anyway). BUT, if you then persuade / intimidate / pay her in the same conversation, Ysolda talks about Morvunskar at once, setting the quest stage to 135 before you ever went to Witchmist Grove: at which point she no longer wants, cares about, recognises or acknowledges that you have the ring - which is thus stuck in your inventory as a quest item (I assume this status is removed from it once Morvunskar is cleared.)

If you persuade / intimidate / pay first, then Ysolda tells you about Morvunskar at once. The quest stage is set to 135 without ever being previously set to 100, and - as I have discovered - this means that Moira is never enabled in the game at all: not even if you then talk about your fiancee, which adds Witchmist Grove to the map. Using the console to type "player.moveto 1cb38" took me to Witchmist Grove, but there was no Moira, only a plain generic Hag: from which I deduced that Moira was "present but not enabled", tried the two commands "prid 1cb38" and "enable", which caused Moira to appear - and be non-hostile - but she had no dialogue, talking gave her nothing to say, and I had to attack her to get the ring. Witchmist Grove was marked as "cleared" after having done (a) this and (b) killing the normal generic Hag that had been there when I arrived: I am not sure whether both were necessary... She had the wedding ring, and picking it up gave me the Objective to take it back to Ysolda in Whiterun, a quest marker points to Ysolda, but she won't talk about the ring, and the quest stage is already set to 135.

I cannot set the quest backwards with the "setstage" command, nor complete a bypassed objective with the "setobjective " nor complete what appears to be a "bypassed" objective, so I'm stuck with a quest item I can't drop or get rid of, and a quest marker pointing to Ysolda. I assume this will be cleared once I clear Morvunskar, as if I'd gone there and cleared it without ever returning the ring... And this will make the quest completable, technically, but still leave me with an incomplete Objective in the "completed" quest.

I'd suggest a fix, as follows:
(1) Moira should be enabled regardless of whether you persuade, intimidate or pay Ysolda, or do none of those things and talk to her about your "fiancee".

(2) If you get the ring from her, Ysolda should recognise it and take it back regardless of the state of the Daedric quest, if it's possible to arrange for this, and mark the objective as completed.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...