Jump to content

NavMesh issue in cell 30,-14

Recommended Posts

I have been working on OBIS SE and its Patrols Addon and have run into a path with a navmesh that is not connected. It's just a small break in the navmesh but with patrol markers on either side of the break the bandits will turn around and go miles around the mountain to get to other side.

Here is view of the area ... second pic has navmesh editing turned on and I labeled stuff ... third pic is showing only the navmesh, you can see the break better....2446084-1546406916.png

I wanted the patrol to go from Mistwatch north of here (down in the images) then turn up this mountain path and head to Clearspring Tarn and eventually up to Riftwatch Tower.


Instead the patrol hits the markers near bottom of image and continue up to Nilheim, Sarethi Farm then all the way around to reach the markers in upper left of image.


I did try to quickly bridge the gap and this did not work - I probably needed to do finalize and clean up the cell borders. It also created a deleted navmesh as that is an island in lower right corner of 30,-14.

Decided that did not belong in patrol mod so I routed them differently to avoid that path.

Link to comment
Share on other sites

This seems to be a valid issue, although I've not yet looked at the terrain closely. If you join the two, one of them will be deleted (and the other renumbered). I'll try to put together a patch this weekend. There are other problems in this area.

The fix has to be a "link" (select the two adjacent edges and join them). Unfortunately, it has to be done very carefully.

Link to comment
Share on other sites

The terrain is steep in that area but should not pose a problem, the separated navmeshes is more of an issue.

1. Is there an object that can be placed across the gap to link them? Sort of an opposite to the Nav Cut Box.

2. Instead of joining the meshes - what about making them Dropdowns (selecting edges and press 'P' ) ? Might look strange to see NPC jumping there..... but would that work in both directions ? hmm...

Link to comment
Share on other sites

Look at the side of that navmesh. It goes up into the air -- like going up the side of a rock. My guess is this used to have a rockfall across the path, then was changed without updating the navmesh.

Looking at the border with 29,-13, the border vertices are much higher on one side. NPCs often have troubles at those inconsistent heights, they come to a stop. I'd fixed a bunch of those on roads.

This clearly is now intended to be the main path up from the road to Clearspring Tarn. But it's going to be tricky, because all those light and dark blue lines indicate elevations and hiding places (and they are in the middle of the road). So we'll also need to regenerate cover and Finalize. With all those existing ISLANDs, it could be a mess.

Link to comment
Share on other sites

Found the rock, it's of one the few rocks in the area (all the rest of the hillsides are massive static forms), put it back in the middle of the path. There was also a tree stuck into the navmesh on one side, moved it out of the way.

There were also some missing triangles in the path, possibly former trees or shrubs or something, so filled them with a few new triangles.

Put the jump links on either side of the rock, so the NPC movements should seem natural. The rock is placed low enough that the PC can easily walk over it.

Generating cover made almost no changes. Finalizing had no problems. No muss, no fuss.

Of course, looking at the navmesh in the area, it's quite a mess. Lots of mid-air or underground. But we've seen than all over the place. So I've only touched the two that had to be fixed.



Link to comment
Share on other sites

The way you describe it - My guess is that the pathing wasn't working in that area and they moved the rock thinking it was that. Instead it was the rock that probably caused there to be islands in the area that were not connected. Removing the rock didn't do anything but that was what appeared to be blocking the npcs.

Anyway... is there any way I can plug in what you uploaded to test it out ?? Or would it be better to wait for release?

and Thank you for looking into this issue DayDreamer!

Link to comment
Share on other sites

So, I gave it a try and it worked :) ... well sort of...

The patrol coming down the path worked great - they didn't hesitate and it looked really natural as they jumped down that rock.
The patrol going up ( see pic below ) got hung up on the NorthEast side of the rock. They were not able to jump up the rock there. They kept trying though and that is 100% better than them going up around the mountain. Also, I did wait for an hour ( wiat menu that is ) and they made it past the rock and on up the path.

In your image - the double pink lines at the Top is the area where they are in my pic below.
I'm wonder if the jump down can stay there but remove the jump up - I think it is just too steep right there. The other side of rock might be ok but they did not try that side going up the path.



Link to comment
Share on other sites

Ok - that didn't work.
The pretty much stayed at the middle of rock trying to go up. He did several loops back and forth and did move more toward the pink double lines side but never enough to jump up there.
The patrol coming down did fine again. They used that area around the pink and did the jump animation. Returning though they were in same situation as other patrol.

I have a couple screenshots, but I also made a few videos - give me a bit to edit them together into one shorter video showing everything.

I'm thinking it has hard time jumping up. That animation needs to fall across the gap onto the other mesh to work. Going up is hard to get that fall across. Might need to overlap them maybe?

Link to comment
Share on other sites

Video starts with patrol 1 trying to go up path.
Then Patrol 2 comes down the path fine.
Patrol 2 then comes back and gets stuck with 1
I then go up the path out of range and wait an hour - this gets them past rock
Then the Patrol 1 comes back down the hill without problem.

Hope that helps maybe you can see where to make changes.

Thanks again for working on this DayDreamer

Link to comment
Share on other sites

Sadly, although I'd thought I understood navmeshing fairly well, this isn't making any sense to me. They seem to be trying to go up the middle of the rock (where there are no links), but down the side of the rock (where there are links). That upward path has a yellow cover edge, while the downward path has a blue cover edge.

A strict Dykstra algorithm shouldn't be doing that. So the game engine is taking something other than the path into account. Maybe one or the other triangles is too skinny? (I'd tried to move as few vertices as possible.)

I have 2 suggestions.

  1. Try setting the navmesh along the path you want them to take as "Preferred". Just select the triangles one at a time, and press 'p'.
  2. Put the patrol markers nearer the links, perhaps one on either side of the jump. That worked for me with Touring Carriages on some cell boundaries. Jumps use the same table as cell boundaries.

Arthmoor has already put this (presumably v2) into the next version of USSEP. But I'm sure he'd accept some preferred triangles, assuming it worked better. I'm more concerned with followers than the patrol. But the patrol makes an excellent test!

Could you post the patrol here as a separate patch, so that I can test too?

Link to comment
Share on other sites

Given how steep this section of land is I'm not really sure it's going to work anyway regardless of what's being done. The patch you supplied is "good enough" to be able to get followers to navigate up to the spring whereas they couldn't before because that entire area was isolated on a giant navmesh island.

Link to comment
Share on other sites

It looks steep but it's not too steep to stop them. I think it is more they are running into the rock with current version. I did try in game to just disable the rock but that didn't work. The navmesh would have to be lowered I guess.

I also think it is "good enough" - like I said 100% better because they do end up going up the path instead of around entire mountain. With bandits - normal play would not be watching to see them bumping into rocks. I'm probably the only person enjoying watching them run around :) Yeah, no need to stop the presses on next USSEP. (not that you would for this)

Followers would be more the issue and they tend to have work-arounds for getting stuck.

Below is my current files for the Patrols addon - requires OBIS SE.esp from Nexus site version 2.5. Separating out just the two patrols that go there would be ... difficult.

1. Load up everything - use the settings book or MCMenu if you have that to enable the patrols.
2. I use ~ TDetect to toggle detection to just follow them around. They also won't spend time fighting everything along the way.
3. Go to Mistwatch keep (Darkwater Crossing side) - Reset the patrols by making change in settings then wait indoors 1 game hour. (you can turn on debug notices to see that)
4. Head out and you should see them jogging up the path from mistwatch. If you look in xEdit/CKit the patrol from Mistwatch up to Riftwatch Tower is #15 and the patrol from Faldar's Tooth to Nilheim is #19 - they cross on that path.

Thanks again for looking at this

OBIS SE Patrols Addon - for AFK testing.7z

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...