Jump to content
KoruptDawg

[Quest Bug, PS4] The Affairs of Hagravens

Recommended Posts

As opposed to the usual, "I freed Melka after killing Petra", this one's the other way around. I played the Quest as it's intended. I freed Melka, followed her up the tower, helped her defeat Petra, aaand... nothing. The Quest still says to kill Petra; Quest marker still hovering over her body; and Melka just stands there saying her three lines of dialogue. 

I've attempted this the other way (kill Petra then free Melka). Nothing. I've left and come back. Nada. And I've used a resurrection spell on her numerous times, making sure to kill her myself, let Melka kill her, use spells, use swords, and still zilch.

I've even gone so far as to deactivate all of my mods in the off chance that one of them was affecting the Quest, but still no improvement.

I tried using a different character and was actually successful, so I don't have any clue as to why my one character is having issues. I guess it's just bugged on that save? So I'm opting to just not do this Quest for the time being. (so jealous of PC's console commands) 

Note: For any unaware, the Unofficial Patch has indeed recently come to the PS4. Everyone's happy about it.

Share this post


Link to post
Share on other sites

That quest requires scripts in order to fix it, so it can't be corrected on PS4 without Bethesda implementing a patch themselves.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

Patreon
×
×
  • Create New...