Jump to content

Recommended Posts

Wrye Bash encountered an error.
Please post the information below to the official thread at
https://afkmods.com/index.php?/topic/4966-wrye-bash-all-games
or to the Wrye Bash Discord at
https://discord.gg/NwWvAFR

Traceback (most recent call last):
  File "bash\bash.pyo", line 249, in main
  File "bash\bash.pyo", line 412, in _main
  File "bash\basher\__init__.pyo", line 4240, in Init
  File "bash\basher\__init__.pyo", line 4276, in InitData
  File "bash\bosh\__init__.pyo", line 2041, in refresh
  File "bash\bosh\__init__.pyo", line 1780, in _modinfos_cache_wrapper
  File "bash\bosh\__init__.pyo", line 1891, in refreshLoadOrder
  File "bash\bosh\__init__.pyo", line 1887, in _do_lo_refresh
  File "bash\load_order.pyo", line 314, in refresh_lo
  File "bash\load_order.pyo", line 265, in _update_cache
  File "bash\_games_lo.pyo", line 246, in get_load_order
  File "bash\_games_lo.pyo", line 508, in _fix_active_plugins
  File "bash\_games_lo.pyo", line 971, in _persist_active_plugins
  File "bash\_games_lo.pyo", line 394, in _write_plugins_txt
  File "bash\_games_lo.pyo", line 382, in _write_modfile
  File "bash\_games_lo.pyo", line 51, in _write_plugins_txt_
IOError: [Errno 22] Invalid argument

I got this, I don't know how to fix it nor what kind of error it is. Any kind of help would be much appreciated, thank you.

Link to post
Share on other sites
  • 3 weeks later...
  • Replies 2.2k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Sorry, but I kind of abandoned my Wizards years ago.  I had them backed up form the longest time, but unfortunately deleted them at some point (don't remember why).  They may not have even been update

The long wait is over - 307 beta2: 307.201712232300 as usual in the dropbox: https://www.dropbox.com/sh/7b5ily482re0khs/AAD3vAWMVJNIpuS30tsdVte5a?dl=0 @alt3rn1ty all yours Archives ne

307.201711041935 Stablest WB ever - includes changes by @Sharlikran for skyrim records (all the best with health issues!) and some code by @Beermotor (thanks !). Fixes the stuck progress bar. All i

Posted Images

I had installed Wrye Bash before and had saved it into the cloud along with my game and mods because I needed a new laptop. Now, when I try to open it, after re-installing, it says this;

 

Traceback (most recent call last):
  File "bash\bash.pyo", line 202, in main
  File "bash\bash.pyo", line 365, in _main
  File "bash\basher\__init__.pyo", line 4214, in Init
  File "bash\basher\__init__.pyo", line 4250, in InitData
  File "bash\bosh\__init__.pyo", line 2001, in refresh
  File "bash\bosh\__init__.pyo", line 1737, in _modinfos_cache_wrapper
  File "bash\bosh\__init__.pyo", line 1851, in refreshLoadOrder
  File "bash\bosh\__init__.pyo", line 1847, in _do_lo_refresh
  File "bash\load_order.pyo", line 314, in refresh_lo
  File "bash\load_order.pyo", line 265, in _update_cache
  File "bash\_games_lo.pyo", line 245, in get_load_order
  File "bash\_games_lo.pyo", line 485, in _fix_active_plugins
  File "bash\_games_lo.pyo", line 984, in _check_active_order
KeyError: bolt.Path(u'Skyrim.esm')
 

What do I do?

Link to post
Share on other sites
  • 1 month later...

help me 

Traceback (most recent call last):
  File "bash\bash.pyo", line 263, in main
  File "bash\bash.pyo", line 358, in _main
  File "zipextimporter.pyo", line 74, in load_module
  File "bash\basher\__init__.pyo", line 105, in <module>
UnicodeDecodeError: 'ascii' codec can't decode byte 0x89 in position 1128: ordinal not in range(128)
 

 

Link to post
Share on other sites
  • 2 weeks later...

Hi. I just find some weird problem. All my arrows are categorised as bolt, so I can't use them with bows, but when I disabled "Bashed Patch, 0.esp" in NMM all were normal. So I tried to do bash patch without "Legendary Skyrim Crossbow", because I thought that was a problem, but surprise - it was not. So I really don't know what to do. Maybe I should activate/disabled some of the option of making a patch?

Link to post
Share on other sites
3 minutes ago, Okultysta006 said:

Hi. I just find some weird problem. All my arrows are categorised as bolt, so I can't use them with bows, but when I disabled "Bashed Patch, 0.esp" in NMM all were normal. So I tried to do bash patch without "Legendary Skyrim Crossbow", because I thought that was a problem, but surprise - it was not. So I really don't know what to do. Maybe I should activate/disabled some of the option of making a patch?

Never mind, I disabled "keywords patch" and it worked. ^ ^"

Link to post
Share on other sites
  • 2 weeks later...

Wrye Bash for Skyrim SE is failing to boot with this error:

 File "bash\bash.pyo", line 249, in main
  File "bash\bash.pyo", line 412, in _main
  File "bash\basher\__init__.pyo", line 4237, in Init
  File "bash\basher\__init__.pyo", line 4265, in InitResources
  File "bash\balt.pyo", line 110, in GetIconBundle
wxAssertionError: C++ assertion "IsOpened()" failed at ..\..\src\common\ffile.cpp(247) in wxFFile::Tell(): wxFFile::Tell(): file is closed!

The happened just after I had installed wrye bash for LE. Clearly it has at least something to do with loading up icon files. But other than that I am pretty lost. 

I think while I was installed Bash LE, it somehow affected Bash SE (which was already on my computer), and if I remember correctly I think I canceled something halfway, though not sure.

Link to post
Share on other sites

While using the latest version (or whatever version is on Dropbox as of this post) of Wyre Bash for Skyrim, when I check "Reweigh Ammunition" under "Tweak Assorted", it throws an error at me. 

MERGE/SCAN ERROR: Skyrim.esm
Traceback (most recent call last):
  File "bash\gui\events.pyo", line 177, in _post
  File "bash\balt.pyo", line 870, in _conversation_wrapper
  File "bash\basher\patcher_dialog.pyo", line 176, in PatchExecute
  File "bash\patcher\patch_files.pyo", line 241, in scanLoadMods
  File "bash\patcher\base.pyo", line 81, in scan_mod_file
  File "bash\patcher\patchers\base.pyo", line 132, in scanModFile
  File "bash\patcher\patchers\multitweak_assorted.pyo", line 355, in wants_record
AttributeError: 'MreAmmo' object has no attribute 'weight'
 

Link to post
Share on other sites

I'm getting this error when I try to install Wrye Bash for Oblivion. 

Traceback (most recent call last):
  File "bash\bash.pyo", line 263, in main
  File "bash\bash.pyo", line 434, in _main
  File "bash\basher\__init__.pyo", line 4224, in Init
  File "bash\balt.pyo", line 884, in _conversation_wrapper
  File "bash\basher\__init__.pyo", line 3965, in RefreshData
  File "bash\balt.pyo", line 884, in _conversation_wrapper
  File "bash\basher\__init__.pyo", line 3129, in ShowPanel
  File "bash\balt.pyo", line 884, in _conversation_wrapper
  File "bash\bosh\bain.pyo", line 1653, in _projects_walk_cache_wrapper
  File "bash\basher\__init__.pyo", line 3159, in _refresh_installers_if_needed
  File "bash\bosh\bain.pyo", line 1728, in irefresh
  File "bash\ini_files.pyo", line 698, in setBsaRedirection
  File "bash\ini_files.pyo", line 649, in saveSetting
  File "bash\ini_files.pyo", line 313, in saveSettings
  File "bash\ini_files.pyo", line 200, in read_ini_content
IOError: [Errno 22] Invalid argument

Link to post
Share on other sites

Hi!

I don't know why, but since I updated my Bash from 307 to 308 I'm having these issues:

1) I can't import a face from a save anymore (never had trouble doing it. The funny thing is: when I installed my older version - 307 something - it worked);

2) The bashed patch isn't importing some of the mods I use, making Oblivion not start and making the mods not work. Here are the mods:

 - Sword-wielding Flame Atronachs (this makes my Oblivion not start. When I copy and paste the missing data from this mod to the Bashed Patch through TESIVEdit, it works normally)
 - Creature Diversity - Arachnophobia Patch (even having this patch available, I still see these horrible creatures, hehe, and, when I open the Bashed Patch through TESIVEdit, it wasn't there, so I have to do the same process above).

I never had these problems before.

If you guys could help me it would be wonferful!

Thanks!

Link to post
Share on other sites

I submitted all tags that were needed for the flame atronachs mod to LOOT: https://github.com/loot/oblivion/pull/304
So if you update your LOOT masterlist, you should now get those tags and the BP should behave correctly.

As for the Arachnophobia patch, that one is constructed in a terrible way. I uploaded a redesigned version in the comments on that mod page (https://forums.nexusmods.com/index.php?/topic/146209-creature-diversity/page-54#entry92734088), try it with that one instead.

Link to post
Share on other sites
2 hours ago, Infernio said:

@Dom Rafael Could you upload some screenshots of what data needs to be forwarded in TES4Edit? I tried it with the Flame Atronach mod and I only see some spell additions getting reverted.

I gonna do it.

Just hang on  because my savegame broke, and I uninstalled and installed both Oblivion and Wrye Bash again.

I'm installing the mods again. Soon I'll install Flame Atronachs.

Link to post
Share on other sites
1 hour ago, Infernio said:

I submitted all tags that were needed for the flame atronachs mod to LOOT: https://github.com/loot/oblivion/pull/304
So if you update your LOOT masterlist, you should now get those tags and the BP should behave correctly.

As for the Arachnophobia patch, that one is constructed in a terrible way. I uploaded a redesigned version in the comments on that mod page (https://forums.nexusmods.com/index.php?/topic/146209-creature-diversity/page-54#entry92734088), try it with that one instead.

Hmm... Speaking of which, if you can...

There are two mods that, if they aren't put in the bottom of the load orders, they don't work:

Feminized Idle Walk Run Animatitions For NPCS and Better Looking Redguards (and you have to put Feminized down Better Looking.

Any mod that alter/ add npcs invadidates Better Looking, in anyway (some mods work, like AFK Weye, others not - MTC Thieves Grotto, for an example).

Feminized Walk doesn't seem to work with any mod, only Vanilla NPCs.

Link to post
Share on other sites
4 hours ago, Infernio said:

I submitted all tags that were needed for the flame atronachs mod to LOOT: https://github.com/loot/oblivion/pull/304
So if you update your LOOT masterlist, you should now get those tags and the BP should behave correctly.

As for the Arachnophobia patch, that one is constructed in a terrible way. I uploaded a redesigned version in the comments on that mod page (https://forums.nexusmods.com/index.php?/topic/146209-creature-diversity/page-54#entry92734088), try it with that one instead.

Hi Inf!

I've seen the lines in the bashed patch after I installed. Thanks!

But, unfortunately, my game doens't start now, like before without those lines.
I've uninstalled 308 and intalled 307 and voilà: my game started normally again.

What could it be??

Link to post
Share on other sites
3 hours ago, Infernio said:

Try it with the WIP build, link is in the second post in this thread.
As for the two mods you linked, the walk mod needed an Actors.Anims tag (https://github.com/loot/oblivion/pull/305) and the latter already has the right tags in LOOT, and so gets forwarded correctly for me in the BP.

Hi!

What's WIP?

Anyway, I'm gonna check it out.

Thank you very much!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...