Jump to content
Our Domain Name Has Changed! Read more... ×
Sclerocephalus

Overhauling the weapon rack scripts

Recommended Posts

[07/08/2014 - 12:29:07PM] [WeaponRackActivateScript < (000F3122)>]PlaceItem() ERROR:[ObjectReference < (000F31B4)>]; Base = [Form < (0006A0B9)>]; rejected for [WeaponRackTriggerSCRIPT < (000F3126)>]
 

Share this post


Link to post
Share on other sites

Hmmm, then maybe the wall has a bad collision and is masking the top of the sword. Or the collision boxes aren't aligned parallel to the wall. Need to look at the wireframe version next time I'm in CK.

Both problems!

 

The whole room is ShipCaptainsBroken01 [00050E7A] and it has a collision boundary well away from the wall, probably blocking all of the thin sword hilt, certainly the sword blade.

 

Also, its Z rotation is 44.4837, while the Z rotation of all the plaque parts is 44.2554. Not a big difference, but the plaque activator [000de861] and other parts are ever-so-slightly tilted into the wall.

Share this post


Link to post
Share on other sites

[07/08/2014 - 12:29:07PM] [WeaponRackActivateScript < (000F3122)>]PlaceItem() ERROR:[ObjectReference < (000F31B4)>]; Base = [Form < (0006A0B9)>]; rejected for [WeaponRackTriggerSCRIPT < (000F3126)>]

 

That's a Dummy Sword [000F31B4] that didn't change into an actual weapon, so the script rejected the nothingness. It looks OK, doesn't seem to be enabled. Anybody else have an opinion?

Share this post


Link to post
Share on other sites

I've got pretty much the same problem Screwball reported, only for a set of racks in Cutting Room Floor:

[08/23/2014 - 05:18:13PM] Info: [WeaponRackActivateScript < (1002ECD6)>]PlaceItem() ERROR:[ObjectReference < (1002ECD7)>]; Base = [Form < (00020154)>]; rejected for [WeaponRackTriggerSCRIPT < (1002ECD5)>]
stack:
    <unknown self>.Debug.TraceStack() - "<native>" Line ?
    [ (1002ECD6)].WeaponRackActivateScript.PlaceItem() - "WeaponRackActivateSCRIPT.psc" Line 697
    [ (1002ECD6)].WeaponRackActivateScript.CheckRackType() - "WeaponRackActivateSCRIPT.psc" Line 517
    [ (1002ECD6)].WeaponRackActivateScript.ActivatorSetup() - "WeaponRackActivateSCRIPT.psc" Line 283
    [ (1002ECD5)].WeaponRackTriggerSCRIPT.TriggerSetup() - "WeaponRackTriggerSCRIPT.psc" Line 254
    [ (1002ECD6)].WeaponRackActivateScript.OnCellAttach() - "WeaponRackActivateSCRIPT.psc" Line 221
[08/23/2014 - 05:18:13PM] Info: [WeaponRackActivateScript < (1002ECDC)>]PlaceItem() ERROR:[ObjectReference < (1002ECDA)>]; Base = [Form < (0006A0B9)>]; rejected for [WeaponRackTriggerSCRIPT < (1002ECDB)>]
stack:
    <unknown self>.Debug.TraceStack() - "<native>" Line ?
    [ (1002ECDC)].WeaponRackActivateScript.PlaceItem() - "WeaponRackActivateSCRIPT.psc" Line 697
    [ (1002ECDC)].WeaponRackActivateScript.CheckRackType() - "WeaponRackActivateSCRIPT.psc" Line 517
    [ (1002ECDC)].WeaponRackActivateScript.ActivatorSetup() - "WeaponRackActivateSCRIPT.psc" Line 283
    [ (1002ECDB)].WeaponRackTriggerSCRIPT.TriggerSetup() - "WeaponRackTriggerSCRIPT.psc" Line 254
    [ (1002ECDC)].WeaponRackActivateScript.OnCellAttach() - "WeaponRackActivateSCRIPT.psc" Line 221
[08/23/2014 - 05:18:13PM] Info: [WeaponRackActivateScript < (1002ECD2)>]PlaceItem() ERROR:[ObjectReference < (1002ECD0)>]; Base = [Form < (0006A0B9)>]; rejected for [WeaponRackTriggerSCRIPT < (1002ECD1)>]
stack:
    <unknown self>.Debug.TraceStack() - "<native>" Line ?
    [ (1002ECD2)].WeaponRackActivateScript.PlaceItem() - "WeaponRackActivateSCRIPT.psc" Line 697
    [ (1002ECD2)].WeaponRackActivateScript.CheckRackType() - "WeaponRackActivateSCRIPT.psc" Line 517
    [ (1002ECD2)].WeaponRackActivateScript.ActivatorSetup() - "WeaponRackActivateSCRIPT.psc" Line 283
    [ (1002ECD1)].WeaponRackTriggerSCRIPT.TriggerSetup() - "WeaponRackTriggerSCRIPT.psc" Line 254
    [ (1002ECD2)].WeaponRackActivateScript.OnCellAttach() - "WeaponRackActivateSCRIPT.psc" Line 221
[08/23/2014 - 05:18:14PM] Info: [WeaponRackActivateScript < (1002ECE0)>]PlaceItem() ERROR:[ObjectReference < (1002ECE1)>]; Base = [Form < (00020154)>]; rejected for [WeaponRackTriggerSCRIPT < (1002ECDF)>]
stack:
    <unknown self>.Debug.TraceStack() - "<native>" Line ?
    [ (1002ECE0)].WeaponRackActivateScript.PlaceItem() - "WeaponRackActivateSCRIPT.psc" Line 697
    [ (1002ECE0)].WeaponRackActivateScript.CheckRackType() - "WeaponRackActivateSCRIPT.psc" Line 517
    [ (1002ECE0)].WeaponRackActivateScript.ActivatorSetup() - "WeaponRackActivateSCRIPT.psc" Line 283
    [ (1002ECDF)].WeaponRackTriggerSCRIPT.TriggerSetup() - "WeaponRackTriggerSCRIPT.psc" Line 254
    [ (1002ECE0)].WeaponRackActivateScript.OnCellAttach() - "WeaponRackActivateSCRIPT.psc" Line 221

I changed the "Trace" to "TraceStack" so I could see where it was stepping through, but I can't figure out what's going on.

 

The racks I set up are copies of the ones at Alvor's shop in Riverwood. Mine break. Alvor's don't. I don't get it.

Share this post


Link to post
Share on other sites

I've got pretty much the same problem Screwball reported, only for a set of racks in Cutting Room Floor:

The racks I set up are copies of the ones at Alvor's shop in Riverwood. Mine break. Alvor's don't. I don't get it.

Again, it doesn't know how to place a dummy item. Why is the dummy not replaced by a real item? Screwball's was an enable/disable issue? Is this too?

 

I've not been active, as I lost nearly everything in the Michigan 100 year flood disaster. Next week, I could try to get a machine running at my ex's....

Share this post


Link to post
Share on other sites

No idea why it's not being replaced. I copied the whole assembly from the racks in Riverwood and those aren't throwing errors.

 

No, these are enabled by default so it shouldn't be an issue with that.

 

Sorry to hear about the flood damage etc, that sucks. Hope everything works out.

Share this post


Link to post
Share on other sites

Hey all, I am trying to put together some single-weapon weapon plaques, one plaque per each of the nine "Blade/Axe of <Hold>" weapons that are awarded to the player upon becoming Thane. Making nine plaques in CK is easy enough, but I want the activator for each plaque to read the name of the Hold, instead of the default "Weapon Plaque". To change the name of the activator in this way, I have had to duplicate the vanilla WeaponRackPlaqueACTIVATORPlayerHouse nine times (i.e. WeaponRackPlaqueACTIVATORPlayerHouse_Rift), then change the Name field for each one respectively, such that I have 1 unique activator per Hold. I then use the 9 references of the default WeaponRackPlaquePlayerHouse (the trigger), and then use the 9 custom activators.

 

So it will look like this:

WeaponRackPlaquePlayerHouse  >  WeaponRackPlaqueACTIVATORPlayerHouse_Rift

WeaponRackPlaquePlayerHouse  >  WeaponRackPlaqueACTIVATORPlayerHouse_Pale

WeaponRackPlaquePlayerHouse  >  WeaponRackPlaqueACTIVATORPlayerHouse_Reach

WeaponRackPlaquePlayerHouse  >  WeaponRackPlaqueACTIVATORPlayerHouse_Whiterun

 

When I use this setup with the vanilla scripts, everything works ok. In game, each weapon plaque reads the appropriate Hold name so the player knows which plaque is for which weapon.

However, when I test this setup with USKP installed (and thus, USKP weapon rack scripts), it no longer works. While the activator name still reads correctly (as it should, since it is merely the name I entered into the Name subrecord of the custom activator, and is not affected by the script), the activator no longer functions. Meaning, pressing the "use" button has no effect at all.. it seems almost as if the activator is not allowing player interaction.

My hypothesis is that the script is written to only function properly when attached to the vanilla activator. I thought maybe there was a property in the script that needed to be set to point to the formid of my new activator, but after sifting through all of the script's properties, I don't see any that point to the base activator object. So, im not sure if my idea is correct or not.. I'm not experienced enough with scripting to read and interpret everything in the script, so maybe i missed something.

 

So, in conclusion:

- Does anyone know how I can get my custom activators to function properly with the USKP scripts?

- If not, is there a way to get the vanilla activator to display a unique name in-game?

Share this post


Link to post
Share on other sites

- Does anyone know how I can get my custom activators to function properly with the USKP scripts?

- If not, is there a way to get the vanilla activator to display a unique name in-game?

 

Have you created linked references between the plaques and the activators? I believe the USKP script follows those links to determine which plaque belongs to which activator. The vanilla script uses them too, so I wouldn't think it would work (properly) without them... I believe the plaque needs a linked ref with the "WRackActivator" keyword to the activator, and the activator needs a linked ref with the "WRackTrigger" keyword to the plaque.

 

The only other way I'm aware of changing the display name of an activator is through quest aliases. That might be overkill unless you're already using a quest for whatever you're doing.

Share this post


Link to post
Share on other sites

[10/28/2014 - 10:54:07AM] [WeaponRackTriggerSCRIPT < (00102BDB)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:18AM] [WeaponRackTriggerSCRIPT < (00102C2C)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:18AM] [WeaponRackTriggerSCRIPT < (00102C33)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:18AM] [WeaponRackTriggerSCRIPT < (00102C2B)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C23)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C1C)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C21)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C1F)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C19)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C24)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()
[10/28/2014 - 10:54:41AM] [WeaponRackTriggerSCRIPT < (00102C22)>]OnLoad() ERROR: parentCell=[Cell <RiftenHoneyside (00016BDD)>] !IsAttached()

Owned Honeyside for a while but just decided to purchase all the "decorations" in one go. The above would have been from the first time I entered Honeyside after purchasing them.

Not expecting an instant fix (hence reporting them here rather than in Tracdown) - this is just to let you know it's happening.

 

Load Order:-

Update.esm

USKP 2.0.7 (release)

SBBasement.esm

Run For Your Lives.esp (2.0.3)

no killmoves, no killcams, no killbites.esp

 

Share this post


Link to post
Share on other sites

I have dovakin hideout mod installed.  I was having trouble with some items not going onto the weapons racks.  After installing the 4 unofficial mods, i am no longer able to place any weapons on any of the weapons racks in dovahkin hideout.  Any idea where to begin?  I tried to d/l your file but i got an error that it doesn't exist.  What's to do?

Share this post


Link to post
Share on other sites

I know this is an old thread, but I'd like to ask anyway: does the latest USKP actually fix the rack problem completely or is it still not advisable to use them?

Share this post


Link to post
Share on other sites

As far as we know they are all fixed completely. They have been thoroughly tested to work and there haven't been any valid reports for a long time about any of them not working. You shouldn't experience any problems unless you're using another mod that edits them in some way.

Share this post


Link to post
Share on other sites

Just be sure that you exit any property you happen to be in if you're updating from an old copy of the USKP so that the racks will update themselves properly when you come back.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Support us on Patreon!

×